Forums

version 4.3 fixed?

version 4.3 fixed?

I got the notice to update maybe three weeks ago. I set it to update and got a message that it did not. After that i read about issues with walk away locking. My question is has that been fixed? I have a new message to update and since timed charge isn't important to me I but walk away locking is, I am debating doing it.

Anyone done it in the past week with no issues?

Thanks!

Bob W | 4 april 2013

I installed 4.3 at 2 am Saturday March 30th and haven't noticed any new problems with walk-away locking. What was broken?

NigelM | 4 april 2013

The early version of 4.3 (1.25.35) did not always update the security module which meant that doors would not stay locked; heard this was >1% of cars. The roll-out of that was suspended and newer versions without this problem are being rolled out now; according to reports on TMC the latest version is 4.3(1.25.45) and is stable but 4.3(1.25.40) is also out there and is also stable.

NigelM | 4 april 2013

Correction: make that last post "<1% of cars". The rest is correct.

shop | 4 april 2013

I'm still waiting to get any update at all! I'm still in v4.2 that I got from the factory.

cpetrush | 4 april 2013

Got my notice to update yesterday. 4.3 (1.25.45). All is good so far.

bobinfla | 4 april 2013

Well, I hope it's fixed, since it's installing on me right now. VIN 4086.

Wayne3 | 4 april 2013

Has anyone that had 4.3 (1.25.35) gotten an update to 4.3 (1.25.45) without asking? I’ve got the former and am curious if I’ll get the mini-update automatically or will have to ask to get it.

Captain_Zap | 4 april 2013

No need to ask for it. They roll them out in stages. They don't want to make the cellular companies too upset.

DFibRL8R | 4 april 2013

@ Wayne3
Mine got re-updated when in for service today

jjs | 4 april 2013

Updated to 4.3 (1.25.45) two days ago. No issues.

Curmudgeon | 5 april 2013

Updated yesterday.
Everything OK.

edcalis | 6 april 2013

I am still driving on the 4.2 version. It seems TM is updating one car at a time.

jat | 6 april 2013

I upgraded to .45 several days ago and have had no issues.

jdb | 6 april 2013

Not yet fixed. I had version .40 on my sig vehicle, doors were not locking, had to disable the auto present and walk away door lock features. Just got version .45, and still not fixed. Called Ownership Experience, said they needed to call local service center for appointment. Told them not a rush, have gotten used to manually locking and unlocking car with key fob. A little disappointing, but guess that comes with territory of us being early adopters.

alfafoxtrot1 | 6 april 2013

@jdb - I had a problem with a rear handle not presenting. Service had me pull the fuses for the door handles and replace them after 10 minutes. All good since then. It basically forced a reset. Maybe you could try this before taking it in. The manual does a good job of explaining how to reach the right fuses. Good luck.

jdb | 6 april 2013

Thanks alfafoxtrot1. All four of my doors do not lock ever since version .40 downloaded a couple weeks ago. Checked fuses per your suggeston, there is #40 for rear door handles but no fuse indicated for front door handles so guess will wait till service calls.

Brian H | 6 april 2013

jdb;
Have you tried rebooting everything? Sometimes that gets all the parts in synch.

exPGAhacker | 6 april 2013

I have a new issue with 4.3 that has popped up and was never an issue previously. My 17" display screen gets confused at dusk and goes back and forth from daytime mode to nighttime mode. It is rather annoying so I will have service check it out after I try a reboot to see if that fixes the problem.

markapeterman | 6 april 2013

I had problems with the AC fan not blowing hard when needed with .40, but it works correctly in .45.

jdb | 6 april 2013

Hi Brian H. Yes, did the screen reboot more than once to no avail. Have appointment late next week to bring car to service location to see if they can fix door unlock problem.

CarlE_P439 | 6 april 2013

Anyone else have problems with their iPhone app working after version .45 update? Mine is not working at all (worked great before update). Grrrr.

July10Models | 6 april 2013

Ver 4.3 rev~.45
All is good. App display projected miles with ideal label.

Brian H | 6 april 2013

jdb;
I meant both reboots.

rodhoffman | 7 april 2013

I instaled V4.3(1.25.45) at 5:00 pm yesterday and no issues. My iPhone app worked fine immediately following. No issues ever so far - ...P07396 delivery 3/27/13 - flawless!

stuberman | 7 april 2013

v4.3 (1.25.45)
Installed Saturday afternoon (PDT). Everything works fine.

Tâm | 7 april 2013

My problem of walk-away locking appeared immediately after applying v4.3 (1.25.40). I now applied v4.3 (1.25.45) but the problem persists.

This despite of rebooting and pulling off fuse #32 Door Controls, Right Side and fuse #41 Door Controls, Left Side and left them out for 2 hours before reinserting them back and rebooting the 17" console display and instrument display.

I guess the Model S has evolved: Some will be obedient with a new update but on the other hand, some will be mischievous :)

jcadman22 | 7 april 2013

CarlE - My iPhone app worked great until two days after updating to 4.3 (1.25.45). Consequently, the app was updated to ver. 1.1 the day after I got the 4.3 push and it worked until today. The app simply won't take my credentials after repeated tries - correct credentials confirmed thru TeslaMotors.com. I have reinstalled the app a couple times and still can't get in VERY frustrating.

jcadman22 | 7 april 2013

I seem to have lost auto-tilt mirrors with this update. I tried resetting the position today assuming the personalization was lost thru the update but it didn't take. The option doesn't even appears on my settings screen anymore. I have the tech package with textile seats; I will be very annoyed if this is the result of some driver profile cleanup under the new options.

deeptesla | 7 april 2013

I had the same issue with the app. I changed my password to include only alphabets and numbers (I had special characters before). After the password change the app works with email and new password (doesn't work with username).

Brian.S | 8 april 2013

Received my update on 4.3 early saturday am. Door handle issue persists.

stosh3 | 8 april 2013

I got the notice that new version was ready to install but for three days now it says unable to install try again later. Tried manually, tried letting it go overnight to no avail. Called and they said they would check the firmware and push it out again to the car.

hnashif | 9 april 2013

I upgraded on Sat from some variant of 4.2 to 4.3 (1.25.45). No issues to report. Improved heating in the cabin. In fact, I have been saying the global warming arrived to my car. I noticed that w/time charging, if the car was left plugged in for more than a day, it would replenish lost charge on the following night. Also, I noticed that range lost while parked is about half what it used to be (4 rated miles -vs- 8-10). The latter may be due to changes in rated range calculation.

Overall, I am pleased with the update.

Brian H | 9 april 2013

You should be able to tell if it's a range calc change. Watch to see if the remaining range # "stalls" or changes slowly for a while when you start driving. That's a sign of "unreal range loss".

jcadman22 | 10 april 2013

I called Ownership about a few issues I've had since updating to 4.3 (1.25.45) The person that I spoke with confirmed that there have been other reports of disappearing mirror auto-tilt like mine and it should be addressed in the next update. Frankly I'm surprised by the number of 4.3 variants out there. Besides the .35/40/45 versions noted in this thread he said they were running a .23?? version on the display that they use in the office.

Also, the issue with the iPhone app not taking passwords with special characters is a bug and it should be addressed in the next release. Fingers crossed on this one - it's not critical to my life, but it's pretty addictive and such a whiz-bang feature to show off.

Michael39 | 11 april 2013

Jcadman22,
I had the same problem with the reverse tilt disappearing.
I took it to the service center and it took them a couple minutes to enable that feature. They had done several cars that morning.

While a lot of people wanted the timed charge in this release, the much improved fob operation when approaching the car is the best feature of this update.

ddruz | 11 april 2013

@Michael39, What is the much improved fob operation when approaching the car that you mention? Thx.

CarlE_P439 | 11 april 2013

jcadman22- my app worked the following day. It still periodically says it cannot find the car (or just keeps searching forever). I think it's been working about 90% of the time since my car software update. I have the 1.1 version of app as well.

hnashif | 11 april 2013

@CarlE_P439 - I have the search problem on Samsung GS3. I stop the app (using Settings -> Application Manager -> Tesla then Force Stop).

I do not have this problem on other Android devices. It occasionally happens on old iPhone w/iOS 5, for which I stop the app as well and that allows it to reconnect quickly.

jdb | 11 april 2013

Spent 2 hours at Dania Beach service center today to fix door unlock problem, they rebooted nodule with gateway reset, works fine again. First time at service center though have over 4,500 miles on vehicle last 4 months. Actually enjoyed the 2 hour visit, chatting with Tesla employees, great group, asking questions about vehicle service etc. Found out that should be rotating tires every 6K miles or, will be there in about six weeks for the rotation.