Can't connect to Powerwall Gateway on my local network any longer

Can't connect to Powerwall Gateway on my local network any longer

I used to be able to bring up a web page and use the REST interface on my gateway. I had one Powerwall fail, and some Solar City technicians came out to work on the gateway and the sensor leads to gather info on my solar panels. After this the power reported by the Tesla app was incorrect and in addition, I could no longer access the gateway's web page or REST interface.

Today, some other Solar City technicians came out to replace the failed Powerwall and fix the problem with the sensors on the solar panel conductors. Now the Tesla app shows the correct picture of what is happening with the solar, Powerwall and street power. But, I still don't have any access to the gateway interface.

I have used NMAP so verify that ports 80 and 443 are open. Going to either from a browser just results in the browser saying the site is down. Using Wireshark to view the traffic, everything looks normal but the webserver isn't returning any information. I think the gateways web server needs to be restarted. I don't know if I should just try to hit the reset button on the gateway or not.

I'm happy to supply wireshark pcap files, etc.

Is there a better way to reset the gateway's web server.



cwied | 2 oktober 2018

Several people have run into this bug, and the reset button seems to be the best way to restore the web server. Some Gateways have no reset button, in which case you have to turn off all breakers leading to the Gateway for a few minutes.

tesla | 3 oktober 2018

Solved! Well I just decided to bite the bullet and hit the reset button before I read the reply to my original message. Thanks, cwied. After all it's just a linux image and on my linux systems, the web server does stop responding every once in a while as well.



mrbroons | 22 oktober 2018

Same problem here. Power cut and then no access although the App is reporting correctly. I have no reset button (that I know of) so will shut it off at the breakers for 20 mins and then restart.I am running version 1.25.0 software if that helps.

mrbroons | 24 oktober 2018

Still not working I'm afraid.