Forums

iPhone Connectivity

iPhone Connectivity

First, let me say that I LOVE my new Model 3...dual motor, long range...the red with the white interior really is striking...rides so smoothly...acceleration...everything is fantastic!

Everything, that is, except that I'm having a problem with Bluetooth connectivity. Specifically, I can't connect my iPhone X and the Model 3. No, wait...let me better state the problem as remaining connected with Bluetooth. I find that it connects, then disconnects after about 5 to 10 seconds and repeats the cycle endlessly. The only other "symptom" I've noted is that the Summon feature won't work with the phone. I get an error message that talks about the proximity sensor being blocked but the phone doesn't have a case and is literally next to the car. Not sure that the two issues are even related.

I've raised it with Service who nicely tried more straightforward corrections (e.g., forgetting and reengaging the phone multiple times). No luck. They even went so far as rebooting/reinstalling the software on the onboard computer. No luck. The last Tesla Service Rep indicated he would forward the request "up the chain." To be fair, that was only within this past week but haven't heard anything as yet. I sent a message through my account for executive review who referred me back to local service. One of the Service Reps did mention that she had heard other iPhone X users having the same issue but was unsure of the fix.

I've spoken with Apple and went through a number of fixes including rebooting and restoring the phone. No luck. Apple finally speculated that maybe I needed to bring the phone to them for a "hardware fix." I may do that but the phone works fine in every other way and connects via Bluetooth with my other cars.

I have a memory trace about this being a topic on the forum before I got my car but can't recall what people found to be useful.

I so hope that someone has a solution...I really want to talk to my car.

gmr6415 | 2 november 2018

I don't really have problems anymore, but when I was I found the easiest thing to do was go into the iPhone settings, turn off bluetooth and then turn it back on.

You can also tell the car to "forget" the phone, tell the phone to "forget" the car, dump the app off you phone, download the app again, and go through the syncing process all over again.

I can't explain what goes wrong, but for some reason the second option has seemed to fix my issues for quite some time now.

I've also found that when things don't go right opening up the app and telling it to open the front trunk seems to resolve the syncing problem. Who knows why? it just does.

Additionally go into iPhone settings and find the Tesla app itself toward the bottom of the list. Tap on the app and select Location. The select "always".

spuzzz123 | 2 november 2018

Summon has been sketchy with me always. I don't think its ready for primetime. Nor do I think its particularly useful even if it did connect reliably.

First, understand that your phone has separate connections for different functions. You manually pair your phone with the car for cellphone carspeaker use and audio play. But the other connection you have is for you 'phone-as-key'. I only see these when I'm actually near the car -- on my phone bluetooth connections, it shows as 4 similar, but cryptic names. Like "s-43652-fds354". These are for your phone-as-key operations.

I did have a problem with a similar symptom (would connect briefly but then lost its connection). I had my M3 for sev months with no issues. Then I bought a cheap home stereo with bluetooth connection. I connected my phone to the stereo which worked fine, but all of a sudden car connection started failing. I would force connect it, but it would only last briefly, and my stupid home stereo bluetooth would hijack the connection (even after I manually disconnected the home stereo). Finally I had to tell my phone to completely forget the stereo connection. Back in business in the car. Do you have other devices may be interfering? As an experiment could you tell your phone to forget all known bluetooth devices except your car (don't blow away anything you don't recognize)

jithesh | 2 november 2018

I am not an expert but I can just suggest trying these things...

Try using another phone may be friends/family and see if that gives same issue.

Is your phone also connected to some other device while it's connecting to Model 3 ? If so remove the other device and try.

Do u get this issue in a particular location or everywhere? I am only speculating this but certain areas may have issues with bluetooth signals due to interference from other sources.

aperfectecho | 2 november 2018

My connectivity with my Android (Samsung Galaxy S8) is spotty. My wife's iPhone 8 is much better, and has worked without issue.
So....could be worse!

82bert | 2 november 2018

No issues with my IPhone X, for what it’s worth.

I’m sure you’ve done this, but make sure iPhone software is latest update. Otherwise, I agree it’s like a hardware issue with phone.

82bert | 2 november 2018

As an aside, my wife’s iPhone 7s works flawlessly as well.

gbb0131 | 2 november 2018

Never had an issue with my iPhone X (running iOS 11 or 12 betas) or my new iPhone Xs Max (running 12.1.1 beta).

I have noticed that sometimes it isn't as quick to unlock the door on V9, but that's very sporatic.

CharleyBC | 2 november 2018

My phone works as a key 99% of the time. My wife has a much lower success rate, and it seems to come in periods. For a while it works, then it stops and won't for a week or two. Then it works again. We have twin iPhone 6 units. The only other odd thing is her phone sometimes also has problems being a phone--white screen in the phone app. So maybe her phone is getting old and near death.

gmr6415 | 3 november 2018

I forgot to mention that when I was having issues I found that my phone had more than i instance listed as a phone key in the car's menu. They were listed by the date synced although they were all for the same phone. If so dump all but one instance for your phone.

jmgazzano | 20 november 2018

I am having the same issue with my iPhone Xs Max. It will not stay connected and goes on an off every 5-10 seconds only when contacts and recent calls are selected to sync. If you turn that feature off it stays connected. I also connected via bluetooth a samsung galaxy 9s plus and it worked fine, synced recent calls and phone book. I think its an issue with some iPhone X and Xs Max's and I have been told by support that they are aware of this issue and are working on a fix... I have bee in constant contact with them since October.

CorkChop | 20 november 2018

"I get an error message that talks about the proximity sensor being blocked but the phone doesn't have a case and is literally next to the car. Not sure that the two issues are even related."

Um, dude, the "proximity sensor" this is referring to is on your car, not your phone.

When you say it connects and disconnects are you talking about Bluetooth Audio (streaming music, talking on the phone) or your watching the four Bluetooth LTE Beacons fluctuate on Settings > Bluetooth? If the latter, this is expected and not an issue.

We need more information to help you. Can you stream music to your car from your iPhone? What exactly is not staying "connected"?

jmgazzano | 20 november 2018

Ok spent a good portion of today on the phone with Ryan in Customer (tech) support and we went through all the possible things that could correct it, many of which I have already tried. This is with a iphone Xs Max. He escalated the ticket to some software people and he called me back after a while and said another thing to try...... He said to look in your contacts for any symbols, $&@#()* or emojis and remove them from the contact names. I work for an airline and had the plane emoji in there quite a bit. I removed and what do you know it connects, stays connected and the contacts and the recent calls appear now. Hope this information helps. John

kcheng | 20 november 2018

I would check using another iPhone X, in order to isolate the problem.

Rygar | 20 november 2018

I had some emojis in contacts and just removed them. Haven't picked up my car just yet but you may have saved me hours or even days of troubleshooting. Thanks!

jmgazzano | 21 november 2018

kcheng... I did use the wife's Xs Max and it worked. So I knew it was something with my phone, contacts, etc. and not the car.

glenn.smith31 | 21 november 2018

First, I just wanted you to know how much I appreciated the thoughtful responses. It is such a benefit to have the forum! Next, I will say that I tried most of the suggestions. Wish I could say that it was successful, but I remain unconnected. But I did want to response to some of them with specifics, not only because people took the time to offer their recommendations but also because it might assist others in the future:

1) gmr6415 - I tried each of the permutations of forgetting the device on the phone and the Tesla...didn't seem to help. Tried to open the frunk and selected "always" not the settings for the Tesla app...nothing.

2) spuzzz123 - don't see any other competing bluetooth devices

3) 82bert - software is up to date but I did try another iPhone...a 6...which seems to work

4) CorkChop - appreciate your insight that summon is car-based and not phone-based. I'm not able to stream any music from the phone...not able to connect using this function as well. Again, the phone connects and disconnects about every 10 seconds.

5) jmgazzano - no emoji's or special symbols in contacts.

I did have another contact with Apple...more collection of data logs that were forwarded to their programmers. I remain hopeful and will pass on anything I hear from them. Yesterday got an email from Tesla service that they will send a technician out to look at it again. Keeping my fingers crossed!

johnvanoene | 30 maj 2019

I’m not sure whether this has been covered yet, but the solution for my inability to pair the iPhone XR with my model 3 via Bluetooth was to do a hard reset. This is accomplished by holding down both scroll wheels on the steering wheel while pressing down on the brake pedal until the screen goes black. When the system reboots, you should be able to connect your phone via Bluetooth.

wshryer | 11 juni 2019

I have been unable to connect my IPhone since I took delivery about a week ago. I have done everything mentioned, deleted the app twice, turned BlueTooth on and off. Have good internet connectivity and all I see is connection error and the white bar at the bottom says "waking up". i fear it may be in a coma!

alberto.casero68 | 22 juni 2019

I had the same issue with my iphone. Easy peasy... when you know. When you search for your iphone from the Tesla touchscreen, you have to do the same on your iphone by entering the Bluetooth menu and search for (settings, Bluetooth, and scroll down to see the search icon in progress). In a matter of seconds both iphone and Tesla will see each other and a code will appear on both screens, pair on the Tesla Touchscreen and it is all done.

shelle.k.martin | 23 juni 2019

I have an iPhoneX and everyone’s phone in the house works but mine, mind you had car for 2 weeks and was working perfectly until yesterday. I have Donte the reboot and nothing, it won’t even let me forget the device it just keeps spinning?

Super frustrating

FISHEV | 23 juni 2019

I've been having same issues with iPhone7+. Basically have to stand next to car (parked on the street), get out the phone and do the Bluetooth off/on to get car to connect.

I changed the setting in the Tesla app to allow "Touch ID" and for some reason, that seems to have helped. Not sure why as I was not signing into or out of the Tesla app and did not have to enter ID or PWD to open the app on the phone.

Might just be sympathetic magic but who knows, we have dueling iphone and tablet/Tesla with Bluetooth so these issues come with that combo.

syclone | 24 juni 2019

I started another forum topic about this problem before I discovered this one. So, I'll move my whining over here.

Waking the Tesla app on my phone varies in time from almost instantaneous to never. There seems to be no common denominator. I could be 10 feet away from the car or 1000 miles away. It just works or doesn't work according to no apparent set of rules.
Has anybody come up with a reliable solution to this problem?

The problem doesn't seem to be the phone and the car not seeing each other. I just started to charge the car and I immediately got a text from the car that charging had started.
As I have been writing this info, I rebooted the phone and the car connected. Then it disconnected because of inactivity. Now it won't reconnect, even after a reboot. Now I'm getting a vehicle connection error.

I have a iPhone 6S+ Except for one day in almost a year of ownership, I have never had a problem with the phone unlocking the car.