Tesla apps on IOS is not connecting to Vehicle -Connection error

Tesla apps on IOS is not connecting to Vehicle -Connection error

Hi ,
Guys are facing Tesla app problem as its not able to connect to my car and giving connection error
on IOS 12.1 Version

shishirkj | 16 november 2018

Tesla app problem as its not able to connect to my car and giving connection error

murphyS90D | 16 november 2018

Works fine for me.

The standard procedure with a troubled iOS app is to delete the app including all data. Download and configure the app. That has worked for me every time.

shishirkj | 16 november 2018

just tried it but not working still

murphyS90D | 16 november 2018

Is the car in a location where it can connect to the AT&T cellular network?
Your phone connects to a Tesla server and then the server connects to your car.
Both connections have to be working.

Tx633cnh1 | 29 januar 2019

Same here, starting in Jan 2019

tregaron | 30 januar 2019

I have a similar issue - the car will not wake from sleep, all I get is "communication error". I was advised first that it was a hardware (modem) failure, but have just been told by service that there is no hardware fix, and that they hope it will be fixed in a software update. The "workaround" is to unlock the car with a fob, then it can talk to the app after it wakes up - not much use if you are trying to (say) start charging or warm the car remotely etc. out of range of the fob.

bhansen34 | 31 januar 2019

Got a new iphoneXR yesterday. Previous IPhone 6 worked app with car flawlessly. Now despite downloading and deleting Tesla app repeatedly , all I get is connection error. Phone and car both in area with good ATT service. Solution?

jbarnett | 31 januar 2019

@tregaron that makes since as I was attempting to pre-heat the car for my wife as she was making her way down to the car and kept getting "communication error" until the point where I realized she had unlocked the door and got in. What software version are you on? Our MX is on 2018.49.20 and didn't have these issues until after it updated a week or so ago.

dsk79 | 25 februar 2019

Does anyone have any update on this issue. I lost complete usefulness of my app since December 2018. The car seems to go into deep sleep very quickly and there is no way for me to access it via the app. I can see the car during charging sessions, but the moment the charge is complete I can no longer reach it.

Over here in France they say it is a known issues but I they keep saying it is all MCU2 cars which can't be true. My sister has an identical Model X to mine delivered just 5 days before and it still works great for her. It has meant absolutely no preheating in winter and the only way to deal with this is unlock the car and wake it so it then reconnects.

dsk79 | 25 februar 2019

By the way, I noticed the title refers to iOS app. I also tried on an android phone and still have the same problem.

joe.collevecchio | 25 februar 2019

I’m having a similar issue in my 2014 S85, except it won’t even recognize the fob and the result is a totally inoperable car. Can’t even open the doors.

It’s happened 3 times in the past month. The only way to wake the car from sleep is to take the nosecone off and jump the car, setting off the alarm. Took it to the SC, and they’ve said the 12V is fine and they can’t find a problem.

More details in the forum post “Deep Sleep lockout” if anyone’s interested.

taylorgmoody | 27 februar 2019

I had the same issue on the same day, but it's working now.

jaymenon | 28 februar 2019

This is happening to me today. Tried to delete and recreate the app, didn't help. Tesla told me to try again once near the car and try soft reset. If it doesn't help need to call SC

T99dalt | 28 marts 2019

Have a persistent "Vehicle Connection Error" when I open the app. Same as jaymenon above. Have gone through all the same iterations The NAV and music streaming seem to function fine. Car responds and functions normally. However, the web download is abysmal and very spotty. Doesn't even respond to attempts to change websites within the saved Favorites.

p.c.mcavoy | 28 marts 2019

I’ve also noticed over the past couple weeks more vehicle connection errors or difficulty in connecting. This is not only with the iOS app, but with other tools like VisibleTesla which I leave running on a laptop at home to capture data. I’ve not bothered trying to uninstall and reinstall the app as I see this on multiple iOS devices (phone and iPad) and multiple products (Tesla app and VT). I have done multiple resets, both the main display and instrument cluster without any change in behavior.

It has the behavior as if the “always connected” option on my AP1/MCU1 vehicle no longer is active and the car is going into a hard sleep. I’ve actually double checked my settings in the car to confirm that I do have always connected still checked.

Sjmyiii | 20 april 2019

T99dalt, my S is doing the exact same thing. Navigation, streaming, everything working perfectly. App was functional 3 weeks ago and then boom, nothing. It shows I have a S and shows the end of the v/n but connection error to use all the functions. Any advice? I’m about to lose my mind. I’ve deleted app many times, cut phone off, etc.....thanks for any advice from any of you.

EVRider | 21 april 2019

Is it just the app that has difficulty waking the car, or are you having problems waking the car when you want to drive? If the latter, see this related thread:

p.c.mcavoy | 21 april 2019

@EVRider - I'm still on 2018.50.6, so my issues with the iOS app and difficulty connecting are not related to 2019.12 in your related thread. I'm also seeing much poorer performance with VisibleTesla being able to log data unless my car is connected to my home wifi. Makes me wonder if something's going on with cellular connection (even though I'll show decent signal in the car).

EVRider | 22 april 2019

@p.c.mcavoy: When our cars were still on 2018.50.x firmware, we had problems waking them from the mobile app. Once we updated to 2019.8.x, those problems went away. 2019.12 introduced the problem in the other thread to my Model S; the Model 3 is still on 2019.8.5 and doesn’t have these issues.

robertcoleman3030 | 7 maj 2019

My I phone 8 stoped communicating with my tesla 3. When I tap on the tesla app it says error. a network error has occurred.This could be a CORS issue or dropped internet connection.

Azred50 | 27 maj 2019

My iPhone 7 has few problems with my 3 but the S sitting next to it in the garagefrequently throws connection errors. Any ideas?

Azred50 | 27 maj 2019

...both cars are on 2019.16.2, if that matters

pkurland | 28 maj 2019

I had this after the last firmware update. Deep reboot fixed it.

tjdubya | 16 juni 2019

What specifically is a "deep reboot?"

Ohmster | 16 juni 2019

Normal MCU reboot with brake pressed. Hold down both wheels and brake.

cohennona | 27 juni 2019

Model 3 stopped communicating with iOS app over LTE, only connected via WiFi. Rebooting the car (by pressing both steering wheel buttons while holding the brake pedal) resolved the issue.

janmikes | 7 juli 2019

Cohennona is right! Just remember to keep pressing brake pedal and both buttons until the screens go dark AND the Tesla icon reappears.

wshryer | 12 august 2019

I get this waking up but it never comes to?

Chr1stLike | 24 september 2019

I also have the same problem. I loose LTE connection in the vehicle and I get this message that I’m driving with no traffic information. My phone and the car connect fine while I’m at home connected to WiFi. Once I leave the house then there is no connection to the car. I purchase a new phone (iPhone 11) thinking it was my phone. I tried rebooting the car and it didn’t work for me. I tried deleting the app multiple times and deleting the keys and reinstalling and it didn’t work. It only works if the vehicle is at home. So makes me think my modem or the issue is the modem that we all have and not our phones.

LT-M3 | 25 september 2019

I'm having problems with my app as well. It's not connecting at all. I've deleted it and re-install, still not working. I've checked that both the car and the phone has connection. Any other ideas on what else I should do?

OurTesla | 25 september 2019

I would believe that Tesla would provide users options to fix their application / car interface activities.

As a new (first time) owner of a (used) Model S I bought from Tesla's used inventory - I had the car three whole days before the app went tits up and I had to utilize the car display to perform app functionality.

The Tesla delivery guy was useless. After waiting on the support line for almost an hour, their response was to "wait up to three business days" for Tesla's I/T to evaluate and fix the problem. This is not acceptable on any measure. No one believes the app / vehicle interface will be "up" 100% - but I waiting over two business days for the app to become available again and it pissed me off. Any corporate wigs paying attention?

Darthamerica | 25 september 2019

I’ve noticed this since iOS 13 beta. Log out, log back in. Usually works until the next iOS update. Something seems broken with the authorization systems...