Forums

Wrong Tesla linked to account

Wrong Tesla linked to account

I had recently purchased a Tesla and had tried to link my car to my account. After a few days of giving them my information Tesla had contacted me that is was done. When I went on to the app it appears that I have the wrong car linked to my account. The vin numbers do not match up of my car and the one on the app. I can control this other guys tesla from my phone which makes me believe someone has access to my car. I was wondering if anyone else had this problem occur. I have emailed Tesla customer support about this and waiting on a response. If anyone has any other suggestions of what I should do and who should I contact please let me know I believe this is a pretty big problem.

DRFLGD | 5 marts 2019

Right no.

stevenmaifert | 5 marts 2019

Just to be on the safe side, you might want to disable remote access to the car until you get it sorted out with Tesla.

bhanuk99 | 5 marts 2019

I had a situation not quiet like yours but may be somewhat useful to you. When I traded my S75 to S100 end of Dec 2018 I had access to both cars for more than 2 weeks. I talked to them and one of the customer service associate asked me to send an email with VIN numbers, a reason why I am asking them to remove the other (traded) car from my account and include the new car to my account. it took some bugging but they remove my previous car. However, I don't see the loot box on my App now and getting the referral award was another pain.

AnnaSmit | 10 marts 2019

Such failures are not only in such accounts, but even personal bank offices. There is nothing perfect and you have to spend a lot of energy and nerves.

TripleTrucker | 10 marts 2019

I purchased a used S and when they linked it to my Tesla account they linked a second one also. I had access to someone's S near Chicago. If I was evil, I could have theoretically driven that car with my phone app!
I contacted service help email and they pretty quickly removed the extra vehicle. I don't think the other owner ever even knew.

TripleTrucker | 10 marts 2019

I purchased a used S and when they linked it to my Tesla account they linked a second one also. I had access to someone's S near Chicago. If I was evil, I could have theoretically driven that car with my phone app!
I contacted service help email and they pretty quickly removed the extra vehicle. I don't think the other owner ever even knew.

rkham | 8 maj 2019

I'm having problems with MyTesla account but slightly different from yours @DevinDefiore. I was prompted to re-enter my password when opening the mobile app on 5/4/19. After several failed attempts, I decided to reset my password in the Tesla website. After resetting and logging in, my 2014 Model S and 2016 Model X were not there. Instead, a different account information showed up. What showed up was another account I have with Solar City's solar panels. The mobile app however has nothing at all. In 5 years, I've never had an issue like this. Tesla chat support couldn't figure it out but just said that this is a known problem and it will be fixed soon. Anyone else having similar issues?

SnoR | 9 maj 2019

Nothing like that (yet), but when I click the Manage button on my account on the web site I just get a blank white screen. Interestingly enough when I contacted Tesla through chat they said the exact same thing to me -- "this is a known problem and it will be fixed soon"

Kinda wondering if that's what they say to make you go away.

johnszac | 9 maj 2019

@SnoR - I'm having the exact same issue. Sounds like they've got a corrupted Model S database or something. How long has your issue been going on. Mine's been going on for at least 2 weeks, but maybe up to a month.

ignazw | 11 september 2019

For over a week I cannot log into the mobile app anymore: "No products linked to your account."
The mobile worked worked without problems before that. Today at Tesla support they asked me if I also had a *****@*****.no e-mail address. Eh, heck, no. Does that mean my car is assigned to someone in Norway?

Through my Tesla account on the web browser I can see my car, with correct VIN. There, everything seems normal. Except that Johan and Hans have used my referral link. Thank you! But who are Johan and Hans? Vikings?

This type of error is pretty bad! To begin with, it's a privacy breach. But worse, it's potentially life threatening if someone else is able to remotely control the car!

First reaction at Tesla is they will look into it, but it may take several weeks. Several weeks??? This is not comforting.

ignazw | 11 september 2019

Tried to disable remote access to the car, for security reasons as I don't have remote control myself, but that fails because to do that you have to enter your Tesla account and password, but then there is no car linked to the account...

Basically, I can't avoid a complete stranger accidentally or wilfully mess with my car...
Honking the horn at night. Unlocking the car while parked in a busy street. Turning on valet mode with a limited range and speed.

Can't believe this is happening.

EVRider | 11 september 2019

@ignazw: You said earlier that your car shows up on your web account, so the car is linked to your account, it’s just not linked to the app for some reason. You can still use your credentials in the car to disable remote access.

Did you already try deleting the mobile app and reinstalling it? Did you recently change your Tesla account credentials?

NKYTA | 11 september 2019

EVRider, you’ve been very helpful of late. Thanks!

ignazw | 14 september 2019

@EVRider like I said in my second post, I can’t disable remote control due to the same car-not-linked issue. Despite the car showing up on the web. I don’t understand it either, but it’s a fact, and as of today, still reality.

And of course I tried to uninstall and reinstall the app and all other common software nuisances.

The worrying thing is that at the Tesla service center they could see my car was linked to some Norwegian account.

I am quite sure this is some kind of human error on Tesla’s side, transferring the wrong car to another account. But reversing this seems impossible.

EVRider | 15 september 2019

@ignazw: In your previous post you assumed your credentials would not work in the car, but you didn’t say whether you actually tried to enter them — did you?

ignazw | 16 september 2019

@EVRider I wrote "Tried to disable remote access to the car [...]"
So I did try, and it doesn't work. No products linked to my account.
Still the case as of today. (I check every day.)
Both app and car say no products linked to my account.
Only on the web I can see my car, with correct VIN.

It is a weird error but from Tesla I hear absolutely nothing about any progress.

me | 17 september 2019

I'm sort of in the same boat. I bought a 2016 MS 90D on 9/06 and initially the app didn't work when I was picking up the car in Paramus, NJ but it did about 30 minutes after leaving the delivery center. It worked great for about 4 days until it stopped communicating with the car on the 10th. I then tried to sign out and re-install the app and ever since I've been getting the dreaded "there are no products linked to your Tesla account" message. I have the delivery specialists email and number but they keep saying they have to email their IT department with zero ETA's.

This is very frustrating as I cant do much without app access and of course their "support line" just directs you back to the app. I also noticed the website still shows as if I haven't picked up the car yet and I suspect that has something to do with my issue, but it seems crazy that it cant be fixed in a few clicks of a mouse.

I love the car so far but not this service.

tdcondren | 23 september 2019

Lost connection to my M3 early this morning. Website shows my car, but app does not. Car itself says my car is not linked to my Tesla account. Logged out of my app and then logged in, and now the M3 doesn't recognize my phone as a key so I have to use the card. Did a chat with support but he transferred me to a different group and I got a "we're all busy" message and the chat stopped. This is horrible customer service!

EVRider | 23 september 2019

@tdcondren: Try deleting and reinstalling the app, especially if you upgraded to iOS 13 recently. You might have to delete the phone key from Control > Keys and set it up again, and if you had the key associated with a driver profile you’ll need to set that up again too.