Dashcam: USB Drive is too slow to save

Dashcam: USB Drive is too slow to save

Hello ladies and gents,

I updated to the latest software and now all of a sudden the computer says that the USB is too slow to save. It's a "quality" PNY 3.0 stick with 128 gigs of space. It worked flawless before this update. Anyone experience the same issue? | 29 juli 2019

@Mfrilles - What brand? Did you test the write speed on a PC or MAC? 300 MB/s should be way over what is needed. I recommend 20-40 MB/s as a minimum, but most flash drives are only rated at a burst rate. With continuous writes, such as done on when recording video, they bogs down dramatically. Some drives more than others.

ferrett1231 | 29 juli 2019

Similar experience here except mine records 1kb files that are useless. I get no error messages from 24.4, just 1kb size files all properly labeled. My Sandisk Cruzer 128GB worked fine before the update. | 29 juli 2019

@ferrett1231 - Any chance you're in the wrong forum and have a HW2.0 Model S/X? More likely you do have a Model 3. I suggest a reboot and see if that starts things rolling.

ferrett1231 | 29 juli 2019

I hope I am in the Model 3 forum...

I also tried a Intel 128GB SSD and it also had 1kb files on it. I have rebooted the car and formatted the drive, etc. But having tried a SSD shows the issue is seemingly with the new update 24.4. | 29 juli 2019

@ferrett1231 - Ok, I've run out of ideas. Clearly it's not working as it should. Anyone else have an idea?

RoadDevil | 29 juli 2019


In the RecentClip folder, I think files are recycled after a certain amount of time, I saw 1kb files on my micro as card as well, but if I pull out the drive after driving and view it immediately, the video content is there. Also if you click on save while driving, the last video clip is saved to SavedClips with the full video content.

EVRider | 29 juli 2019

Based on what people have been reporting, I think the code to test write speeds is buggy and I hope they fix it soon.

Syed.Hosain | 29 juli 2019

I have this drive (not just a "USB stick") and it works very well indeed! Test at near 400 Mbytes/sec read and write speeds:

I have two partitions on it - first one at 200 GB for the camera (has to be first partition as far as I can tell) and the second at 270 GB for my music files.

shimmy | 30 juli 2019

Been using Sentry Mode since GA release, using two identical USB 3.1 drives, with no issues with write speed, until the 2019.24.4 update indicates that the USB drives are slow. It's been reported to Tesla Service, among other things, and case is still open.

steevsteevsteev | 30 juli 2019

PSA: Some SanDisk drives seem to have an issue where they get really slow after formatting, and since they all come as exFAT or NTFS out of the box, you have to format them. I was using a SanDisk Extreme Portable 500 GB rated for 550MB/s / 500MB/s read/write. When I tested it out of the box, I got close to the rated speeds. Then I threw two FAT32 partitions on it for music/dashcam and plugged it in. I was getting corrupt sentry mode camera saves and just wrote it off as a Tesla problem. However, I decided to benchmark it again and I was now getting about 40/40 read/write. I googled it and I'm not the only one having this issue (see here: I tried the solution listed in the forum and it bricked the drive. SanDisk is RMAing it.

Finoguy | 30 juli 2019

Got the warning message yesterday. Unplugged the drive and plugged it back in—has worked fine since then.

beaver | 1 august 2019

I got the too slow to record error after upgrading to 24.1. Before that I had no issues. I deleted all the files and left the TeslaCam folder. This didn’t work and I got an error about the drive not being formatted properly. After reformatting the drive it started working again. But after 10 min driving I got the same slow drive error.

I have a 128 GB SanDisk with 2.0 USB, which spec is up to 480 MB/sec. Tesla’s manual says it needs at least 4 MB/sec. my drive should be fast enough. Hopefully just a Tesla bug that will be fixed.

ffrr | 2 august 2019

Has anyone found a workaround?

I tried powering off the car, rebooting every time the Dashcam stops working, taking it out and putting it back. None lasted. At parking state, it would also complain that the USB Drive is too slow, which means sentry mode likely is of no use. This is even worse than before where it randomly generated 1KB file, but at least most of the time it worked.

thedrisin | 2 august 2019

PNY USB 2.0 64 GB works fine.

gnusnomis | 2 august 2019

My Sandisk 128 gb usb 3.0 failed after update and sometimes kinda worked but doesn’t record all the time. Just got a no name brand SSD 60 gb and works flawlessly. Seems a lot of people are also having problem with SanDisk. Maybe it’s just a popular brand but could be not compatible with Tesla. The same Sandisk usb sometimes doesn’t work with my iMac.

bruceskarin | 2 august 2019

Hey @TeslaTap, I read your page when I noticed that I was only get the front cam most of the time. I had a pretty slow write drive so I upgraded to the Sandisk Extreme Go and it seemed to be working better, but I'd still often only get video from two of the three cams.

So, I'm not sure if this new warning is fully a bug from the latest update. Instead I think Tesla may have just added a notification of problems with saving all three streams. Why it then stops all recordings, however, is still suspect.

It sounds like others are having the same problem with the Extreme Go. I did just benchmark it again and it still seems to be writing large files around the 40 MB/s mark for large files (screen shot in the link below), but I'd be curious to see what other folks are getting and if anyone is getting all 3 cams all the time with a particular drive and not seeing this warning.

jestrada3 | 3 august 2019

My two cents is that Tesla has had an issues with its USB forever. Yes, some of the issues users are having are related to buying cheap $10 drives on eBay, but there are also just as many people having issues with Quality drives with proper write speeds. I've had multiple USB drives fried while plugged into my Tesla and now I have the Extreme Go recommended by Tesla Tap and I'm getting the same too slow error as everyone else. Really, a USB 3.1 drive with highly rated speeds is too slow? How many other applications other than a "Tesla Dashcam " will it be "too slow" to use? Not to mention that the eject USB option on the car really sucks and is not a proper eject USB option, so the drive gets corrupted any time you need to pull it out. Tesla needs to get on the ball with this, i'd rather have my Dashcam working than playing a driving game while parked somewhere sucking my thumb...

mmcp42 | 3 august 2019

I'm new to all this
Q1 does M3 come with any sort of memory or do you have to supply your own?
Q2 what does the committee recommend as the most suitable?

ta v much!

jestrada3 | 3 august 2019


Q1 - They do not supply any memory for use
Q2 - The jury is still out on most suitable, as you can probably tell by reading through this thread.

EVRider | 3 august 2019

@jestrada3: I agree that Tesla has had USB issues for a while, long before they even introduced the dashcam. Fortunately the issues playing media from USB have mostly been fixed. I also agree that there should be a USB eject feature, but until Tesla provides one, you need to stop recording and wait 20 seconds or so before removing the USB; if you do that you won’t corrupt the USB.

@gnusnomis: I think SanDisk is a pretty reliable brand. Since your USB isn’t working reliably in your Mac either, it’s probably the drive itself. Try reformatting and see if that helps.

efuseakay | 3 august 2019

Been getting this with a usb 3.0 hub, the usb 2.0 splitter cables, and with my 3.1 drive plugged in directly. Doesn’t matter if I’m playing music from it or not. Pretty annoying.

jestrada3 | 3 august 2019

We all need to report these bugs through the car, because Tesla does not moderate these forums.

Amandylynn | 4 august 2019

And I thought it was just me. I threw out my Kingston 32 GB flash drive a week ago, because my M3 fried it. Not sure what happened. It was recording fine for several months, then nothing. My computer wouldn't recognize it anymore so I couldn't try reformatting, which I'd done twice already to try to correct the errors. It's challenging to find accurate specs for these USB flash drives.I bought a Samsung 64 GB 3.0, but I couldn't get it to format to the acceptable formats required by Tesla (FAT32, ext3, or ext4). According the M3 manual, "NTFS and exFAT are not currently supported." So, that new USB became useless.

I miss my Dashcam and Sentry Mode recording, but I don't know if it's worth buying and trying another USB until Tesla pushes out another update to hopefully address these new issues. I came on the forum here to see which USB flash drive I should buy, but it looks like none of them are reliable for multiple people. :-(

Amandylynn | 4 august 2019

I checked some other forum threads and found this helpful video:

I'm getting the SanDisk MobileMate USB 3.0 microSD Card Reader $13 and the Samsung PRO Endurance 128 GB Micro SDXC Card (I didn't know they made ones for high temperature and abuse from the constant recording) for $35. After watching the video, I see I need to download a 3rd party Fat32 formatter to get it to format correctly. With the cost of the car, what's another $50? XD

I'll try this and hope for the best,but it seems like Tesla still needs to correct the bug.

EVRider | 5 august 2019

@Amandylynn: You only need a third-party formatter on Windows, not on a Mac. | 5 august 2019

@Amandylynn - There are three reasons flash drives die - one is longevity - they only handle a limited number of writes. MLC drives handle about 3 times the life as cheaper non-MLC drives. A lot more here:

The second is removing the drive without stopping writes. This can cause the drive to write anywhere and in some cases, trips the read-only bit (which can't be reset). Always turn the drive off first using the dashcam button and wait 10-20 seconds before removal. This is no different than a PC or MAC, but rarely are you writing massive data to the drive upon removal, so the issue is rarely seen on a PC/MAC.

The temp range can also be an issue. My charts of drives include temp ranges.

Ok, you're on the right track going to microSD and adapter. I suggest a few here: I've not heard of any of these causing problems.

As a plus, you can stick these in late model Android phones and view the video through the phone's USB connector

thebunk | 7 august 2019

I have the same problem with my SanDisc Cruzer Fit 64 gb. Interesting that the cheaper 16 gb Sandisc drive I have works fine. Has anyone got any new info on this?

thebunk | 7 august 2019

Also - Does Tesla have anyone monitoring these forums so they can comment or at least take issues back the business?

MattOnLife | 7 august 2019

Same problem, same Sandisk Extreme Go as many others. Can we take a poll of which storage devices people have and whether they are getting the error or not?

Also, for those with Extreme Go’s, did you change to something else and see the problem go away?

jcjoseph | 7 august 2019

What brand and model of thumb drive do you find that works for TeslaCam? 128 GB SanDisk does not consistently work.

HummerMan3 | 8 august 2019

Me: 128 GB Sandisk Extreme USB 3.0 drive with the same error message most of the time since the update.

gmkellogg | 8 august 2019

I was getting this error pretty consistently on 24.4, but since updating to 28.2 I haven't seen it.

EVRider | 8 august 2019

I've used all of the following with 24.4 and now 28.2, and I have yet to see the "low write speed" error:

1. Lexar JumpDrive S75 64GB USB 3.0 Flash Drive (Model 3)
2. SanDisk 128GB Ultra Fit USB 3.1 Flash Drive (Model S)
3. SanDisk MobileMate USB 3.0 microSD Card Reader with SanDisk Ultra 128GB microSDXC UHSI (Model S, replaced #2 with this)

The reason I switched from #2 to #3 in the Model S was because people were having better luck with SD cards in general, and it will be easier to view the microSD card on my iPhone or iPad once iOS 13 is released this fall.

Note that in both cars I'm also playing USB music from a separate SanDisk Ultra Fit 64GB USB 3.0 Flash Drive whenever we drive.

matthew.a.cain | 8 august 2019

After discussions with Tesla, this is the answer I received:

Prior to the 24.4/28.2 updates, Tesla was unable to alert the drivers that their drive was occasionally dipping below the recommended 4mb/s write speed and thus unreliably recording video. Now, it shuts off the recording if it senses a dip below 4mb/s in write speed, such as to encourage the driver to better equip with a better USB drive with a SEQUENTIAL write speed CONSISTENTLY above 4MB/s. I didn't have an issue with my 2.0 USB drive prior to the update, but I admittedly didn't look back on all my data, and it is possible that I often was writing incomplete or corrupted video files. I'm upgrading to a better drive in hopes that it fixes the issue, as it does not seem like this is necessarily a bug that Tesla is going to "correct" anytime soon.

HoustonM3 | 8 august 2019

I'm using a Transcend Jetflash JF780 150MB/s write speed USB drive and get the same error. This is a top tier USB drive, if not the best on the market. There is no way it's the drive. Tesla has a problem that needs to be fixed ASAP.

MattOnLife | 8 august 2019

Sounds like some people have seen it go away with 28.2, hopefully they push that out to my M3 soon and we’ll see. @HoustonM3 I agree, Sandisk Extreme Go has peak 150m/s and should get at least 30-40m/s sustained sequential, I think the error reporting in 24.4 is over eager on some drives for some reason

raqball | 8 august 2019

I have 28.2 and a Samsung T5 SSD (500gb) I have not gotten any warnings since I updated. I would love to have those warning though including that the drive is full.. Anyone know if those warning are still there in 28.2?


Cswp4555TesM3 | 8 august 2019

My M3 SR+ is currently on 24.4.

1. Transcend 128GB USB
2. Patriot Supersonic Rage 2 128GB USB
3.Samsung microSDX UHS-I Card Pro Endurance 128GB withSD adapter used with a VANJA USB card Reader/Writer/OTG Adapter

I have formatted and used all of the above and keep getting gray pixelation when viewing videos from Dash cam and Sentry mode. Dash cam videos are fine while driving but when the car comes to a complete stop or is parked and recording with Sentry Mode on, the videos show mostly gray pixelation.

I put in a request to Tesla Service, they requested photos and videos and below is the partial response:

"After reviewing the videos and photos you sent as well as vehicle data logs, the gray artifacts in the video are from the USB device and not the vehicle. These will show up on videos when the write speed of the USB is too slow when car computer is recording the video to the USB device. Tesla recommends using a USB storage device formatted to FAT32 (windows) or MS_DOS FAT (Mac) with a sequential write speed of 4mb/s or higher. Most commonly we have seen much success with customers who have a version 3.0 or higher USB drive.

USB stick you show does appear to meet the minimum speed requirements per its listing, keep in mind the write speed of USB sticks is recorded at room temperatures, and heat can have a negative effect on transfer speed I have seen where if the storage device gets hot the write speed can lower due to the heat, this could be one affecting reason for the gray artifacts."

I just got notification for update 28.2 and will do a soft reboot after installation and see if that solves the problem.

louie.lacsamana | 8 august 2019

I noticed that when using more than 32GB. Even formatted properly to fat32 it crashes after a while. I bought SanDisk 32GB Ultra Fit USB 3.1 Flash Drive. I've been using it for a while now and it works well. Got it for $6.

x-sparker | 8 august 2019

For those of you asking for a workaround/solution: I highly recommend switching to a high endurance microSD card with an adapter.

I, too, started using my Dashcam at first with the SanDisk Extreme Go 3.1 USB flash drive (64gb). It worked fine for five months, until, like everyone else, I started getting that "write speed too slow" warning (around July 24, which looks like it was the date when they pushed the 24.4 update). I honestly thought it was my fault because I did accidentally pull the USB out without pausing Dashcam on one occasion previously, when I wanted to review footage. I thought I had bricked the USB. I also noticed that over 5 months of leaving the USB in and barely ever checking it/cleaning the files up, the combination of Sentry Mode and Dashcam footage had eaten up about 50 gb of the space and I was left with about only 12 gb. After looking into it a little more, I decided to switch to using a high endurance microSD card with a USB 3.0 adapter, and with higher capacity to hold all that footage. This combination has worked perfectly ever since, even while I was still on 24.4, and continuously to the present update to 28.2. Here is what I used (the two items combined costs only slightly more than the flash drive of that capacity):

I tried to get SanDisk to RMA the flash drive but they refused out of claiming that flash drives like the Extreme Go are not meant to be used for continuous read/write functions like dashcams and video surveillance. I haven't yet tried to use it in the car after updating to 28.2, but if it's true what other people are saying about the warnings going away, I might just keep the flash drive as a backup. I'll try it tomorrow and see if I get any more errors.

x-sparker | 9 august 2019

Reporting back: SanDisk Extreme Go 3.1 USB still getting "write speed too slow" error, even on 28.2. It worked fine for the first 20 minutes when I drove to work, but when I came back to the car at the end of the day, the warning was right there when I got in (sentry mode was on all day). So this USB is toast.

MicroSD card + adapter method mentioned above still works perfectly fine, although I have only done footage review on that once so far. No missing clips or artifacts in video that I can see, unlike with the flash drive.

spiderx1 | 10 august 2019

I tried several but the Scan Disk Ultra worked so far, 3 days, 128GB, came formatted in FAT32, just added the TeslaCam folder. I was getting ready to reformat and I noticed it was already FAT32.

beaver | 10 august 2019

My 128 GB SanDisk v 2.0 still won’t work with 27.2, “drive too slow”. So I switched to a 32 GB drive and it is working fine so far for a day.

beaver | 10 august 2019

Sorry meant 28.2

anuragkumar | 10 august 2019

I am having the same issue with PNY 128GB 3.0. It was working fine before the latest update, I have many videos recorded. Also bought SanDisk 128GB Ultra Fit USB 3.1 Flash Drive - SDCZ430-128G-G46 from Amazon, this one Tesla refuses to even recognize, even it is FAT32 and has the TeslaCam folder

Hp.1193 | 10 august 2019

Told as many ppl I could. This flash drive works flawlessly. I just picked up another today just in case for backup if my drive is full on a drive and need another. Have been using it for 4 months and had zero issues.

thedrisin | 10 august 2019

PNY 2.0 works great. Maybe problem is using USB 3.0 in 2.0 port.

Neutroniker | 10 august 2019

A couple of comments after trying multiple solutions to get reliable sentry mode videos. And before I begin, a shout out to for providing a wonderful, in-depth write-up of potential solutions.

First, I found that every single step in the chain matters, and in-between components can slow down the read/write speed. I used a short USB 2 cable to avoid having a long USB drive hanging out of the port. Resulting videos had a lot of green bands or splotchy video. Changed the cable to a quality USB 3 and things improved. I tried a microSD card solution and that was better than the USB drive I was using, but still not perfect. Then I swapped out the microSD USB reader with a faster one and that greatly improved the video quality (it's the solution I use now). Oh, and I'm not sure now but I think that I tried going through a USB hub at one point and abandoned that because of the poor results.

Second, I discovered the usefulness of testing potential solutions against each other. Thanks to a suggestion here, I use the Blackmagic Disk Speed Test app to compare solutions against each other. You can select 1GB up to 5GB test file sizes. The advertised speed of drives can bear little relationship to test results. For example, the 128GB SanDisk Extreme Go USB 3.1 was not working well for me. Sentry mode videos were splotchy. I tested with the Blackmagic Disk Speed Test and I watched the high write speed plummet quickly from an initial 66 MB/s down to 1 MB/s with these large files. Read speed was 140-160 MB/s. This app is also how I was able to diagnose the slow microSD card reader that I was using. The basic one I started with provided 9 MB/s write speed and 15 MB/s read. A higher speed Anker microSD reader upped that to 50 MB/s write, 80 MB/s read. These last two tests were conducted using the same 64 GB SanDisk Extreme SDXC 150 MB/s microSD card. Oh, and I should state that microSD cards are very consistent in their performance regardless of whether they are writing 1 GB or 5 GB test files, which was not true for the USB drives that I tried. I don't know what specification to trust at this point, but at least I can tell whether something new is an improvement over what I was using before.

I am now using a short USB 3 cable, Anker Model AR200 USB 3 card reader, and 64 GB SanDisk Extreme SDXC microSD card. Sentry mode video quality is good now on all three cameras. If I decide to go with a bigger microSD card at some point, I will go with one of the suggested ones that can handle high temperature.

MattOnLife | 10 august 2019

Anyone tried the OWC EnvoyPro SSDs in a Tesla? I’m thinking of getting the 480gb to replace my 128gb Extreme Go as everyone is saying 28.2 doesn’t fix it so maybe it’s just true that it’s not fast enough. Those Envoys are supposed to be some of the fastest drives around I think?

calvin940 | 11 august 2019

I use the 256gb SanDisk ultra fit with no speed issues.