Blank release notes for v10 and subsequent updates

Blank release notes for v10 and subsequent updates

I have a 2013 P85 and every release starting with v10 has had empty release notes. The release notes page comes up on the center console, but there is nothing in there. When I navigate to the release notes on the center console, it comes up blank there too.

Has this happened to anyone else?

Is there another place I can see the release notes?

murphyS90D | 10 november 2019

The release notes are not stored in the car. You have to wait for them to download from the Tesla server.

Bighorn | 10 november 2019

Yes--they presumably are bug fixes with no new features.

jordanrichard | 10 november 2019

Chunk Jr. , yes that has recently been happening to my ‘14 MS85. It seeming takes for ever for the release notes to appear and that is even when sitting in my garage connected to my home wi-if. Ever since getting V10, I have had maybe 3 other updates and each time the release notes screen was blank. Since it took all of only 20 minutes to install, based on experience, I figured it was juts a bug fix and if the notes did appear, it would list anything different from when V10 got installed.

EVRider | 10 november 2019

If you google the version number you can usually find release notes online, but they might vary depending on your model and configuration. | 10 november 2019

@Chunky - Blank notes happen to me as well. It does not matter if I'm on WiFi or LTE, and bringing up the notes page and after waiting 5 minutes, still no notes - just blank. I haven't alerted Tesla about it yet, but I guess I should.

It started back on some V9 release, so V10 didn't start the issue. I wonder if it is an MCU1 vs. MCU2 issue? I have MCU1 as do you.

In the past when it worked, if it was just bug fixes, you'd at least get the last set of notes. | 10 november 2019

Ok, I sent off a bug report to Tesla via comments.

If others have the problem, would be good to hear if you have MCU1 or MCU2. (MCU2 are in all cars made 1-March-2018 or later).

Bighorn | 10 november 2019


Salagubang | 10 november 2019

9/2014 Mod S85. Latest software Version: 2019.32.12.7 b728e1d. Release notes: blank. I assume I have MCU1.

cmichael | 10 november 2019


Thanks for working this with Tesla.


Did you request that a message that reads "no feature releases and click for additional information" be used? This would be preferred instead of a blank page which makes one think WiFi or LTE, or the software update is distressed imho. | 10 november 2019

@cmichael - No, I just requested that it work. Good idea though! It might be worth a few more sending bug reports to Tesla (not via the car). I suggest using the contact under your account, Manage, Request Help, and I used "Feedback".

Chunky Jr. | 10 november 2019

Thanks TT (and others). It does sound like a bug.

It's not unusual to have no release notes for an incremental update, but I didn't even get any from 9.x to 10.0. I have no idea what's new for P85 w/o auto pilot, or if there is other subtle changes that might be useful for me that I don't know about.

Chunky Jr. | 10 november 2019

@TT : how can I check which version of MCU I have? I've had mine replaced several times and now I have LTE instead of 3G.

Tropopause | 10 november 2019

MCU1 same issue for me.

haysenator | 10 november 2019

Yes, this has been happening for me for a long time. I've told Support a few times, and they seem to think it's just me. It's not that there aren't valid notes, it's just annoying that initially that morning a blank white screen is displayed. I can go to the Tesla screen and find them, but it's a stupid bug they should fix.

bhanuk99 | 10 november 2019

MCU 2. Not blank-I see release notes with each update tho it is the same for 36.1 and 36.2.1 | 10 november 2019

@Chunky - I'm 99% sure you have MCU1 if you upgraded to LTE. You can run my MCU tester. In the car's browser, type:

jordanrichard | 11 november 2019

Mar 2014 build, definitely have a MCU1, and as I mentioned above, I get the blank screen for very long periods of time when bringing up the release notes.

bsteinesq | 11 november 2019

This may be just a one-off occurrence, but after I downloaded 36.2.1 to my 2017 S (MCU 1), I could not access release notes using the "release notes" link that pops up under the Tesla logo at the top of the screen (have not been able to for several updates)---and I let it sit for 10 to 15 minutes to see if it would download. I was on solid fast wi-fi. Finally, I used the quick controls menu (the car at the display bottom), then "software" and then "release notes" and after a second or two, the release notes came up. YMMV | 11 november 2019

@bsteinesq - Good idea. I tried it and no joy (with 5-bars on WiFi). I noticed the browser was also dead (would not load any site). Maps and traffic show fine. I'll try it later today when I'm out driving.

reed_lewis | 11 november 2019

Release notes are displayed using the web browser which as we know with MCU 1 cars, does not work at all in V10. Sometimes a full reboot will get it back for a while, but it usually is never working.

Chunky Jr. | 11 november 2019

@ bsteinesq : that worked for me, too. thanks for the tip!

blueridger | 15 december 2019

Release notes have been blank for me for several months. I tried rebooting the system as well as powering down the car multiple times. Waiting for extended periods of time does not work either. Hopefully Tesla will acknowledge and fix this defect soon. It is not a huge deal, but it is very annoying that Tesla cannot fix something as simple as release notes.

Peter C | 16 december 2019

The MCU1 web failures appear to be due to resource exhaustion. I managed to restore it this time by clearing all navigation history items, then a 4-minute power off, start, restart of MCU, then changing map tiles from aerial to roads only.