USB drive too slow, have Mac? Problem fixed

USB drive too slow, have Mac? Problem fixed

Tldr: use Mac reformat security level 5 to get that too slow drive working again.

I thought I would share this as it worked for me. I had a lexar USB stick 128gb it worked fine then after a firmware update a while back it would get that too slow error. Well, I reformated and tried, till the error. Then on the Mac, I tried the security reformat, 3. And still it failed, I didn't want to do the level 5 cause that takes hours. In the end I used security reformat level 5 and the USB stick works flawlessly with 2019.36.2.1.

CST | 13 november 2019

Given that just removing the drive and replacing it often solves the error, I doubt this is a reliable fix.

EVRider | 13 november 2019

I’ve been using a Lexar 64GB USB in our Model 3 for almost a year, and today I saw that “drive too slow” error for the first time. Updated to 36.2.1 a few days ago. I removed the USB and reinserted it, and it worked again. I don’t think the formatting makes any difference.

texxx | 13 november 2019

I've had the "USB drive too slow" a bunch of times after the 2019.32 update and removing and reinserting the drive fixed it every time. Yesterday I switched to a Sandisk Extreme Pro and we'll see what happens. That drive has 380MB/s write speed, so if the error returns it won't be because of write speed.