New Model 3 AWD LR delivered with SW 2019.35.106 and Acceleration Upgrade Issue

New Model 3 AWD LR delivered with SW 2019.35.106 and Acceleration Upgrade Issue

I just picked up my Model 3 AWD LR yesterday, it is a 1/20 build and noticed it has SW 2019.35.106. Unfortunately this means I can't purchase and use the Acceleration Boost upgrade. How long does it take for the new SW to be updated ? I have Wifi in the garage and have it setup on the car. I have also scheduled an appointment with the local SC to upgrade the SW. Is this something they can actually do?

Finally, I have also noticed my drivers side lumbar support does not work so I hope to also have it addressed on the same day at the SC. It is rather unfortunate to have these issues on a 24 hour old car but I am loving the Tesla experience!

rmg007 | 14 februar 2020

Wait a minute. You are loving the Tesla experience, but complaining that you have an issue because your software hasn’t been updated in the 24 hours that you’ve had the car?


FISHEV | 14 februar 2020

"It is rather unfortunate to have these issues on a 24 hour old car."

It is. Kind of lame they don't do all the updates before delivering the car.

Steve-3LR | 15 februar 2020

Did you get your update yet? I've had my Model 3, built 2-20 according to doorjam, for 9 days now and still no update. It's running 2019.35.106. I have excellent full AT&T signal, and full strength WiFi in my garage with an EERO. Tesla tells me it's the latest software for my VIN. I read on some website that 2019.35.106 specifically released late January. I have no idea what is going on - I purchased full FSD, but have no visualization access.

hcw5733 | 15 februar 2020

Steve-3LR, i'm in the same boat and no update yet. I did schedule an appointment with the SC to see if an update could be pushed and also to address the non functional drivers side lumbar support. Based on what I read on other forums there might not be much we can do but to sit back and wait! I actually initially purchased the acceleration boost via the phone app which does not warn the user about the min requirement of 2019.40.x. I have since requested a refund and will just re purchase once this thing updates! I'll keep you updated.

dnlhardee | 16 februar 2020

I was here searching around to see if anyone else had mentioned taking recent delivery with old software. I took delivery 2/14/20 for my SR+ and even before I left was disappointed I was missing the latest software features. I tried the tapping the button 5 times in software section on car trick and got a weird soft reboot but no update. I also have 2019.35.106 and don’t have any WiFi in my condo basement so don’t have much hope of getting an update anytime soon.

DiminishedSeventh | 16 februar 2020

@dnlhardee a few options you could try:

• Use your phone as a hotspot and have your car connect to WiFi that way (you’ll probably only want to do this if you have unlimited data)
• Try to connect to an open WiFi network or drive to a local library or Starbucks or something with free WiFi. If you’re close to a Service Center, they should have an open WiFi there as well

I think my car took about 5-7 days before it got registered in whatever system Tesla uses to push its updates and it received the latest update. I know it’s hard to wait, sorry. Hope you’re enjoying the new car!

BruceLee | 16 februar 2020

I find that if you use the phone app and select SCHEDULE SERVICE, and then SOFTWARE, and then UPDATE, you will either receive a text message or the update starts to come through in a few days as long as your car has a wi-fi signal

sheldon.mike1010 | 16 februar 2020

I read about and tried parking next to a Tesla service center for 30 minutes. Have done it twice when software seemed behind other's.
Both times within 24 hours the software installed thru my home WiFi. Worth a try if SC is nearby and you have the time.

dnlhardee | 16 februar 2020

Those are some good ideas. Thanks.
I remember mention of the app for service, but I have a mobile appointment to fix an interior trim issue we scheduled at delivery. Maybe I’ll try the app after my appointment on 2/20 if I’m still not having any luck.
Mobile hotspot won’t work for me and most open WiFi networks I’ve tried it gives me an error that they require a log in or approval page that the car does not currently support - or some error like that.
And unfortunately our nearest service center is an hour away. Fine since mobile seems to serve us well. But not so good for mooching off WiFi.

I’m absolutely Loving the car. Red with white interior. Took 2 months to get it. But was worth the wait considering I’d already been waiting years to get a Tesla. Cabin cool alone is worth it. It’s already been in the low 90s since I got it. In Florida with the humidity thats not very comfortable. Especially in my work pants and button up/tie.

DiminishedSeventh | 16 februar 2020

You could try asking a downstairs neighbor if you can connect your car to their WiFi? Otherwise what I’ve done is run a powerline adapter down to my underground garage to get WiFi down there. You could also try range extenders.

Since you have a service appointment already, see if they’ll update for you there. Explain your predicament and they should help. My suggestions above would be for going forward. 2 hour drive to get a software update would be a no-go!

g.alhundi | 19 februar 2020

Don't hold your breath! Picked up mine on Feb 8, 2020 and still on 2019.35.106. When I booked a service appointment, my excuse being I wanted the new voice commands, the tech ran through the usual wifi signal blah, blah, blah ultimately he said the following...

"Currently your vehicle is on the lastest firmware version which is available for your vehicle. The newer version which has the voice commands will be released to your vehicle soon. The wifi connection you currently have is plenty for regular firmware downloads when they are available. Thank you for your patience in this matter."

Don't I believe Was there anything he could have done about Will I get it eventually...yes, but only God knows when! :)