Tesla App does not connect to Powerwall

Tesla App does not connect to Powerwall

About 2 days ago my Tesla App would come up with an error when I tried to connect to my Powerwall. After reloading the App and logging back in today I am not getting error but not getting any power flow indications and it constantly appears to be trying to connect. I called help desk and all they did was make me reboot my wifi which did nothing and then pushed it to "tier 2" help desk. Any one have any ideas?

richstone | 3 november 2017

I have just had a tesla 2 installed and I can't get onto the app to view my solar usage

glenn | 4 november 2017

Mine was installed yesterday & worked perfectly, then today it's the same as you guys. It says "Standby", and can't view any usage, or power flow indications.
It sounds like something is wrong on their servers. Hope the PW2 itself is operating as it should.

glenn | 4 november 2017

Actually... I just rebooted the gateway (cycled the circuit breaker), and it came back online a few minutes later. I did read someone else having issues with the gateway crashing a few times a week, and needing repairs.
Hopefully it doesn't happen again to me.

agiangone | 5 november 2017

Maybe something was wrong with their server because it seems that yesterday's values were doubled. Both usage and generation.
Anyone else?

gordonallanhead | 10 november 2017

10th Nov. Everything ok at 7:30 am but when checking at 11:00 app giving a connection error with a reference to one of the solar systems (we have 2 ). Switched off and on AC for solar system and gateway - still no connection - internet obviously working (I'm logged on to enter this).Any thoughts?

harrye | 12 november 2017

If you are using the 'phone App v3.2.1 it seems to have connectivity issues. Stop/start the App again.

troftas | 12 november 2017

Mine was installed on 25th September. Installer did not get it commissioned that day and in fact Tesla Support got it going remotely on 20 th Oct! Now wall is working well but app is not displaying correct info and I am trying to get installer back to check metering connections.
At least I am not paying for electricity at the moment

heiko | 16 juni 2018

I have the PW2 for a few weeks now. All fine until yesterday when the app did not connect anymore: "Home Energy Gateway: Unavailable" and "Powerwall Connection Error".

Stuart.Sutherland | 27 august 2018

Hi all, PW2 installed but the app has always noted that the Gateway is on standby, how do I get this to move from Standby?

cwied | 27 august 2018
dicemanlp | 17 september 2018

Help, changed router/wifi password and I cannot get my PW2 to reconnect to the net and I get "site connection error" on my app.

Shygar | 17 september 2018

Can you plug an ethernet into your powerwall backup gateway temporarily? That should get you online so you can login to the customer login and update your wifi password. You would need to go to it by using the IP address in your web browser once you plug in the ethernet between your router and your backup gateway. Or you can just email or call customer support, but they might take a little while.

elbe5050 | 14 januar 2019

My PW2 stopped communicating with the Tesla app.
It was fine at 2:30PM this afternoon but nothing since.
No errors just tries to connect but cannot.
Tried to call Tesla support but hung up after around 15 minutes.
Will try again tomorrow.
The PW2 seems to be working but without the app connecting I don't know what its status is.
Any suggestions would be much appreciated.

craybeard | 5 februar 2019

I've been experiencing this problem intermittently since mid December. Tesla support pushed a new firmware in December and followed up with a phonecall to confirm that my Power Flow data in the app was showing. It was. Then it stopped again in January. We were in the middle of one of the best "solar" days in our area, Mid Atlantic, since our system was installed in Nov/2018. Being an impatient data geek I went to the backup gateway, opened the cover, and used a screwdriver to press the reset button. That solved my immediate problem but I suspected the problem would happen again. It happened again in late January and then again twice yesterday evening and once again today.

Power Flow data comes back online every time I press the reset button. That said, I don't think one should have to reset the gateway so often so I called Tesla Support and have been elevated to the next level of support. I was told that they would probably schedule a site visit and to expect a call in a "couple days."

My gateway is connected via Ethernet CAT5e to a switch, which is connected to my router.

philp0286 | 15 februar 2019

Mine is which I downloaded from appvalley app store :) here is the official appvalley site to get download working Tesla app.

Justaguy | 18 februar 2019

I had to uninstall the app from my phone, reboot the phone, and reinstall the app. Then it worked.

david | 18 marts 2019

I've tried deleting the app, rebooting the phone etc etc.

Anyone have any solutions to this recurring problem?

jghooper | 18 marts 2019

My app intermittently fails to communicate with my beautiful Powerwall 2.
This is may last for a few hours and in some case days,
I am on the NBN here in Australia. The router is functioning and seems from checking to be working fine.
(Browsing the internet to check)
This situation happened again today. Just annoying when you pay for such a beautiful product.
Any suggestions please let me know.
Kind regards and thanks, John

annthorn | 19 april 2019

I have exactly the same problem John. I'm also on the NBN in Australia and for the last 5 or 6 months my connection to the powerwall 2 was intermittent. For the last 4 or 5 weeks it hasn't connected at all.. Did you get any ideas from your post? I've tried rebooting the wifi, the phone,reinstalling the app and nothing works.Would be grateful for any ideas..

annthorn | 24 april 2019

An update. Had a very helpful phone call from Telsa Customer Support last night. They talked me through connecting directly with the gateway via the IP address.from the laptop. After a couple of hiccups it connected and displayed the the home energy use. And interestingly, the phone app started connecting again. Am monitoring it to see what happens over the next few days. A big thankyou to customer support

stupidnenu | 29 maj 2019

TutuApp which is an alternative to all the App Stores, be it in Android or iOS.

johnofficial012 | 12 august 2019

tutu app is a good alternative of app store and play store which provide paid apps to to download for free

ankittricksking | 5 september 2019

I had to uninstall the app from my phone, reboot the phone, and reinstall the app. It worked for me you can try as well

Thanks & Regards

michaelsballiro | 8 september 2019

I have repeatedly contacted Tesla support and have always received back a polite e-mail alerting me that Tesla would get back to me as soon as possible. A month later I have yet to hear anything except the auto response. I have since given up. I can no longer see any data on my desktop related to my energy consumption or usage. In the past I had used this data to illustrate to newbies how they can track the benefits installing solar panels. I can no longer do this, but at the same time I am no longer sure I would recommend this particular provider if one wanted to install solar panels. It might be better to go to a source better able to support their products.

gregbrew | 8 september 2019

The old saying about the definition of insanity comes to mind. Why do you repeatedly use e-mail when you get no response?

CALL them!

(877) 961-7652

lafavifoy | 11 september 2019

The old saying about the definition of insanity comes to mind. Why do you repeatedly use e-mail when you get no response?

dllopp | 23 september 2019

I had the issue with my app not connecting to the Powerwall
The only thing I tried was signing in & out of the app, which didn't work.
The next morning the app was functioning
Now, less than a week later my Model 3 will not connect to app.
I've signed in & out of app, checked that Bluetooth is enabled and I have rebooted car by holding down two steering wheel rollers, neither worked.
Has anyone experienced similar

elizabethbrown2240 | 24 september 2019

Same issue. we are working on. Finding for some instant solution.

dllopp | 24 september 2019

No solutions you've found?
Was router table link a mistake - did you mean to provide something different?

chrisbailey13 | 25 september 2019

So, My app shows the PowerWall's disconnected, but when I look at the flows and the history I can see the powerwalls are being charged and discharged. I can also see the powerwall activity from the browser.

Is this the same behavior you are all experiencing?

dllopp | 26 september 2019

Yes that was what I was experiencing at first but the following morning the Powerwall information started working.
Now my M3 won't connect.
I've turned phone off & on, closed & reopened, deleted and reinstalled the app.
And - the enable app is turned on in the car.
I think those are all recommendations that I have heard and although I find dialogue on the app not functioning properly with Powerwall I haven't found much about it not connecting to the car.

dllopp | 26 september 2019

M3 connects to app now, maybe a result of charging car

chrisbailey13 | 1 oktober 2019

Question: Is this happening on IOS and Android?

I have an Android device

gregbrew | 1 oktober 2019

The Tesla app has worked flawlessly on my old Galaxy Note 3 (running Android 5) since the turn-up of my Powerwalls in early February of this year. I don't own a Tesla vehicle.

tom8814pol | 3 oktober 2019

Lucky Patcher Apk is one of the best apps of all the users you can easily Modifying apps and games for your devices. There is no extra material required to download this app.

paul | 3 oktober 2019

I just had Powerwalls installed at my house. After being able to see the power flows for two days, the Tesla app suddenly stopped showing me the flows. Also, the Walls are listed as "Standby" on the app even though they should either be charging or discharging as I have the Powerwalls set to power the house at night and recharge during the day.

I spoke with my installer and he determined that the Neurio device, which measures the flows, may need to be reconfigured. Apparently, it was originally configured to use my network to contact the walls. The installer is going to come out and reconfigure it so it is hardwired and will no longer use the network which for some reason was kicking it off.

Hopefully this will solve the problem.


zoomerdog | 8 oktober 2019

I lost connectivity via the app to my PWs yesterday. No power flow. Nothing. I've rebooted them and still nothing. The Power Walls have their own WiFi signal (TEG-XXX); which allows me to bypass my router and log in directly. That too is dead.

gregbrew | 8 oktober 2019

I had the same thing happen to mine after a short grid loss. Nothing from the system reporting side (via the app) during the loss, but the system itself was up and running just fine. Even though I could connect the the TEG WiFi WAP, I got nothing but a blank screen. No explanation, no error indication, it just didn't work at all.

The reporting part came back to life after a day or so. I would have worried more about it if the PV and PW system itself was acting wonky, but it wasn't. It was functioning as designed. Weird.

zoomerdog | 9 oktober 2019

Solution for my issue. When I said earlier that I "rebooted" the system, I meant that I simply flipped the breakers off and on. The solution was to hit the "reset" button in the gateway. I used a pencil. Works perfectly now.

Regarding gregbrew's issue above, I've not experienced that, yet. You might try hitting the "reset" button if it happens again

hughbie | 10 oktober 2019

Similar experience as @gregbrew during the big PG&E public safety power shutdown. Solar and PWs functioned fine and kept electrons flowing during the grid shutdown. But was unable to monitor Powerwall status and energy use. Biggest load is my Model 3, which can be managed but knowing the PW status is important to success. Seemed to need the Internet to work, although the Gateway and Tesla app devices all use the home WiFi router. Grid is back up now and PWs showed 75% charge after overnight use. Shouldn't need the interwebs for the app to work, should it?

gregbrew | 10 oktober 2019

Unless you connect directly to the TEG's WAP, you are dependent on the Internet to get your data to and from the Tesla servers. I connected directly to the TEG's WAP, and I still got nothing. (My home's 'net backbone is backed up with an UPS, in addition to the PWs.)

If it happens again, I'll try re-initializing *everything*, including opening all of the breakers, shutting down the inverter and PWs, which should shut down the TEG. I'll re-initialize by closing all of the breakers first, then start up the PV with the switch on the inverter (which should start the TEG) and then turn the PWs back on with their switches, and see what happens.

Heck, I might even simulate a grid outage by opening the Main, to see if I can repeat the symptoms I saw previously. One problem with doing that is that it's really hard on breaker contacts to open them when current's flowing through them. Arcing can leave carbon deposits on the contacts. Not good.

erik_peterson | 14 oktober 2019

Mine stopped working on October 10. I have Tesla solar, power wall, and model 3. It still works great for the car, but can no longer swipe over to get solar and battery data. I do see power wall marketing material however. I submitted a support request but am still waiting to be contacted with help from Tesla.

gregbrew | 15 oktober 2019

By far, the best way to communicate trouble to Tesla is via telephone. Trouble tickets and e-mail responses are exceptionally slow...if you get any response at all.

When you call, do *not* select "other issues" at the voice prompt. If you do, you'll end up in "Hold Purgatory".

ankittricksking | 21 oktober 2019

If you are using the 'phone App v3.2.1 it seems to have connectivity issues. Stop/start the App again.

l4xrp | 17 november 2019

PPSSPP Gold APK is one of the most popular and best PSP emulators for android. With the help of this emulator -

Citigg2019 | 28 november 2019

Thanks for your information, it's very good to me. Please visit the store of useful Seo tips and Marketings:

gregbrew | 29 november 2019

Where are the freaking moderators! This spam nonsense is completely out of control, and making this forum practically unusable. I've seen on other threads that a couple of users have reported the spam to the moderators, but *nothing is happening to correct this mess.*

What gives, Tesla?

ct.ggmedia | 3 december 2019

A helpful question, I'm waiting for an answer

rahul | 18 december 2019

Great loved this.