Cannot Schedule Service Appointment through Tesla App

Cannot Schedule Service Appointment through Tesla App

I am having issues scheduling an appointment through the "Schedule Appointment" button on the Tesla App.
This problem has just started about a week ago. I have booked 4-5 appointments before through the app with no issues.

Expected Result:
1. Open Tesla App
2. Click "Schedule Appointment"
3. Enter appointment details

Actual Result:
1. Open Telsa App
2. Click "Schedule Appointment"
3. See loading screen for "Looking for appointments"
4. See loading screen for "Getting appointment details"
5. Loads details from a previously completed appointment. There is no option to schedule new appointment.

I have tried the following things with no success:
- Restarting my Android device
- Signing out of the app and signing back in
- Clearing Tesla App cache
- Reinstalling Tesla App

I have not been able to reach Tesla customer service regarding this issue. I tried following the the customer support links on the website, but it only takes me to the FAQ, which doesn't give me any useful information. I have tried e-mailing but received an auto-reply stating that the e-mail address is no longer monitored. I have tried calling my local Tesla service center (Vancouver), but any appointment-related query gets an auto-response to "use the app to make an appointment".

I am running the most up-to-date Android version of the app: 3.10.2 (8bd2dc0ef).
Any help you can provide on this matter is appreciated.

normtoystoys | 12. Dezember 2019

Sounds to me like your cellphone app is "pinging" you and Elon is "ponging" you.

andrebowen | 12. Dezember 2019

I have this exact same issue, using the Tesla app on an iPhone.

edow | 12. Dezember 2019

Yep, same problem. Cannot schedule an appointment through the app.

rehutton777 | 12. Dezember 2019

Possible fixes: Make sure you have the most current phone app (V3.10.2). Delete app and re-install.

surfpearl | 12. Dezember 2019

Sorry to hear. My app is the same version as yours but works fine, was just recently able to set up a service appointment.
How far is your local Service Center in Vancouver? Make it a fun trip and have a side visit with them in person, schedule your service and inquire about the app issue. If that's not an option, get a carrier pigeon :)

chaomon | 13. Dezember 2019

@rehutton777, I've already tried those steps and more. I think it's something on the Tesla side.

@surfpearl, I do plan to go to the Vancouver Service Center when I get the chance. The tricky part is that my issue is related to a leak that is happening when it rains, and finding a day that isn't raining in Raincouver is not exactly easy ;)

The last service I booked was a mobile service, and they tried to fix the leaking issue that I had. But the problem still occurred so I tried to book another appointment. That is when I ran into this problem.

jodyhess | 13. Dezember 2019

I've got the same issue. I've logged out and back in, turned phone off and then back on and deleted and reinstalled most current phone app. No such luck. Apparently this is the only way to schedule an appointment. I'm at a loss.

amodp123 | 13. Dezember 2019

Same here in SF Bay Area! Can't see the option to schedule service appointment in online account, and the app link shows old appointment with no way to schedule new one! Tesla, pl fix ASAP.

chaomon | 13. Dezember 2019

I found another e-mail that was referenced in an older discussion thread:
I e-mailed the address with the issue to see if I'll get a response. At least this one did not immediately return with an auto-reply saying that the address was no longer monitored, however I'm not holding my breath.

yangjian888 | 10. Januar 2020

same problem. tried multiple times. no luck. also no customer service available for help. very frustrating...

fras | 14. Januar 2020

Same problem here, using iPhone

wvisser | 14. Januar 2020

Same problem here..... on Android

patrick1120 | 14. Januar 2020

same problem on iPhone

stingray.don | 14. Januar 2020

Do you have the latest app version - V 3.10.3?

jackting88 | 15. Januar 2020

same problem on iphone. app version 3.10.3

suryakumarirajt | 21. Januar 2020

same problem on iPhone

lilbean | 21. Januar 2020

Same problem on my flip phone.

regi_jose | 27. Januar 2020

Same problem here - cannot cancel/reschedule. "Getting Appointment Details" message stays on for a long time and then Errors out. Tried all other options mentioned above too. At a loss!

carlosirney | 27. Januar 2020

After 3 days traying to get an appointment and no look calling the service center and using the app I was able to do it thru the app on January 10 then I receive an email and a text message with the confirmation of the appointment for January 29 2020 at 14:00, Now the application shows that the appointment is for January 30 at 2:00 pm, and I am unable to verify wish one is the correct one, the schedule service on the app in no working any more, I get “looking for appointment” then “Getting appointment details” and noting happen, calling the service center is impossible.

NwPlaneflyer | 27. Januar 2020

Same problem. Very frustrating! Can’t get a human...

mps331 | 27. Januar 2020

I was just about to send an inquiry regarding the same issue, I did send an email to the support page, but it says 2-3 days response. The app is useful, if it works, future scheduling is unfortunately blocked with the old appointment.

I have not tried calling, as I have tried before. any help will be appreciated.

I also have logged off in the app and logged back in, but still blocked.

thank you

mps331 | 27. Januar 2020

To Chaomon - I tried the email address, but it was undeliverable. fyi.

thank you

LostInTx | 27. Januar 2020

Interesting - I was able to schedule a tire rotation using the app. The silly thing is that you have to make an appointment with a service center, though I know full well that tire rotations are handled with the mobile units.

Sure enough, as with previous appointments made with the app, I received texts from a real person saying the appointment has been canceled and rescheduled with a Mobile Unit. We discussed via text (2-3 hour lag time, but whatever) and we found the best time for me.

That service appointment with the Mobile Unit is now seen from my app. All this was done this past Friday.

Version 2019.40.50.7 ad132c7b057e
Galaxy S9

mps331 | 27. Januar 2020

Update: during my recent service01/18/2020, they sent me a text with confirmation and that was how I communicated with them for that particular request; anyway, I notified the person thru the same text number (today, as I have another service request) and informed him, I cannot schedule a service thru the App as there was a previous request; he responded a few minutes later and said, he had clear my previous request appointment. after which, I was able to place my schedule service request, just fyi...