Forums

Unable to connect to Wi-Fi

Unable to connect to Wi-Fi

Although my Model S connects to my home WiFi router without any problems, it will not connect to the WiFi router at my workplace.

The SSID appears in the list of available networks, and the signal looks okay at 3 bars. Attempting to connect via the list of available networks gives an error message saying unable to connect. Trying to connect via the Settings dialog, where I explicetly type the SSID, returns an error saying check the network name. This happens for each of the security options available.

My Android smartphone has no problem in connecting to both my home and work networks, so it looks like something related to the car. Technical support tell me that the router is using channel 9, so I am wondering if it is related to that.

Does anyone have any ideas?

Thanks in advance.

tes-s | 12. März 2018

My guess is signal strength. Is there a reason you want to connect to the wifi?

Anthony J. Parisio | 12. März 2018

I found the Requirements part of the article very helpful. Thanks EVRider!

Alan75DUK | 12. März 2018

Thanks for the link. I have checked everything described. I see that the guide says 'The Tesla hardware support bands 1-11' Given that the destination router is on Channel 9, that should be ok as well - So the mystery continues.....

It does occur to me that there is more than one router broadcasting the same SSID for the one network. The second router is further away and provides a very weak signal (checked using a laptop computer) but using channel 13 which is not supported by Tesla. Could that be the cause of my problem? The IT support people have refused to change the channel of this second router, so I cant see how to eliminate that possibility.

Alan75DUK | 12. März 2018

Thanks for the link EVRider. I have checked everything described. I see that the guide says 'The Tesla hardware support bands 1-11' Given that the destination router is on Channel 9, that should be ok as well - So the mystery continues.....

It does occur to me that there is more than one router broadcasting the same SSID for the one network. The second router is further away and provides a very weak signal (checked using a laptop computer) but using channel 13 which is not supported by Tesla. Could that be the cause of my problem? The IT support people have refused to change the channel of this second router, so I cant see how to eliminate that possibility.

Alan75DUK | 12. März 2018

tes-s: I am sure that the signal strength is adequate. The router to which I am trying to connect is just the other side of a window, and all measurements show at least 3 bars.

Connecting to Wi-Fi whenever possible is recommended by Tesla in the user manual on page 128. This will be the preferred route for receiving updates when I am away from my home network.

tes-s | 12. März 2018

Good luck with it. There is no need to connect via wifi except in places where there is no cell service and you want the car connected. Updates can be received via cellular.

hammer @OR-US | 12. März 2018

Tesla's Wifi will only connect to a mixed G+N network. If your work SSID is set for "N-only" then it wont connect. This is addressed in TT's article but it is way down in the notes.

TeslaTap.com | 12. März 2018

Another check is if you're near a sales/service center is to just drive nearby and see if the car picks up the Tesla WiFi. If that works, it rules out any technical issues with the car.

JayInJapan | 12. März 2018

I had the same problem after my car’s system locked up post-update/hard reboot (last summer). Ranger came and reset my car (thanks!), and I could not reconnect to home wifi. I also had a thread last year about not being able to use the Design Studio on any devices at home. @EVrider advised me that it was probably in my wifi router.

Due to those issues (and others), I went back to our cable company’s internet service a couple of weeks ago. All is now well again. I would suggest checking into your router’s set up.

tes-s | 12. März 2018

@TT - connects to his home wifi with no problem, so unlikely it is an issue with the car.

I have a bridge that will connect to my wifi network, but won't tether to my phone. My computer connects to my wifi and will tether to my phone. Is it a problem with the bridge or the phone that they won't work together? Some network devices just won't play nice with each other - regardless of standards.

Alan75DUK | 12. März 2018

Thanks all for the responses and suggestions.

hammer: I had missed the point about G+N protocols so will check that out when I am next at the office on Thursday.

Made in CA | 12. März 2018

I know the Model S wi-fi does not allow special characters in the SSID or the password. I had to the change the password for my home wifi because it had an apostrophe.

Alan75DUK | 12. März 2018

Thanks Made in CA. The password is just regular upper and lowercase characters and numbers.

Attaran | 12. März 2018

@Alan75DUK: I know this won't necessarily help you, but it's good to know for reference. You are not alone dealing with WiFi issues!

My October 2017 build model S100D refuses to connect to my Asus RT-AC68U at home. It has no problem connecting to a Netgear R7000 sitting in the same spot. Both routers are configured almost identically. No other device I have has shown this issue, and I have many devices! (VeraPlus, Nest, Alexa, FireTV, Roku, iMac, iPhone, MacBook Pro, Surface Pro, etc).

I read in one of the threads that having DLNA devices on the wireless network could cause this, but I have not tried removing devices from the network one at a time to see which one is causing the issue.

For now I'm using the spare Netgear router and all is well. One of these days I will do more troubleshooting to actually root-cause this.

Alan75DUK | 13. März 2018

Attaran: Thanks for your support.

As part of my investigation I have discovered a lot of information online about two Wi-Fi routers providing access to the one network via the same SSID. Go and google it.

The summary seems to be that the two routers should be linked physically via an Ethernet cable, with one configured as an extender to the other Primary router, They should otherwise be configured *identically* except for using a different channel. Remember that Tesla only supports channels 1 to 11 even though in the UK, and maybe other parts of Europe, other channels are available.

Hope this is of some use.

Attaran | 13. März 2018

I'm in the US and use different SSIDs on my routers and have tried different channels, forced 802.11B only, forced 802.11G only, 802.11B/G only. The car sees the Asus router but refuses to connect to it!

So my temporary solution (until I find time to fiddle with it more) is to connect the Netgear router to one of the ports on the Asus router and have it only serve the car while the rest of the house/devices are all connected to the Asus.

AIA304 | 15. März 2018

TeslaTap,
Nice wireless app, one possibility to consider is add type of WiFi connection is currently being used; a, b, g, n, or ac.
Reason? If said Access Point for wireless supports multiple connections, the connection can change as different mobile devices connect and disconnect.
Example, the AP will change speed/connection type to “slowest device” which connects on that AP. Which means if someone connects with an mobile device which only supports an “a” type connection, the entire AP drops everyone connected down to match the slowest device.
Thanks for listening

TeslaTap.com | 15. März 2018

@AIA304 - Thanks. Great Idea, but I've not found a way to extract the connection type. Some of the hardware details are never made accessible to an app, at least that I've been able to discover.

dbork | 15. März 2018

@Alan75DUK You should change your WiFi channel to either channel 1, channel 6 or channel 11. Please take a look at this article. Channel 9 is just going to create interference with both channels 6 and channel 11. https://www.metageek.com/training/resources/why-channels-1-6-11.html

AIA304 | 15. März 2018

TeslaTap,
Try finding the MIB; Management information Base, for wireless AP. This MIB and snmp application is required to “get and set” parameters which provide detailed info from devices that support SNMP,simple network management protocol.
There is lots of information to be gleaned from servers, desktops, routers, bridges, switches, and mobile devices, etc , etc...
The get and set abilities is protected by passwords which default are public and private, but can be changed.

Alan75DUK | 15. März 2018

dbork: I have no choice regarding WiFi channel. I am told that channel 9 has been found to get least interference from other nearby but unrelated WiFi networks.

More generally, today I have run into some local politics about connecting my car to the network. I do not understand the reasoning, but hey-ho, I am just an end-user and what do they matter!!

For now I seem to be at a dead-end, but if I get any headway on the wireless protocols (n, g, etc.) I will be back with an update.

Thanks everyone for your input.

tes-s | 15. März 2018

Most business networks are now 802.11ac (maybe some older ones are still n) with auto-channel switching, and the slowdown to b speeds when a b device connects was resolved over a decade a go. It is also very unlikley there are any b or g devices connected.

I don't think the channel or some b device is the issue.

ravisundaramam | 24. November 2018

It is a signal strength issue. Confirmed. Got my TM3 in May. Never could connect to home wifi. My cell phone can, and its hotspot can connect to TM3. But TM3 would not.

Finally yesterday bought a WiFi range extender, (happens to be a cheap netgear 750, about 50$). Installation was painless. Made sure extender works with my chromebook. Went to TM3, as soon as I touched the icon the new network SSIDs popped up. It never showed the SSID of home network before. Entered the password and it connected. Added both the 2.4 GHz and the 5GHz connections. But it looks like it does not remember the password of more than one network, or may be it is limited to one network per location. Anyway it works.

Chromebook network connection dialog, advanced tab shows signal strength. It was showing 67 very close to the router and 36 at the right mirror of TM3. After the extender, strength was 71 near the extender and 56 near TM3. So looks like TM3 needs very good signal strength to pick up WiFi.

DRFLGD | 15. Dezember 2018

Thought I'd dredge-up this thread instead of create a new one.

So I decided to put my 7-year old iPad in my 1-1/2 year old S100D as close as possible to the right passenger sideview mirror (where the WiFi antenna is) and see if it connects. Sure enough it did and never disconnected. My S100D OTOH connects and disconnects with no rhyme or reason. So it's not a signal strength issue; it's an issue with the car/software/WiFi antenna. Unless I am missing something.

markecollins | 29. März 2019

Just chiming in the thank the above contributors. I had to switch my router from WEP to WPA2 before the 2015 model S would connect.

dave.dussinger | 01. Mai 2019

recently obtained my model3. the wifi appearss to connect but i receive an error "unable to connect to internet, check Firewall settings. i do not hve extra security on the wireless Firewall. has anyone else seen this

EVRider | 01. Mai 2019

@dave: I suggest you post your question in the Model 3 forum, since it might be an issue unique to Model 3. I haven't heard of that issue specifically.