Cruise Not Available Error

Cruise Not Available Error

Does anyone else get the error that says “Cruise not available” when you try to go into autopilot or even just plain TACC? It occurs about 50% of the time I drive and the mph and road lines do not show up, nor does the little auto steer wheel icon. It does not come back until I end the drive and leave it sitting for a while. Not even pushing both steering wheel buttons to restart the computer fixes this issue.

The service rep told me it disables itself when it’s “sending data that has been collected” back to tesla. This seems obsurd to me. I didn’t pay 5K for a feature I can only use half of the time I drive.

Any help or experience here would be great!

CharleyBC | 31. Oktober 2018

Where are you, and what kind of roads are you on? When it's not showing lane lines are there in fact lane lines present and clear? Not showing speed limits could mean it doesn't have or can't access its geographic data for that area. You may in fact have a defect, but it also seems this might occur in remote areas, country roads, etc.

Rt002k | 31. Oktober 2018

Did you by chance go over 90MPH while having autosteer engaged? It will punish you for the rest of your trip if you do. If that's not the case, I would say it's defective. I was thinking the same as Charley, but you state that it only will come back after sitting for a while. That points to a defect if I am making the assumption that you are driving on the same roads and it sometimes works and sometimes doesn't for the same stretch of road.

You CAN engage Autosteer even when you have no service. The lines will not show up if there are no clearly visible lines on the road, and that will prevent the steering wheel icon from coming up. How many miles have you put on your car?

kevin_rf | 31. Oktober 2018

I have it happen with some frequency, not 50%, maybe 5/10% Usually it feels like it's not happy about where I am in the lane. As in just got on an on ramp hard and try to engage while getting settled in the lane. I just count to ten (milliseconds) engage the tacc and then a few seconds later try the double click for the EAP. Usually works...

The most annoying thing about a failed double click is it also turns off the TACC.

And for the record I have only gotten the car over 90 twice! Both times with chill mode!

jdcollins5 | 31. Oktober 2018

At times, for whatever reason, I have gone to use TACC and realized that the gray TACC icon was not showing. At other times I have hit the stalk and received the Cruise Not Available error and realized the gray icon had not been showing.

Zenon5 | 31. Oktober 2018

I have had this exact problem. It’s infrequent but very annoying. Seems to have nothing to do with anything external. These functions either work or they don’t, off or on.
I contacted service and they had me log a couple of my episodes as to time of day road surface, etc. dropped my car off on Monday. They checked camera connections and replaced the three pack of cameras on the windshield along with one other camera. Got my car back yesterday, Wednesday.
No recurrence yet. Naturally I’m hoping this solves the problem.
It’s not a phantom and you would probably be best served by working with service.
Good luck!

Efeil3600 | 31. Oktober 2018

Thank you very much for the input everyone.

@Zenon5, I think this is what may happen to me as well. I am bringing it in for service Friday and have been logging a few instances of this for them to look into. What’s interesting as well as the auto high beams also don’t work when autopilot, lane lines, and speed limit sign are not displayed on the screen which makes me think all these depend on those front cams (I’m still on V8). Also interesting is that autopark still works during these times, maybe because it’s only using the proximity sensors.

Neil07 | 01. November 2018

@Efeil3600, exactly the same issue. Took the car to the service and they fixed it by rebooting the software. Later on, I had the test drive with the technician this afternoon and worked fine. However, while going home from work, same issue. Cannot initiate cruise control as well as auto steer. Also no blind spot assist... Mine autopilot works only 20% of time. Very frustrating as I bought the car just 3 days ago. I am going tomorrow to the service and let’s see what they have to say.

Neil07 | 13. November 2018

So here is an update... I had my model 3 for a week now at the service center and they have to replace the whole computer inside. They calibrated the autopilot and is working very well. Hopefully no recurrence of the problem.

amory | 28. Januar 2019

I got my Model 3 in November. I live in the Colorado high country. This error message occurs perhaps a tenth of the time, most recently yesterday and today while driving on a clear four-lane highway with good lane markings. Once I got the error when a crust of ice on the front bumper may have occluded sensors, but yesterday and today the bumper was clear and there was no obvious cause. I do not have the Autopilot option, but only a day earlier, Cruise had worked fine for more than a week on the same road, even with more snow on it. I wonder if I should contact Service (but they'd need to send a Ranger, since we're about 200 miles over the Divide from the Service Center).

amory | 29. Januar 2019

It was my error. I just discovered I'd inadvertently left the car set on Valet mode, which disables Cruise and limits speed and acceleration, among other things (manual p. 39, where it's included in "Autopilot convenience features"). Perhaps some others might be making the same mistake.

synon2000 | 18. Februar 2019

I had it happen 3 times - both cruise and auto pilot not available and no lines are visible. All three times it was at night. First time when I was driving back home from airport (Columbus, OH). Weather was ok - no rain or no snow - so could not find any reason. Second and third time, I was on I-70 traveling east-bound towards Columbus, OH - the weather was nasty - freezing rain. So, I would imagine, it may be due to sensors/cameras being blocked! Stopped at an exit, cleaned the ice on the wipers and the side cameras to get around the issue.

scott.b.francis | 07. April 2019

Just had this happen, drove 50ish miles to visit family with tacc and noa without issue, get in car to go home and no speed limit signs, try to apply tacc, get cruise not available message. No lane lines, no other cars showing, no auto high beams all on route it just worked well on. Stopped for hard reboot (parked both scroll wheels and foot on brake). No change after reboot. Still inoperable. Parked at home with issues still present. Will request service and see how it does in am on commute.

ewd7 | 07. April 2019

I've had the exact same problem for the past couple days,. Tesla acknowledged a software problem, but only said to wait for a fix which could be weeks and they refuse to push updates.