Software Update of 2/24/13

Software Update of 2/24/13

I was asked to update my software Saturday and did so. After I did I noticed two changes. First, when I went to, where I used to get the desktop version, I could only get the mobile version. Unlike my phone, there was nothing at the bottom to let you switch. I called Tesla Roadside and the guy on the phone, went to one of there demo cars and found he was stuck in the same spot. Did anyone else have this happen to them? Secondly, when I left my car the headlights stayed on longer than before and I'm talking about a lot longer. Before, the handles would retract and the headlights would go off in a shade under a minute. Now, it's over 4 minutes. Anyone else?

mkh1437 | 25. Februar 2013

What software version did you receive? Is this newer than 1.19.42?

jat | 25. Februar 2013

I hope the car isn't staying unlocked for 4 minutes after walking away.

The choice of what to show for a given user agent is up to the web site, and specifically giving you an option to see the desktop version vs the mobile version is totally up to the server. If anything changed on the Model S's end, it would be in how the browser identifies itself in the request.

craig.tesla | 25. Februar 2013

I can confirm that of of just a second ago, sending a User-Agent of "Mozilla/5.0 (X11; u; Linux; C) AppleWebKit /533.3 (Khtml, like Gheko) QtCarBrowser Safari /533.3", returns the mobile page with no footer option to go non-mobile.

I think this is a change on Yahoo's side though, that User Agent string is from which got it from a thread back in October 2012.

negarholger | 25. Februar 2013

yes, that is a Yahoo change... is on all my PCs including work PC and with all browsers. I don't like the new format.

Pungoteague_Dave | 25. Februar 2013

jat, that's not true - it isn't necesarilly the website that chooses the format - my Androids have browser-based options to request the web browser format instead of the mobile format. I don't know if this exists on the i-series, but you can definitely select-out with Android.

olanmills | 25. Februar 2013

I actually wanted would prefer the mobile version of websites because the Model S browser is kind of slow.

There's one site I have in my Model S favorites that detects the Model S browser as a desktop, and forces you onto their desktop site, even if you manually enter their mobile address, and they stupidly don't have a link to manually specify mobile.

Brian H | 25. Februar 2013

Mobile: "Little tiny license plates for bees."

GeekEV | 25. Februar 2013

@Pungoteague_Dave - In that case Android is changing its user agent string to emulate the one from a desktop browser and removing the mobile identifier. Might be nice if Tesla let you do that too, then you could tell the web sites what to go do with themselves... :-)

jat | 25. Februar 2013

@Pungoteague_Dave - yes it is -- the web browser sends the user agent string to the server, and the server decides how to render its web page. You can change the user agent that gets sent, and some mobile browsers let you do that, but again the choice of whether to send the mobile site, a flash-based site, a pure HTML site, an AJAX site, etc etc is strictly up to the server. Even if a mobile browser tries to pretend to be a desktop browser, if the server wants it isn't hard to figure out it the client is really a mobile browser.

I have been writing web apps before Netscape existed, so I know what I am talking about.

Robert22 | 25. Februar 2013

Now if you were writing them before Mosaic I'd be really impressed ;)

craig.tesla | 25. Februar 2013

What's a little funny is that other than the "QtCarBrowser", the UserAgent string looks way more like a desktop browser than a mobile one. The only thing I can picture Yahoo triggering on to switch to the movile site is that QtCarBrowser substring, which seems like an odd thing to trigger on. Is there some other QtCarBrowser out there which doesn't use a giant 17" screen and would more suitably have a mobile site presented?

MandL | 26. Februar 2013

I developed a web site before Mosaic for use with WorldWideWeb/Nexus. Haven't done much of that sort of thing in recent years though, and all the hacking threads, while I find them fascinating, give me a headache. Keep up the good work!

tonysled | 27. Februar 2013

I had the same issue when I went to The desktop version worked perfectly fine but the mobile version that comes up now is horrific. I tried to change back with no success. the internet functioned far better before the update. Internet access is painfully slow and the touchscreen response within the Internet function is slower than my grandmas walk to the mailbox. Funny the touch screen works fine in the other modes.

Also had issues trying to open up the owners manual from My Tesla account. got the list of manuals but can't open any of them. Anyone else have this issue? seems odd that I can't reference my manuals from the car itself... had to pull up the user guide up on my laptop.

bp | 28. Februar 2013

The manuals are in .pdf - and there doesn't appear to be a .pdf reader currently in the browser.