Issue using

Issue using

I have been trying to buy and adapter. I tried yesterday and again today. I have tired different browsers and even different credit cards. I keep getting the same message. Anyone else having an issue?

There was an issue retrieving your order. Please try again.

jimglas | 02. Juli 2019

what was the message?

zbaz | 08. Juli 2019

Same problem here. After you enter payment info it sits there with the spinning wheel of death for a good while and then goes to a new page that says "There was an issue retrieving your order. Please try again."

Then I tried again with the same credit card and it gave me:

"There was a problem processing your payment. Please check and try again or contact your bank. For further assistance, contact (Error code #KR36)"

According to the bank nothing was declined. They see no charge attempt. So then I tried a different credit card and after submitting payment again it came back with "There was an issue retrieving your order. Please try again."

gary.heaton | 30. Juli 2019

Sorry to say its weeks later and I'm seeing the same problem buying a 14-30 NEMA adaptor. After entering my credit card information, I consistently receive the message, "There was an issue retrieving your order. Please try again." Trying again, even a day later and with a different credit card, gives the same message.

kbopara | 31. Juli 2019

Hey guys no worries, I had the same error message, and then i got charged 5 times AND the tesla shop ordered me 3 adapters. When I tried to contact Tesla through email because for some dumbass reason, thats the only way to contact them, absolutely nothing happened. Consider yourself lucky you didn't lose hundreds of dollars like I did because the tesla online shop and customer service is shit.

jimglas | 31. Juli 2019

sounds like FUD to me

gary.heaton | 02. August 2019

Hi kbopara, I sent an email about the error message to which I am pleased to say did respond in a day or two: "Unfortunately, we are not seeing a payment attempt on our side, so it is unclear what the exact issue may be. We recommend clearing cache/cookies and deleting any item in the cart. We also recommend using Google Chrome as the web browser. If you continue to have this issue, please log out of your Tesla account and attempt to checkout as a guest." In my case, the original attempt was using Chrome, so I switched to Microsoft Edge browser (which I almost never use so it should have a nearly empty cache) and re-did the order. That attempt worked fine.

dfhb4 | 27. August 2019

Clear your browser cookies with cache and try again.