Tesla Model 3 isn't detecting iPhone

Tesla Model 3 isn't detecting iPhone

Is anyone experiencing this? Whenever I go to unlock my M3 and phone is in my pockets (with Bluetooth turned on), it doesn't unlock and it shows on the screen "Key card needed"

Now, when i take out my phone and it lights up, the car unlocks fine, I don't even have to unlock my phone. It just has to light up. It's just annoying when i'm carrying stuff that i have to drop everything and take my phone out of my pocket.

I called Tesla and they said that my "Background App Refresh" has to stay on and I tried that but it's still doing the same thing.

Any help would be appreciated.


apodbdrs | 20. Januar 2020

I asked the same question, someone recommended in the phone settings turning on Location, Bluetooth and Refresh. It seems to be an I phone issue.

Magic 8 Ball | 20. Januar 2020

Reboot car
Reboot phone
Check phone settings
Check car settings
Unpair phone the pair it again
Delete profile and recreate profile

Some of the things to try.

EVRider | 20. Januar 2020

Might just be where the phone is in your pocket, if everything works after you remove the phone. Other people have reported the sane thing.

NorthValley | 20. Januar 2020

Yep, butt block has happened to me a couple of times out of a few hundred unlocks. I take the phone out of my pocket, it connects immediately.

amr.aghar.7 | 22. Januar 2020

Awesome, thanks guys!

pavanforest | 22. Januar 2020

Is it working now for you?
I had to remove spaces in the hotspots name to get to worked, just in case if this is the case with you,

EVRider | 22. Januar 2020

@pavanforest: This has nothing to do with WiFi or hotspots, since the phone key uses neither one.

pavanforest | 22. Januar 2020

I don’t know solution for it, it use to work 100% like till last 3 months, then it’s not. To make it work I need to unlock my phone, then car recognizes my phone as key. When car went to deep sleep I have to wake the car up with app on phone to recognize it, I usually do that before I come out of home when car haven’t used for a day or so.

CRAIGJFIFTY3 | 22. Januar 2020

With my iPhone 6s+, I sometimes had to shake the phone in my pocket to get it to connect. I have a 8+ now, and have had no problems with it connecting. Except for the occasional failure to wake the car from inside the house, but that’s a different issue.