Model X

Wifi on Model X fails to connect

edited November -1 in Model X
Hi everyone. I have an interesting question for you. I am a new model X owner and cannot connect it to my home Wi-Fi. I brought a brand new DLink when Tesla told me mine was incompatible. The new Wi-Fi modem functioned like the old one, took it back to Best Buy. I have asked Tesla to tell me what to buy. They do not know, standard reply "its not compatible," I found this on Tesla Forum:…/connecting-model-x-home-network-…

The forum writer concludes: "I consider this a firmware bug that Tesla should fix: the late-03/2018 Model X sending and requiring response to an ARP request for an IP address that is not on its subnet. Tesla should not assume that every router implements and enables proxy ARP."

Statement is mostly Greek to me and I did google Wi-Fi modem supporting ARP and did not come up with much.

Bottom line - no one seems to be able to tell me how to get the firmware bug fixed. I'm version 2018.42 and note that Cisco is the only company that supports ARP, which is Not a good option for a home user. My wife has a Model S same garage no issue connecting.

Any thoughts of how to get this to the attention of Tesla are most welcome - Christopher


  • edited November 2018
    After installing the 3 station hot spot (Google Wi-Fi) my MX shows full wifi bars on its screen and the download speed went from 10-15Mbps to 60-65Mbps. I’m happy!
  • edited November 2018
    I connected my 2016 MX to numerous access points. I’ve never had a problem connecting to WiFi. I’m running 42.2 firmware. It might have to do with your home router configuration than the car...
  • edited November 2018
    I'm using a Netgear with a Victony Repeater & I have full WiFi bars on 42.2.

    1 of 2 things.....

    1) Your distance from the router to the car is too far
    2) Your configuration is not correct when connecting.
  • edited November 2018
    I think there's another forum about difficult WiFi connections. I had issues with my March 2018 making connections. It seemed to work good enough eventually.
Sign In or Register to comment.