Model S

problem camera fills up thumb drive and then stops

edited November -1 in Model S
the camera just records until full and then stops. I thought it should record over the old pictures and continuously record. Any one else with this problem?


  • edited February 2019
    Here's what the manual says:

    "Note: Tesla recommends using a flash drive with as much available storage as possible; saving the most recent ten-minutes of video requires approximately 300 MB, and the hour- long video footage loop requires approximately 1.8 GB of free space. If your flash drive does not have sufficient storage, an "X" displays on the dashcam icon and dashcam may be unable to save video files."

    If you're going to use the dashcam, use a USB drive with enough capacity. They don't cost much. The manual doesn't say what happens if you run out of space, but if you're not following their recommendation, all bets are off.
  • edited February 2019
    I was told at the service center that the dashcam couldn't use a drive larger than 32g . I was also told that when it filled up it started writing over the earliest recordings.
  • edited February 2019
    @jlackey1948: I think you were misinformed. Other people have reported using the dashcam with drives larger than 32GB, and if the OP is correct (I don’t know if they are), the recording just stops when you run out of disk space.

    That said, 32GB should be more than enough since the dashcam only uses about 2GB for video that you don’t save. I don’t know if Sentry Mode changes the requirements.
  • edited February 2019
    The 32GB limit comes from the FAT32 disk format under Windows. It’s designed to support up to 32GB disk partitions. There are, however, formating tools under Linux or MacOS which can handle disks above 32GB... it’s just not the norm...
  • edited February 2019
    Thanks for the info, I checked my thumb drive and it said 16GB. So, I guess i will go get a 32 GB drive and let you know if that works
  • edited February 2019
    Thanks for the info everyone.
  • edited February 2019
    @Passion2Fly: FAT32 supports up to 2TB -- the 32GB limit was from Windows 2000. See for more information. I'm currently using a 64GB FAT32 USB drive to play music in our Teslas.

    @blundell31: A 16GB drive should have plenty of space, so I don't think that's the issue with your USB drive. Is it formatted to use FAT32? It needs to be. It's also possible your USB drive is defective. Try reformatting it.
  • edited February 2019
    I concur with EVRider - doubtful the size of the drive is the issue. His suggestions are great. You also might just try another drive. Note that cheap no-name drives on eBay are almost always fakes and will have all sorts of problems. Buy only from reputable companies like Amazon, BestBuy, or the manufacturer itself.

    I wrote this article a while back on USB drives for Teslas, more for music, but much applies to use as a dashcam USB drive: The section on how to detect fake drives may be useful too.
  • edited March 2019
    replaced my 16gb thumb drive with this 500gb external drive

    so far so good.
  • M3RM3R
    edited March 2019
    @sloflo, you just plug the USB cable into the car and that’s it?
  • edited March 2019
    Older topic yet still important for the use of Sentry. Model 3 owner.

    I see people plugging in more than just flash drives both on YouTube and discussions here.
    Owner's manual for the Model 3 says only flash drives and not USB hubs. Yet folks are going beyond these anyway!

    My question is what are the current limits for the front two USB ports? Specifications? I can't seem to find that information. I'd be concerned plugging a higher draw external SSD drive e.g. despite this sounding like a nice solution to capture all the video files.

    I assume this 500G SSD gets it's power from the 5V output of the car's USB ports. Is the current draw for the drive easily, safely within limit for the USB port? Same questions with a hub powered by the USB port.
  • edited November -1
    The original standard USB port provides a maximum of 0.5 amps at 5.0 volts DC. If the device that is connected tries to draw more than that it is supposed to turn the power off. The USB 3 spec provides up to 0.9 amps.
    There are lots of violations of these specs around.
  • edited March 2019
    I've tested the USB ports and the fronts are about 2.5W, and the rear around 3W. Most SSD drives are in the 2 to 5 W range, with larger capacity drives requiring more than 3W. What is not known it what the peak power needed, which occurs when writing. Some drives have significant power peaks during the write cycles, well beyond the USB port capacity. I worry that if you are in the middle of writing the file access table when a peak power is needed beyond what is available, the drive may miswrite and corrupt the table. I'd stay with USB flash drives unless you do quite a bit of research and testing. Be prepared for the SSD drive to be corrupted, possibly beyond the ability to repair.

    More details at the end of this section:
  • edited March 2019
    What hub should I use? Any recommendations here.
  • edited March 2019

    Why I am here as you are. What can we really do and why or why not?
    My first thoughts were current draw of USB ports. If exceeded, what happens?
    Hmm, are there fuse protections? Heck, I haven't even explored if there's a fuse box yet on Model 3

    I simply didn't want to take a risk of drawing too much current (power) and damaging car electrical system. brings up the peak current demands during writes and corruption of data. Significant.

    Page 20:
    Note: Do not connect multiple devices using a
    USB hub. This can prevent connected devices
    from charging or from being recognized by Media Player.

    Page 110:
    Note: To play media from a USB connection,
    Model 3 recognizes flash drives only. You can
    play media from other types of devices (such
    as an iPod) by connecting to the device using

    Note: Media Player supports USB flash drives
    with FAT32 formatting (NTFS and exFAT are
    not currently supported).

    Note: Use a USB connection located at the
    front of the center console. The USB
    connections at the rear of the console are for
    charging only.
  • edited November -1
    @wilborville - where did you get your referenced page 20 from?
  • edited November -1
    @CVTRVA - the referenced page above is form the owners manual. I’m guessing it’s the Model 3 owners manual given the Model 3 reference in his content from page 110.
  • edited November -1
    This keeps happening, and I don't believe it's our fault - it's a bug in Tesla's code/logic.

    I ran into the TeslaCam "X" issue with a 16GB USB 3.0 drive and my latest what I thought was bulletproof solution - a USB adapter with a 64GB (FAT32-formatted) Samsung PRO Endurance card.

    Once the card fills up, the dreaded X appears, and it fails to record further.

    Here are some photos/screenshots:

    I haven't had recordings for 2 days until I finally pulled out the card, put it into my phone, deleted some space, and put it back. Now it's recording again.

    Tesla, when are you going to fix this issue?
  • edited June 2019
    I'm extremely upset with Tesla. I can tolerate updates but I bought the car for its features including the integrated dash cam and autopilot.

    Yesterday, I had a maniac Lamborghini driver hit me in the UK and speed off at high speed weaving through traffic. No panic...i pressed the save recording button and thought I'd have the whole incident on my dashcam to report to the police. It was very frustrating to find that the dashcam hadn't recorded anything but stub records.

    I now have expensive repairs to pay for all because the car didn't do its job and I cannot trace the Lamborghini owner!

    @Tesla - Why would i bother continuing to evangelise this brand?
  • edited November -1
    If you’re unhappy with how the Tesla dashcam works (as many are), buy a real dashcam. No one is forcing you to use the Tesla version. You get what you pay for, and you paid nothing for the Tesla dashcam.

    Many issues are caused by not removing the TeslaCam USB properly. You need to stop recording (both dashcam and Sentry Mode if active), wait about 20 seconds, and then remove the USB.
  • edited June 2019
    Should have learned how set it up and test it to make sure it worked first . Huh?
  • edited July 2019
    I am having the same problem as OP. I have tried multiple flash drives of different sizes and they all fill up and are not overwritten.
    Does anyone have a solution?
  • edited July 2019
    @EEPlasty: Sentry Mode does not overwrite old files, so if you use it the USB will eventually fill up.
  • edited July 2019
    @EEPlasty - Yep, known issue. Solutions:
    - Erase sentry files every so often - before it fills up
    - Use a larger flash drive - I recommend 128 GB. Doesn't fix it, but you don't have to erase files for 1-2 months.
    - Don't use sentry mode
    - Set Sentry mode off at home and/or work (which stores less files). Options in controls to do this automatically.
Sign In or Register to comment.