Model X

Tesla Forums are now read only. To continue the conversation with the Tesla community visit

USB Loading Error

edited November -1 in Model X
I have been playing music from an USB thumb drive since purchasing my X90D in December 2016. After uploading the latest update, 2018.50.6, I get a loading error after playing the first song in both the shuffle mode and non-shuffle mode, and it will not continue with the next song. I can select another song and it will play, but it will not continue with the next song. I have restarted the system by depressing the scroll buttons and powering down from the service option. Tune In is working fine. Anyone else run into this issue? I have already reported to Tesla Customer Service but have not received a reply or resolution.


  • edited February 2019
    It’s a read/write speed issue on the usb bus. I haven’t found what one works, but there are drives where this doesn’t happen.

    Check the thread on the dashcam usb drives for compatible ones there and you should find one that won’t have the loading issue.
  • edited February 2019
    Probably need a USB 3.0 drive now. I haven't tested this yet as I don't have the latest firmware but I've been using a higher end USB drive for the TeslaCam - no issues.
  • edited February 2019
    I had the same problem with the USB stick worked fine. After the update loaded all the media but it only played the older songs the newer ones that I copied on the be USB stick would not play. I did get it to work with the same songs on in order USB stick that I had in a different car. From this I'm guessing that for whatever reason the new update didn't like the newer disk. The old one with the same songs but was made couple years ago worked fine and it still working with the new update.
  • edited February 2019
    I Have been using the same USB stick for the last 2 years and was working fine until the new update. No new songs added or remove. Has to be compatibility with the new update. Hope they resolve it on the next update.
  • edited November -1
    Have the same problem. Even more on regularly on fix location when LTE signal loss. Seems fixed with uncheck all favorites songs from list (the file seems corrupted in my case)
  • edited March 2019
    What types of drives work with the new software update? My old drive stopped working with the latest update and I bought a new Samsung Portable SSD T5 and it does not work either. Any thoughts?
  • edited March 2019
    I found that the car wouldn't play the wave files that were default on the ripper. I changed the format to mp3 and it worked fine. It's probably a combination of changes with Tesla and Microsoft that did it. Old wave files play fine. But recent ones that used to work don't anymore.
  • edited March 2019
    Winamp - it really whips the llamas ass!
  • edited March 2019
    Dammit jjgunn, I still remember that sound clip, and now it’s ratteling around in my head again! :P
  • edited March 2019
    After further research, I found the music player on the Model X does not play properly from a USB hard drive or thumb drive after the most recent software update. It will play some older files, but only a few. I am using AIF files I ripped from the original CD.

    Is anyone else having this issue?
  • edited November -1
    Mine is still playing all the same music file from my usb drive.
    Still have periodic loading issues when switching between Apple files and any other type.
  • edited March 2019
    I have loaded my music library in mp3s on my classic 240gb iPod enabled as a hard drive mode, and I have no problems accessing the library by USB mode. Still works great.

    Mike P
  • edited March 2019
    Model 3. With v 5.15 I got the Loading Error as well. usb 3.0 thumb drive.

    My low rez MP3 files play fine. I had both CD rips at 16bit/44hz (AIFF) and a number of vinyl rips stored at 16 bit and some higher sample rates. Those higher rez files played fine until now. The Loading Error is only with respect to my higher rez files.

    Only low rez, compressed, crappy sounding MP3s will now play. The only way to play decent quality audio files was via the thumb drive. Bluetooth compresses the signal from the source and there is no other way to connect a high rez music player.

    Please restore higher rez playback capability via the thumb drive and the internal DAC.... please.
  • edited March 2019
    @odell2 - Use FLAC, it avoids all the problems and is a non-lossy high-res format. Never had any loading errors over 6+ years and two cars. Apple/AIFF has always been a bit iffy in the Tesla on any version for years now. For some it works, others get lots of loading errors. Seems to be partly dependent on the USB drive, although with a lot of testing I did, I was unable to identify why some USB drives causes Apple files to get loading errors. Converting Apple files to MP3 always solved any loading errors on my tests.
  • edited March 2019
    Indeed, FLAC is the way. thanks. sampled various high resolution file formats and FLAC was the only one to work consistently. ALAC, WAV and AIFF were no-gos.
  • edited May 2019
    I created several new 4GB music USB sticks for a road trip. However, when I plugged each new one in, the displayed playlist was stuck on that from the previous USB I’d been using for the last 6 months. Those songs common to both the original and new USBs played fine, but I got loading errors for everything else. It’s as if the previous USB playlist is imprinted into the car memory and it won’t recognize any new USB stick.

    I found a solution but it is VERY awkward. I reboot the car each time I switch USB sticks. What??? Anyone else have this problem and/or a solution? An obvious fix is to put all my music on a single high capacity USB, and I’ll work on that... but not before my upcoming road trip!

    The details:
    USB is high grade made for medical devices, FAT32 format
    Using FLAC (converted from Apple lossless).
    Software 2019.16.2, Model S75D 2018.
  • edited November -1
    @TOM "After further research, I found the music player on the Model X does not play properly from a USB hard drive or thumb drive after the most recent software update. It will play some older files, but only a few. I am using AIF files I ripped from the original CD."

    Hi Tom I have the same issue. I'm my 2017 MX90d

    And after thinking the USB drive was corrupted I reloaded it and it won't play anything at all. Monica @ Tesla Service in Costa Mesa tells me it is the drive But I tried 5 drives, and none work, with ALAC, FLAC, ACC, AIFF. .4ma no files seem to work.

    Plus try to browse, is your Brower so slow its almost unusable? I am thinking the issue might be related.
  • edited July 2019
    paper folder, you might try to rename your drive and reload all the songs. I think Tesla makes a file for every USB name it encounters and creates a TOC (table of contents) and when it doesn't see a song on the original TOC the you added later it won't work.
  • edited July 2019
    I'm not sure why Tesla wouldn't POST a working Hardware and software work flow.

    Like, BUY these USB drives, USE this conversion software for MAC/PC/Linux, and only these formats...and then it will definitely work. And make it for lossless.

    When I use slacker it invariably chooses the wrong version of the song I want. I want my music in lossless at high sample rates, would quad rate DSD along with 24/192 PCM be too much to ask?

    Why have over 100,000 beta testers without a video from Tesla showing a definite fix?
  • edited November -1
    @johngilmour - Almost any USB drive will work for playing music as long as it's formatted for FAT32. Even dog slow ones. Keep in mind there are a lot of counterfeit and outright bad flash drives being sold. If you're having problems with a specific drive, I wrote up instructions to confirm it really is the drive size specified:

    The problem is using Apple proprietary formats - which Tesla has not handled well. Switch to a common standard like MP3 or better lossless FLAC, and it should works fine. Not sure about the extreme sample rates through. I use FLAC at 44.1kHz, and I'm fairly sure it works up to 192 kHz, but I've not tested that limit. It is limited to two channels.

    @Paperfolder - That's really strange, but not too surprising. Better to just buy one larger drive. The are so cheap now. $28 for a 128 GB drive like this: (and plenty of others)
  • I have 5.85 GB of music loaded on a Samsung USB 3.1, 64 GB flash drive and I am using a separate USB for the music than for Sentry. I get the message on the Tesla screen "error loading USB" after the first song plays and it won't play any other songs. Also the song list on the Tesla screen shows duplicates of every song. I inserted the same USB in my laptop and there are no duplicate songs and they play fine from my laptop. Any advice? I'd much prefer to use the USB rather than my iPhone for music.
Sign In or Register to comment.