Model 3

Latest Update but still have "Failed to Turn on Climate" Error

For the last three updates my app climate control has stopped working and I get the error "Failed to Turn on Climate". PIC:

Also, I was thinking I was going crazy, but High to 81 is high temp, but once I adjust to 80 and below its all low. 66 degrees and 78 degrees feel like the same temperature. Does anyone have one or both of these issues? Thanks!


  • edited April 2019
    Had same problem. But went to service center and they fixed it. Said was loose wiring but not really sure about that vs software bug. Left car with them and got laner
  • edited April 2019
    Temperature control problems likely require at least a mobile service call.

    But the "failure to wake or unlock car" or "failure to turn on/off climate controls" issues can be a simple communications error - like when your laptop can't find the printer that happens to be attached!
    Easiest fix for me when I get a strange App error is to immediately kill the Tesla App, wait a few seconds, re-start the App. Normally, the App now finds the car fairly quickly and the command to open/cool/heat etc. now works.
  • Having the same issue -- and it is very strange..
    From all apps (two phones and TeslaFi) I get the same message "Failed to turn on Climate".
    However; if the door on the car is open it always work; regardless of being inside, or away from the car - it works..
    All other controls works fine without problems..

    I reported it to Tesla and they adviced to re-install my tesla app .. I did (and change password) - and IT WORKED.. but only for a day :(
    I connected the second phone; and did a car wash .. and now it is broken again (may be one of those thing that caused it, but it may also simply be random)..
    It would be really nice to find a solution; it is a very strange problem..
    I should mention that from the screen in the car everything works as expected - it is solely an APP issue.
  • edited April 2019
    Since the versions can very in a given timeframe, you should really identify the actual version(s) of firmware in the subject.
  • Yea that is a wise comment. 2019.8.5 is my current Firmware version
  • edited June 2019
    I'm getting the same "failed to turn on climate" message. Running version 2019.16.3.2. Car is 2 weeks old. My question is, does it matter if there are two phones connected to the car? My wife has the app on her phone too.
  • edited June 2019
    i have this same issue starting 3 days ago setting the temp to anything other than hi is really cold and my keep climate on and dog mode are grayed out.
  • edited November -1
    Did anyone find a solution for this? I have the same problem as Jbcamilleri
  • edited July 2019
    Received update 20.4.4 today and now climate fails to turn on from app and dog mode and leave climate on are greyed out. Had no problem with update 20.4.2 but did have same issues with 20.4.1, 20.2.1 and maybe some earlier ones. I scheduled service back then but received update 20.4.2 which temporarily fixed issue before service so they not address that issue during my visit. Sounds like a combination of software and hardware since it affects only some of us.
  • edited July 2019
    I occasionally get the "failed to turn on ..." message on the app when the car has a very weak or intermittant local wifi connection, or when the home Comcast network that it's connected to is flaking out and laggy. It seems there are limits to what Tesla can do to deal with flaky network connections that are not under its control. Issuing the warning message seems to a good approach, though it would be nice if the message contained more specific details of the cause if available. (Ignore Fish. He has an agenda.)
  • edited July 2019
    clanmacarms did you ever get your issue resolved? We have a new to us 2018 with the exact same app issue and exact same temperature issue.
  • edited July 2019
    How do you know what is the latest update software available. Can you manually download it.
  • KLKL
    edited July 2019
    I have two iPhones (work/personal). The iPhone X iOS 12.3.1 phone with the latest Tesla app could not turn on the climate control. The iPhone 7 iOS 12.3.1 with the lates Tesla app could turn on the climate control. The phones are literally next to each other.
  • edited July 2019
    Same issue for me with remote climate and dog mode grayed out. Started for me with build 2019.20.1.2. I have a SC appointment for 8/2. Ill update...
  • edited July 2019
    If you presently have this issue, have you tried a Factory Reset? Sometimes cures issues.
    note: it erases all custom settings like radio, seats, mirrors, etc.
  • edited July 2019
    I'm having the same issue. It's intermittent, and for some reason seems to happen mostly between noon and 6pm.
    When it happens, I can log into the car from my app. It allows me to unlock doors or enable keyless driving, but when I try to turn the a/c on I get the generic "Failed to turn on climate" error message. At the same time, cabin overheat protection is not working -- the app shows interior temps as high as 117 F (supposed to auto-cool to keep it at 105 or below). The a/c works, because if I get in the car and turn it on the a/c always works perfectly. Also, sometimes (although very rarely) it will work just by trying it over and over. I'll be sitting in the same spot, I'll try and fail 10 times, then suddenly on attempt 11 the a/c turns on. It's bizarre.

    So: the problem is not with the a/c itself, it works fine. And it's not anything to do with logging into the car or inadequate reception / wifi / LTE / location where I am parked or where my phone is, because I can always log into the car and other functions work fine. (I've verified that it's communicating with the car by standing outside it and watching the doors unlock, even while I can't turn on the a/c.) Combined with the fact that cabin overheat fails at the same time, the problem is some issue with the car's ability to turn on the a/c "by itself" (i.e. without me in the car).

    I've had this car for 2 years and only started having this problem recently. I did have a windshield replaced recently (which someone up-thread noted as a possible cause, although I don't see how). Or maybe it's related to the most recent software build. But I wish they would fix it, because I live in a desert and getting into a leather-upholstered car that is 117 F inside is pretty unpleasant.

    Version 2019.20.4.2
  • KLKL
    edited July 2019
    Definitely an intermittent issue. I just tried with both my phones (per above) and neither worked. Tried 5 or 6 times. Now, suddenly, it worked. I didn't change a thing; didn't even restart the app.

    - K
  • edited July 2019
    Service needed to replace the HVAC temperature sensor in mine to fix the ‘Climate fails to turn on’ that I discussed in an earlier comment. Car needed to be left at a service center for a day and they gave me a Model S loaner. I’ve had my model 3 back for three days now and it seems the issue is fixed, at least I hope so.
  • edited July 2019
    Same issue with mine...keep climate on is grayed out and app won't turn on AC. Also the auto mode seems a bit flakey, always defaults to foot vent and fan speed seems fixed, so I have to drop temp to 62 to get comfortable. Previously auto mode and temps at 73 were the sweet spot. Sounds like I need to schedule an appointment. For those that have had the sensor replaced, is this something that a mobile tech can do?
  • edited July 2019
    I have the same problem as Halbach.
  • edited August 2019
    Same problem, also after having windshield replaced. App can't turn on climate, dog mode and keep climate on are grayed out...message saying battery must exceed 20% charge but battery is fully charged.Temp control seems off. I emailed support but it's the weekend... From what I see here it looks like a service is inevitable. I was hoping this was caused by the quick fix to dog mode, but I guess not...
  • edited August 2019
    Same issue. I found that I cannot turn on climate remotely or turn on dog mode/keep climate on if I just drove the car. Somehow, if I left the car there for. maybe one day, then I can turn on climate remotely. So it must be an bug from software side.

    Tesla team, please do check it and fix it asap.
  • edited August 2019
    I had the same issue but the techs at the service center did their magic and my dog in now cool again. Take it to Tesla.
  • edited November 2019
    I am having same issue.
    (1) Climate control does not work from phone. Tried 2 different phone, reinstalled app but no help. All other functionality works perfectly fine like lock/unlock, summon. Climate control works only if door is open or I am sitting inside car.
    (2) Heat does not work or very slow if keeps around 70s. It works only if kept very high.
    Left car at service center they advised it may take unto a week.
    Got loaner "Model S" but i like to drive my car than loaner. Heat works perfectly on loaner and i could see big difference between two.
Sign In or Register to comment.