Energy Products

Tesla App without Powerwall

HI Guys,

I just got permission to turn on my system yesterday (I was so pumped) but when looking at the app (IOS) I have the triangle (for solar) at the top, at the bottom left I have grid, and at bottom right I have home (looks like the OP's screen but without any results). The problem is, nothing is showing up at all. Every now and then I can see us using energy from the grid, but mostly I see no flow from the panels or the grid.

I called Tesla support and they said to give it 24 to 48 hours. I did have to provide them an MAC number that was located on my inverter. I read someone say it has to be "activated" on Tesla's end. What does that mean? I think the person I spoke to today said something about activating as well. I looked on the inverter and it does look like it is getting energy from the solar panels (it is rainy and cloudy here in Pittsburgh, so not getting too much) so I was hoping I could see some results, but I got nothing. The rep said to wait 24 hours because it can take some time for the inverter to communicate with the gateway that is connected to my router. I guess I will wait and see what happens tomorrow.

Had anyone else gone through this as well?


  • edited November -1
    In response to your question, my answer is no. Our Tesla app showed everything working right away (solar, PW, Grid, home usage). Hope your issues are resolved soon.
  • edited April 2019
    Hi Tesla-David, thanks for your response, I appreciate it. I am having a tech come out and check things over as the rep said there may be something in the inverter that is not allowing it to communicate with the gateway that is hooked up to my router. The inverter is working as I can see the wattage coming in from the panels but it is just not being reflected on the app. I also see my meter (net meter) going backwards when it is sunny indicating that energy is going back to the grid. The rep was asking how far my gateway was from the inverter as he thought that maybe the distance between the two may be a reason. I do not think that is right but what do I know? The inverter is in my garage and the gateway is in my family room which is the floor above the garage/basement. I guess we will find out soon enough.
  • The Tesla Mobile App problem I am having just occurred today, after that app was working perfectly yesterday.
    My app is now failing to log-in because "There are no products linked to your Tesla account"

    DUH_H_H_H_H! The app was displaying my Solar City (now Tesla) installed functioning and statistics in great detail yesterday. My question is what happened to the solar panel product links between yesterday and today in my Tesla account???????? Any ideas and/or suggestions would be very appreciated.
  • edited November -1
    Finally got it working. The problem was my ISP's firewall. Once I called them (while the Tesla Techs were present) we were able to get everything to communicate with each other. Now I got the app to show the production of my solar panels...thank god! Only took a month and a half!
  • edited June 2019
    My Tesla app is not communicating with the Powerwall. In the last 10 days I have shutdown the mains power on 2 occasions. Very inconvenient!
    This morning it has done it again. Before I power down and power up is there a fix?
  • edited June 2019
    The Tesla App is useless. I need to have support transfer over my Solar City account. Problem with that is each time I call support for ENERGY the hold time is over an hour... PLEASE. Besides this problem, from what I have read, I see No Means of accessing my system for production on a NOW, DAY, WEEK, MONTH, YEAR basis.
    Someone said they were able to get to the IP address on the inverter. Who knows how to do this? Do I need to have Support help? Need to do this before TESLA changes to the APP only access which is a violation of my contract of me being able to monitor my own system and not rely on them to see that it is doing something.

    Help, How do I get to the IP or MAC address on the inverter so I can monitor it dierectly?
  • edited June 2019
    I am new to Solar. We purchased a house with Solar City panels on it. I had tesla transfer them to me. Customer support very rude when I called and ask questions. My information on the output shows up in Solar City app. When I log in to Tesla app I get the no products associated with your account message. How can I get my panels to appear in the app. If anyone has an answer that would be great. I emailed support with this request 2 day ago. No response from a person.

    Really not impressed with this level of support.
  • edited November -1
    There's what appears to be a trend in this thread and another. Some of the solutions may include:
    1. You need your account enabled to communicate with your App. Tesla customer service will do this for you by sending you an email with links for you to agree to terms.
    2. It would appear that the App works as designed for most of us. I'd therefore look at other components of the chain and not blame all on Tesla App alone. Your phone/device setting and your ISP/router settings are examples here. Such problems tend to happen with lots of other Apps in my experience and some of the solutions that have worked for me include but not limited to 1) uninstalling the App and then restarting the phone/device before reinstalling it . 2) Checking what devices are connected to your router and making sure the inverter is one of them. This requires a low level of technical know how but not much beyond basic. One can look up on the internet how to do this.
  • edited July 2019
    It's awesome to see homeowners wanting powerwalls, panels, and tiles! I just sent in my resume to ask for the opportunity to help make this happen for you, and hopefully hundreds of others!
  • edited May 20
    Does anyone know why, on the app, that when my solar production increases the house power also increases without any changes to what is energized inside the house. Basically, in the morning if I'm using one kilowatt from the grid it shows me using one kilowatt in the house but a few hours later when my solar kicks in and it is generating 4 kilowatts it shows me using 5 kilowatts in the house..... I thought it would show 3 kilowatts going back to the grid.
  • edited May 21
    It appears that your current transformers (CTs) are incorrectly configured. Call Tesla customer support. Often, they can reconfigure the calculations to account for the errant CT while you're on the phone. It might be as simple as flipping the sign of a variable, but it could require a site visit.
  • edited May 26
    On ios app getting sign in failed - no products linked to your Tesla account error when trying to view info from my solarcity panels. I've been successful logging into Tesla web acct. Any advice on how to get around this error? Tried calling in although had to hang up after 25 min to go back to work.
  • edited May 30
    I too am being told my no products linked to my app. I can log onto but my account has no info, no billing details and no power info. Any ideas? I emailed the support team, do they need to link my account?
  • edited May 31
    Experiences described here by others indicate that e-mail is not an effective method to contact Tesla Customer Support.

    Call them: 888-765-2489

    Don't select "other issues" at the voice prompt, or you'll end up in "hold purgatory".
  • Finally we got it working without powerwall,all the best , we are waiting for more updates,thanks from
Sign In or Register to comment.