Model S

Autopilot and Bright Lights Not Working

edited November -1 in Model S
Recently my Autopilot/Cruise Control and Bright Light sensor all stopped working. I'm not certain there is a connection other than the timing of the failures.
I have rebooted the system twice as well as turned off and on all the systems referred to above.
Other than taking the car in for servicing (which in San Diego in the past takes a year and a day) does anyone have any other suggestions I might try?


  • edited November -1
    What version AP do you have? Sounds like a front camera problem ,my AP1 car had the front camera replaced for similar issue. San Diego appts are 2-3 weeks out right now.
  • edited November -1
    Is mobile service an option for you?
  • edited May 2019
    Have you tried a Factory reset from the menu, I had same and that was my only resolution.
  • edited May 2019
    The one thing to try before factory reset would be a power down. Go into service screen while sitting in the car, and select the power down option. Wait at least 5 minutes and do not move at all and let everything shut down.

    Then press the brake, and then do the scroll wheel brake reset to reset the main CPU.

    I found this fixed a myriad of issues that I had that a simple reboot did not fix. The weirdest issue that it fixed was that my windshield washer liquid squirter did not work. As soon as I did the power down, then it fixed that.
  • edited November -1
    Specifically in 16.2 which went out less than a week ago for many of us.
  • edited June 2019
    Tesla Model S75 delivered February 2017 from a new build order December 2017.

    This happened to me evening of May 31, 2019 after the car sat outside all day while in the office. Symptoms:

    * Headlights on all the time despite the auto setting being set to on.
    * No cruise
    * No car icons on screen.
    * No lane markings on screen.
    * No autosteer

    I cannot remember what forum is was, but I followed the advice given as follows:

    * Park the car overnight
    * Do not charge it
    * Kill the app on the phone
    * Turn off always connected mode on the car
    * Disable sentry mode
    * Clean all 8 cameras. There are three behind the front windshield. There are one each on the side posts between the doors behind class. There are one each on the chrome pieces on the side. There is the rear camera.

    Moving forward, for each car wash, I will be cleaning the cameras. My intuition is that this plus the software upgrade contributed to this problem.
  • edited June 2019
    Also, I turned off climate control. Following all those steps got me autopilot etc back.
  • edited June 2019
    From what i’m hearing from our local club it sounds like a sentry flaw. If you run sentry mode everywhere the computer never has a chance to sleep and clear out some of the clutter. Unless absolutely needed turn off sentry while at home overnight. It needs to sit for a few hours with sentry off.
  • edited November -1
    And now the problem it is back. After sitting all day at the office. Will stop using sentry mode.
  • edited June 2019
    I had the same problem as mre5565; followed his recommendation and the problem was resolved. Started after my last update.
  • edited June 2019
    I am in the middle of a 1200 mile road trip and halfway through my nav and cruise control stopped working. Called Tesla and they said to disable Sentry Mode, remove the USB drive, shut down the car, and wait an hour. So now I am an hour behind schedule due to this software glitch.

    They said not to keep Sentry on all the time. Really? How about it automatically shuts down when the car is in motion? Right before this update I forgot to turn on Sentry and my car was vandalized. Had it been on the police would have had their perps.
  • edited June 2019
    @Hammonddave - see my earlier response. Sentry is not active when you're driving. What Tesla is telling you is that you need to turn sentry off when the car is stopped at some point. The computer needs to “rest” at some point every few days and if you are running Sentry 100% of the time it can't do that. So for example, on a road trip if you are going to supercharge for a while while you go to dinner turn sentry mode off as hopefully the supercharging station is “safe“. I’m sure that they are working on a permanent fix, but this is the workaround for now. For those of us that don’t really need sentry mode on 100% of the time we should limit it; for example I don’t run it at home at night as the car is in my garage.
  • edited June 2019
    I stopped using sentry mode on June 3, 2019, and on June 4, 2019, Autopilot works again. Sentry mode has been off since then. I am at software version 2019.16.2. I've read (reddit dot com) that 2019.20.1 still has this problem and that 2019.20.2 fixes it.

    >> The computer needs to “rest” at some point every few days and if you are running Sentry 100% of the time it can't do that.

    Sentry mode is the trigger for the problem, so my intuition is that Sentry mode is directly or indirectly corrupting a shared module that Sentry and AP both need. I further intuit that

    * the shared module is related to the camera since both Sentry and AP require camera feeds to work properly.

    * if the shared module indicates to AP that the camera has a fault or that vision isn't good, or if AP is misinterpreting what the shared module is saying, then the AP system concludes the cameras are bad.

    If use of Sentry mode for some indeterminate time causes AP to stop working, especially in the middle of drive, then for me, Sentry mode is the lower priority. I can certainly imagine car owners with a different pattern of use where Sentry would be more important. However, it would be interesting to test whether Sentry mode even works after it kills AP.

    Based on my speculation, a solid fix is very interesting software reliability problem. I'd be happy with a software reset that just worked.
Sign In or Register to comment.