Model S

"Key not in car" quite often

edited November -1 in Model S
I'm getting a "key not in car" message that stops me from starting the car quite often. This is especially annoying since the key was detected to unlock the car, and I can use the toggle on the key to lock/unlock the car while the message is displayed. How is that detection different from the detection that unlocks the car?

Comments

  • edited May 2019
    I don’t know but it sounds like you need to replace the fob battery.
  • edited November -1
    A phone can block the fob signal. Do you put the fob next to a potential signal blocker in the car?
  • edited May 2019
    Believe it or not, your clothing can block the signal. I had a conversation about clothing design with a young lady and she explained a lot of clothing today have silver lined in the fabric.

    When wearing my thin but extremely warm north face jacket, I get that message alot.

    Go figure!
  • Tinfoil keeps out the Gamma rays too Silver. LOL.
  • edited November -1
    That's why Silver wears his special shorts - to avoid fob problems.
  • edited November -1
    BOOM!
  • edited May 2019
    Presumably you are talking about aluminum foil, I've never seen "tin foil". Gamma rays go right through aluminum foil. You need concrete to stop gamma rays.
  • edited May 2019
    Thanks for your insightful comments, everyone ;)@TranzNDance I think you might be on to something - I'll try separating the key and my phone (they're usually in the same pocket).
  • edited November -1
    I agree with @TranzNDance. That happens to me.
  • edited November -1
    @lilbean I have changed the battery, and the problem also occurs (perhaps less often, I'm not sure because I usually drive when we're together) with my wife's fob so it seems like the fob itself isn't the problem. It just seems strange that the car can respond to signals from the fob (lock/unlock) and yet not think that the fob is in the car. Perhaps they need a place to set the fob (like the M3 key card).
  • edited May 2019
    Transmissions from the cellphone block the receiver in the fob so it doesn't know the car is asking if it is still there.
    The signal from the car to the fob is very low power. It only works within 3 or 4 feet. The signal from the fob to the car should work from 75 feet away from the car.
  • edited May 2019
    RFID cards next to fob also cause the same issue.
  • edited November -1
    That has happened to me a few times in the past. Not a battery issue. Moving the fob inside my pant pocket a little will always fix it. It usually lasted for a few days and then mysteriously gone. May be metal house keys had something to do with it but I wasn't too sure of that.
  • edited May 2019
    @jackrg... are you sure you are talking about a Tesla? what toggle? Driving the Tesla without the fob (with just the mobile app) is a pretty normal alternative to using the fob...so normal that the 3 doesn't come with a fob/key like the S/X.
  • edited May 2019
    USB drives in pocket can cause this issue also. I carry them to do repairs and have similar issues
  • edited November -1
    Anything metallic that blocks the signal from the car to the receiver in the fob will cause the problem. Radio signals do not go through metal.
  • edited May 2019
    jackrg, you say you replaced the battery. There's no guarantee that even a freshly unpackaged battery had not been sitting on a shelf long enough to drain to the same level as the one you took out.

    And since you asked, there is a recommended location inside the car to place the fob. It first was in the center console cup holder, then revised to near where the front USB slots are. We just don't hear much recently.
  • edited May 2019
    @jackrg My X fob was doing that. Come to think of it, when I brought it in for service, the firmware on the fob was updated and it didn't happen again.
  • Theres firmware for the FOB lilbean? Never knew that. Would that be something they would only do at a SC?
  • edited November -1
    @TranzNDance Thanks! That seems to have done the trick. I started putting the phone and the fob in different pockets and in the couple days since then, I haven't gotten a single "key not inside" error.
  • Today I dropped off a package at my local UPS store. When I returned to the car the handles auto opened but the “key not in car” alert was activated.
    I went back into the store to see if getting the fob a fresh go at the car would work. It did not.
    In my haste I exited the car with my phone inside.
    Then tried to a Activate the trunk, frunck, and thought the key fob was dead until I locked the car (Rookie move!) And it would not open at all.
    The UPS store folks said it “happens all the time with Tesla’s in our parking lot... and just wait a while.”
    Huh???????
    Anyone else heard of such a thing at a specific location?
    Tesla service call person was great and suggested I borrow a cell phone from a friend and download the app. It worked: opened and turned on the car. Drove home and all has been fine since.
  • Does anyone know exactly the antenna/transceiver is for the KeyFob interacts with the car? Same as the Radio/Media antenna in the back glass?
  • It's at the base of the windshield on the passenger side. If in the event that your FOB quits, you can place the FOB at the base of the windshield near the wiper blade and the car will/should unlock.

    The car is always sending out a signal and as you approach the car, your FOB in a way get energized and with power from the battery in the FOB, it sends a confirmation signal. With a dead battery, obviously there is not enough power to send that confirmation signal. Hence, placing the FOB near the antenna at the base of the windshield, there is no distance between the two and your car will recognize that the FOB/you are indeed there.
  • > @kerryglittle_98128116 said:
    > Theres firmware for the FOB lilbean? Never knew that. Would that be something they would only do at a SC?

    No need. I believe you get to that through the Service Menu on the MCU screen.
Sign In or Register to comment.