Model S

First service experience a total fail [RESOLVED ON ITS OWN]

edited July 2019 in Model S
I got my first Model S about a month ago during the "unlimited supercharging on inventory S and X" June; a beautiful, black on white P100D with all the options including Enhanced Autopilot.

Since I got it, the Navigate on Autopilot has been grayed out, with a message saying I need to connect to WiFi to download a Maps Update. It's parked in my garage every night, connected to a WiFi extender in the garage (that's been there to cover my backyard) with a solid signal on a 50 mbps internet service. Every day the same thing, no Maps Update.

So first I went to my delivery service center (after a pretty miserable delivery experience, by the way), and they said they couldn't do it because they didn't have time but they would create a case to see if "Fremont can do it over the air." That never happened. So I've called customer service twice, each time with at least 30 minutes on hold waiting for a rep (actually I called several times but only had time to wait through the hold twice). Both of them tried things like having me restart the system, etc. which, of course, never works.

So then they offered a SC appointment about 2-3 weeks off, then offered mobile service which I took. Making this appointment was difficult because somebody reaches out by text with cryptic time offers that go back and forth and back and forth like a couple of millennials discussing when and where to get a bubble tea. Finally an appointment was set on my day off.

The Mobile Service van (a Ford, not a Model S) arrives on time! I ask him if he is familiar with the problem, and he gives me a very attitude-filled "yeah," so at least I feel some confidence that he will easily accomplished this rudimentary task that any bright middle-school kid could complete. He gets into my car, pulls out part of the center console, connects his laptop, and tells me it will take 30-40 minutes to download the Maps Update to the car.

Then start the worrisome calls on his earbuds. I overhear words like, "so then how do I?..." and finally "I forgot... had it on my other laptop... should have brought..." So he gets out of my car and feeds me BS about how it's too big of a file to download, etc., not realizing that I had just overheard the truth. He tells me he will have to download the file at the shop which will take an hour or more because it's 6 GB (with his attitude, he should have know this already, as I did), and the agent will have to call me to schedule another visit next week.

Sorry, but this just downright sucks for service on a $100,000 car.


  • edited November -1
    You didn't mention it so I have to ask.
    Is the internet in your garage 2.4 GHz?
    Is the security WPA2?
    Did you program the security key into the car?
    Is the internet on 24/7?
    Have you successfully connected the car to your internet?

    I have a slave wireless router in my garage and it works fine with the car.
  • edited July 2019
    It’s all yes’s. The connection works fine for communicating with the car, and firmware updates install without problems. I also left the car in the garage for, maybe, 36 hours once and still nothing. I also connect it to a decent WiFi when parked at work with no luck. 6 GB is a large file to download at once so they should have a better process for this. If it has to download in parts and rebuild the file once it’s done then that’s what should happen but this is immature service, at best.
  • edited November -1
    Its not triggered from your end, Tesla triggers firmwares based on on location, and version.
  • edited November -1
    @kram, it's not firmware, it's a Navigation Maps update. The display says it will update when connected to WiFi. The car is connected to WiFi every night or more, and it's failing to update. Tesla knows about the problem so they sent out Mobile Service to do the update locally from a laptop but the Mobile Service tech failed miserable to do an extremely simple task.
  • edited July 2019
    What SvC center?
  • edited July 2019
    Burbank, CA
  • edited July 2019
    Well, there you have it.

    No research?
  • edited July 2019
    What, this is my fault?
  • edited July 2019
    No. But a modicum of googling might suggest that you picked one of Tesla’s worst SvCs is all I’m saying.
  • edited November -1
    It’s the one near me, conveniently between my home and work. The next closest is not that far in miles but some of the worst Southern California traffic is between me and it. But if I have a big problem in the future, maybe it’s worth the trek. Thanks for the heads up.
  • edited July 2019
    Has anyone had problems with backup camera disappearing everytime or almost everytime the car is parked. I have a 2018 Model S 100D I picked up on Dec 31, 2018. From the 1st day the BUp camera disappeared and the dealer said to just reboot the system by holding down the 2 buttons on the steering wheel because all I had when it disappeared was a white screen with 2 ghost streaks where the bup guide lines would have been. Anyway, it worked, but since then everyday almost 90% of the time, the bup camera disappears requiring a reboot, somedays, 3 or 4 times a day. I have had a couple of updates, but nothing has been mentioned, and it continues. Anyone else report such a problem? and what is the permanent fix. My sister picked up her Model X the same day and she has not had any problems with the bup camera disapearing.
  • edited July 2019
    @kartflyr - Sounds like something is wrong. I suggest making a service appointment and having Tesla take a look. It may need a new camera.
  • edited July 2019
    i Use the Torrance one as i just took delivery on my Tesla 75D 4 weeks ago and had some issues with the body (rear panel semi detached, etc), my initial experience was quite good, a stark comparison to the delivery which was not great (marina Del rey) If you can try this location.
  • edited July 2019
    Problem solved by leaving the car in the garage all weekend! Seems the download completed from Friday night to Monday morning, and went to work with Navigate on Autopilot this morning! A bit of a wait but very cool...
  • edited July 2019
    @kadakn01, thanks for the recommendation!
  • edited July 2019
    I've had nothing but problems with service and customer service since leasing my second Model S. The first time was wonderful. Now, it is horrible. I was told that I would have 6 months free supercharging only to be charged the first time. I had a flat tire and they lost my wheel and I went running all around trying to make sure I didn't have to pay for the loaner. Two months later, still no wheel. When I turned in my lease, the Burbank service center forgot to tell the bank that I turned in the charging cable and extra key. And I cannot get my car to connect to the internet despite my first one connecting just fine in my garage. The gaps in the windows make driving on the freeway noisy. I cannot ever find someone to speak with and I cannot leave messages because the mailboxes are full. The Burbank service center is so jammed packed and people are working all sorts of crazy hours. I'm so disappointed.
  • Wow, just read this entire thread. Same problem just after HW3 update and WiFi connected. Waited and nothing happening. Tried taping software update ‘advanced‘ button 3 times and maps navigation data stared download automatically. Now shows a software download bar advancing.
  • edited June 2020
    I drove two counties away to Santa Barbara, after scoping out the nearest 4, and being underwhelmed. I did Google the 4 SeC's as NYKTA suggested.

    My first service there at SB was great! However they did damage my dash trim slightly at MCU corners and failed to secure dash panel.

    My second service was for a major problem that required pulling the HV pack. After two tries, they found and fixed the problem. When I got the car home had a good look and could not find and damage, but was glad I had covered the driver's seat with a towel.

    Looked under the car and found over a dozen missing fasteners. Only a few were trivial plastic rivets. The bolts holding the HV pack to the subframe plate were 1/3 missing, and 1/3 loose.

    This kind of repair quality I would expect at a second tier repair shop.

    After two weeks, was able to get the missing parts ordered and a competent Mobile mechanic made it all right. When pair of screws were not found, he took them of the underside of the service vehicle!


    Tesla will not take care of the older cars in the future. It is up to us. Make contacts within the SeC organization, and support the developing 2nd and third party repair shops and parts sources.
  • edited June 2020
    "When pair of screws were not found, he took them of the underside of the service vehicle!"
    That, there is the best reason for using Teslas as service vehicles. A full complement of parts, right where they should be.
Sign In or Register to comment.