Model 3

DashCam not recording continuously

I have been using the Dashcam facility of Model 3 for a while. I have a Fat32 formatted 128GB USB drive. Initially i used to check the recording every other day to confirm if the events of the day like drive to and from work, time in the parking lot is being recorded properly. I then forgot about checking the video for a while till last week when i found out someone had dinged my car in the Parking lot at work. When i got home that day and inspected the drive (it was about 28G used) i noticed that the recording has not been done for the Drive into work and for the time the car was parked for that day. It had recorded the drive home. When i checked for last 7 days i saw it hadn't recorded for few days (weekdays when i use the car) and for days where there was some recording it was incomplete or sometimes it wouldn't open the file. I even tried enabling Sentry mode the next day and i saw the same behavior. I open a case with Tesla 3 support (Sunnyvale), met with a Service advisor who told me that he would need the logs to be analyzed by some specialist and they would let me know why the recording has been irregular and messed up. Its been few days now and i havent heard back from them. I have called up few times, left messages but no response.
Please let me know if you have faced this issue or if you know of any solution here?
I formatted the USB drive yesterday and drove the car into work today. When i inspected the drive i see that the video for the morning drive and most of the parking timeframe is not available. The last 1 hour in parking lot and the drive home was available.


  • edited August 2019
    Dash cam caches files in the recent folder and then they are overwritten after one hour of recording by a first in first overwritten protocol. Dash cam video isn't moved to the saved folder unless you manually save it by tapping on the dash cam icon. It will then move the last 10 minutes of cached video to the saved folder.

    Sentry mode "events" should be saved to the saved folder automatically.

    If you are missing files it may be that the write speed of the drive isn't sufficient. Generally files that won't open are corrupted files or files that don't have a full minute duration and were not properly closed out.

    Before removing the drive do you pause the drive by holding the dash cam icon until you see a pulse of light under your finger and then wait until the red dot on the icon turns gray? If not you aren't properly removing the drive and it can result in unreadable files.

    In the manual:
    Dash Cam page 65
    Sentry Mode page 120

    It might be worth reading, so you know how to use them and what to expect.
  • edited November -1
    Most of the time if not all of the time the problem is due to the drive, read this concerning bad drives, counterfeit drives, formatting, etc.
  • edited November -1
    I'm not sure its the drive "most of the time" and definitely not "all of the time." I've tried USB thumb drives, microSD, and SSD, and they've all been exactly the same. If it was write speed or any other problem with the drives, there would be at least some improvement (or worsening) from one drive to the next. I'm sure SOMETIMES its a bad drive, so I don't doubt the people who have seen an improvement after changing drives and its probably a good idea to try getting a faster drive if you haven't yet. There are also plenty of people, like myself, who have tried several very fast drives designed for video recording that still don't yield perfect results (not that I expect perfection from a free software gift, but it would be nice).

    There's a pretty consistent pattern being reported that people are having more problems with sentry mode videos than they are with dashcam. Dashcam ALWAYS records and once you reach an hour of footage, it is also constantly erasing files as well. This should be more demanding on the drive than Sentry, which records intermittently and never erases old files. My experience, and the experiences reported on the forum, don't really fit that well with this being a drive problem, in most cases.

    Even if it was a problem with drives not being able to write fast enough, Tesla could increase the video compression to eliminate this problem, if they wanted to. In the same way Netflix and other video streaming services will automatically switch quality to match your available bandwidth, Tesla could test the drive and adjust compression accordingly.
  • edited August 2019
    Yes, not all of the time but I have been running the same 128GB drive since last year and have had no issues. I purge the saved files folder about once a week and it keeps going. But, yes, if you have eliminated variables associated with it possibly being bad drive or user error then a call to service would be my recommendation.

    In terms of what Tesla could do that is not what we are dealing with currently, and as I mentioned My 128GB drive has been working fine. YMMV.
  • Thanks for the feedback @gmr6415 and Magic 8 ball. As you have mnentioned i didnt read the manual thoroughly and thats my fault. I will try the steps mentioned in the manual and check if that helps. I did get a call back from tesla today and they mentioned there is a bug in Firmware against Sentry mode where it may impact the recording of the videos. I asked for more information and will post the same here when i hear back from them.
  • edited August 2019
    I can't add much more than others above, but some owners are not aware that when you do a manual save or when sentry mode saves video, it takes it from the recent folder and MOVES it to the saved folder. It is not a copy. At first glance, it may appear there are gaps in the saved folder, but if you were to combine the two folders, you should see a solid hour of recording.
  • edited October 2019
    With V10, my sentry mode files appear under Saved Files, however, there are many time gaps. I park from 8-3, and the files show 4 sets of files generally, from 8-8:15 or so, then a gap to 10:00-10:30, then more gaps, with some footage from 1:00-1:30... This is just an example. Other days, I have different gaps, but I don't seem to ever get an entire day's worth of recording, even though my drive shows over 50GB of data remaining. I can't find/figure out how the car decides to record in Sentry mode...??
  • edited October 2019
    Asabatelli: What you are seeing is normal Sentry Mode recording. When parked, it does not record continuously (assuming it has been activated), but is triggered when a "sentry event" occurs. This typically happens when someone walks in the immediate vicinity of the car - - it is not triggered by seeing motion away from the car. In the event an "event" is triggered, it saves the 10 minute period prior to and shortly after the event "ends" into the SentryClips folder. If you look at the last 1-2 minutes of the 10 minute series of videos, you should see the event which triggered the "save" function. Therefore, if no "event" occurs, there will be no "save" of sentry video. It is therefore normal to see time gaps (sometimes large) between sentry clip videos saved to the folder.
  • edited October 2019
    Note - - in my second sentence I should have said "Wen parked, it does not SAVE the files continuously in the SentryClips folder,...." It does record continuously and saves these to the "RecentClips" folder, but they are moved (and saved) to the SentryClips folder only when a "sentry event" occurs. Video clips in the "RecentClips" folder are overwritten after one hour of recording.
  • edited October 2019
    Since the latest update, I do not even have the dashcam icon on my touchscreen. Any ideas about what to do.?
  • edited November -1
    @Johneg: Try rebooting, and if that doesn’t work, remove the USB and check the drive on a computer to make sure it isn’t corrupt. I had a problem today after installing V10 where my music USB wasn’t showing up, but a reboot fixed it.
  • edited October 2019
    Johneg: I assume you have the "TeslaCam" folder in the directory of the drive? If not, dash cam won't see the drive. Also, if you are using a flash drive, it could be causing trouble due to inadequate write speeds. If you are using a flash drive, try using a high-endurance MicroSD card (mine is a 128 GB SanDisk SDXC card).
  • edited January 2020
    Somebody rear ended me today on a bike - luckily low speed and nobody got hurt. When I looked at the video on the rear camera I discovered that the cameras only record for 57 seconds out of each minute. And for me, the 3 missing seconds started about half a second before the biker ran into me. The next clip started about 3 seconds later, but the MOST important 3 seconds were missing. It's an great feature to be able to access recordings all around the car for situations like this - however, for me due to bad li
  • edited January 2020
    cont from previous post... due to bad luck, my recordings are missing the most important 3 seconds. Maybe the engineers could work on the clip switching software to eliminate or reduce the missing frames from the car cameras? Ideally all the frames would be present, but if they at least minimize the missing frames down to as few as possible, it would be a significant improvement. In my case it's not that big of deal - only lost out on a chance to post a viral video LOL. But the missing 3 seconds could come at a time that some critical event happened - which would be real bummer for someone.
  • edited November -1
    @joe: Did you touch the dashcam icon to save the video, or are looking in the RecentClips folder? If you saved the video, the video will be in SavedClips. I haven't heard of any other reports of 3-second gaps in the recording.
  • edited January 2020
    Hi EVRider,

    Thanks for the rapid response.

    I was looking in the RecentClips folder.

    I took a look to see if this might be a one off event. But no, it's very consistent for all my cameras. It's very easy to prove that there are roughly two missing seconds:

    - Look at the start time of consecutive clips from the same camera
    - All of the create times for each of clips from all of my cameras are 60 seconds apart
    - Look at the length of each clip and you will see that the length is 58 seconds

    If the videos from all the cameras are created every 60 seconds but the length of all the videos are 58 seconds, then there must be 2 missing seconds from all the videos from all the cameras.

    I've looked at videos before and I never noticed the missing 2 seconds of video so it's not surprising to me that nobody has noticed it before. The only reason I noticed it is the missing two seconds was during a critical event that made the missing time obvious.

    I'm using a high quality USB drive, so I'm pretty sure this is not an issue for just me because of the USB drive I'm using. Can someone else check the start times and lengths of consecutive videos on their system to validate this is a software issue and not an individual USB drive issue?
  • edited January 2020
    I suspect the software is written with a single memory buffer for each camera.

    Once per minute, the software runs the following sequence:

    1) Turns off the camera
    2) Write the 30 megabytes of video data to the USB drive (which takes about 2 seconds)
    3) Reset the camera to the start of the buffer
    4) Turn on the camera

    While the camera is writing the current buffer to USB drive, there's no place to put the data (because of one buffer), so the data is lost.

    A simple design that would not lose data (or very minimal amounts of data):

    Instead of one video data buffer, use two buffers per camera - bufferA and bufferB.

    Once per minute:

    Assuming we are currently writing to bufferA
    1) Turn off camera
    2) Point camera to bufferB (can be done almost instantly)
    3) Turn on camera using BufferB
    4) Write data from bufferA to USB drive

    So by alternating buffers, we always have a place to write camera data without interfering with writing data to disk from the other buffer.

    This simplistic design uses double the amount of memory. If this is a problem, it would be possible to use a lot less memory at a cost of a little more software complexity, where you have an extra buffer that's big enough to hold, lets say 5 seconds of video, During the time we're writing the USB data to drive, we swap the camera for a few seconds to the smaller buffer. After we're done writing the big buffer from the last video segment, we copy the small buffer video to the start of the big buffer, and then switch the camera to continue to write after the end of the small buffer data. This swaps should be possible to do fast enough that either no frames are lost or maybe 1 or two frames, which would hardly be noticeable.

    A vast improvement over losing a full two seconds of video every minute!!
  • edited January 2020
    Ok, I'm not getting the same results. I had some footage from a few months ago and the footage seems seamless between clips. I've paused it at the very last image and the first image of the next shot (front camera) and I don't see any loss across action in front of the camera. I'm using the SentryCam player and for the clip, it shows 59.2 seconds on the last frame - yet going from one clip to the next feels seamless. If I've lost something, it is under 0.5 seconds, not 2 seconds.

    Now if I bring up a single clip in Windows, it shows it being 59 seconds long. A different clip showed 58 seconds.

    I'm not 100% sure, but one issue is the compression may only be able to create a freeze-frame once every 250 mS or so. When running video, the compression may expand to the end of a keyframe, but you may not be able to stop on a single video frame. I'm not up on the newest compression, which I think has variable keyframes.

    I only examined one video clip picked at random that had some action in it. My thoughts for the reasons you are losing a couple of seconds include a software change has screwed this up, or the flash memory you are using can't keep up and lost a few seconds.

    Perhaps others can chime in with their results.
  • edited November -1
    Same issue for my vintage Apr 2018 Model 3.
    About a 3 second gap between clips.
  • edited November -1
    I had an incident today where the ice on the roof of the car in front of me came loose and landed on my car. Luckily no harm was done, but the dash cam did not record the few seconds during the incident. I can see the car with the icy roof on one take and then a clean roof on the following take, but nothing in between. I thought it may have been because I had applied the brakes suddenly, but I can see that the problem might be this 2 or 3 second gap others have experienced.
  • edited January 2020
    Thanks arkreymer and mcorro for confirming the issue. I'm using a new super fast USB 3.0 drive, and the fact that it's very consistent across all my cameras all the time along with others seeing the same problem makes me think it's a real issue. My Model 3 is vintage March 2019.

    As great as having the camera recording feature is, I think it's a real problem when there's a 1 in 20 chance a particular incident will be missed by the recording.

    If this is a key frame timing issue, it should be super easy for the engineers to adjust the time frame to be a multiple of the key frame interval. The gaps in the video from my car are very consistently way to long to be explained by a 250 millisecond keyframe gap - so I really don't think this is the issue.
  • edited January 2020
    Interesting observation about an alleged 2-3 second gap between video recordings. I review my dash cam and sentry video often (usually at least a couple times per week), and I never see more than a very small (maybe half second) gap maximum. Like TeslaTap, the videos are nearly seamless for my dash/sentry cam.
  • edited January 2020
    I have the same problem with the 2-3 second gap between clips. Noticed it with my old usb drive, which the car eventually complained about being slow. After upgrading to a SDD with a high speed interface, still see the same gap.
  • edited January 2020
    I can confirm the 2-3 second gap problem is very real.

    We were in a serious accident with the Tesla S (Raven) today where a truck driver did not stop for traffic on a main road where we were driving, but dashed out to cross the road and caused a collision.

    Luckily we escaped pretty much unharmed by sheer luck while the Tesla was totaled.
    We became very interested in studying the multi camera recordings from the few seconds of collision but found the event coincided with the camera-to-memory-card write operation data loss that several owners have reported !

    We could see the first second of collision that represents the end of a buffer write to memory card, BUT the next buffer written to memory card lacks some 2-3 seconds from the recording so that the full 4-5 seconds of the crash sequence has not been written to the card.
    This was very disappointing for us to realize and can really represent a serious flaw when it comes to documenting an incident. The same buffer write bug was seen for all of the four camera video file sets.

    Q1: Does the car diagnosis system record these video streams to some other location than the memory card so that TESLA Inc. would perhaps have access to an uninterrupted version ?
    Q2: Is this video storage data loss problem being addressed by Tesla ?

    The particular memory card we use was especially chosen to be high performance so we do not suspect the video loss to be caused by a slow access card.
  • edited January 2020
    Just got my Tesla 3 this week and I cannot get my dash cam to operate ,I have formatted a 32,64 and 128 drives with Fat 32. I plug it in and nothing happens? Help!
Sign In or Register to comment.