Model X

Auto driver door unlock stopped working

After the recent upgrade to version 10 , my MX stopped unlocking the driver door ( not auto present ) when approached with a working key box. The door would just unlock so that pressing the handle would open the door. Now, I have to reach out for the key fob and double click on the top of the key fob to unlock the car after which the mirror swivels out and door unlocks . Is this a glitch that version 10 introduced ? The mirror auto swivel out and the door unlock was working perfectly when approached with a working key fob.

Also to mention I tried Smart summon once. Did this cause this perfectly working functionality of door unlock and mirror swivel out to stop working ? Any pointers and similar experiences after version 10 upgrade or use of Smart Summon ?


  • edited November -1
    Interesting. I do not have FSD, but picked up my car last Friday. The auto present driver door has been working flawless until I downloaded V10 today as well. I hadn’t even installed it, just downloaded and ready for install when it stopped working earlier today. After software update, it still does not work.

    Hopefully Tesla is aware and working on it.
  • edited November -1
    Auto door still working for me on V10.
    Can you check your settings for auto presenting door? Sometimes settings get changed after an update. Also do a reset.
  • edited November -1
    Unfortunately a reset didn’t do it. It is set to on as well. I have a “game update” in download. Perhaps there’s some bug fix within it that might fix it after install.
  • edited October 2019
    Same thing happened to me. Actually it was working just fine after the V10 (11) download and after 11.1 download then this morning(days after both downloads) it let me in the car like normal. I charged my PIN(maybe a coincidence) but right after that the doors no longer unlocked as I approached. I have to manually unlock with key fob. Also the disable and enable PIN is acting odd, won't let me change until I put in my TESLA credentials like I forgot my PIN, even though it had been disabled.

    If any one figures out how to get the keyfob to once again unlock the car when approaching let me know. Might have to have TESLA remove the keyfob and reinstall since you can't do that yourself like on the model 3.
  • edited October 2019
    Got mine working again, Not sure which step did it Maybe I didn't notice passive entry got turn off(odd). But I did a hard reset "four finger with brake" method and once back up checked that it would take PIN and go into drive then reset passive entry and now it works again.
  • edited November -1
    @dkanq: Do you always leave PIN on? I did a reset myself. I didn’t hit the break, but it reset. Not sure that would do it. No harm in trying
  • edited October 2019
    @freemarket there are a number of options to reset (or at least some people believe so, I an not knowledgeable to judge and there is a bit skepticism about the options). I used option #3 below and you can tell there is a difference because the instrument cluster will also reset. I have heard this referred to as a system reset in other blogs.. and the four finger reset because it requires pressing four things simultaneously. Now I have also seen the folks believe it can be accomplish by just pressing and holding just the two buttons above the scroll wheels. I choose to press all four.
    Option 1: The scroll wheel reboot
    Option 2: Top button reboot (MS and MX only)
    Option 3: Full steering wheel reset
    This reboot is a little harder to do. You need to be sitting in the car with the doors closed and not open
    them for the duration of the reboot. Place your foot on the brake and keep it there, although some
    believe this is optional, it does no harm.
    Now press and hold both buttons above the scroll wheels, and the scroll wheels on either side of the
    steering wheel (MS and MX) for up to 10 seconds and the drivers dash/screen will reboot .
    Wait, keeping your foot on the brake. Eventually the screens will restart.
    Option 4: Full power down and restart
    Options 5: Factory reset(not recommended
  • edited October 2019
    Refence for list above is TESLA INFO website I found them googling don't know their reputation but I have seen other discussions that have similar info.
  • edited October 2019
    Issue resolved. As dkabq states, the passive entry setting was turned off , I had to enable it and set a pin for extra safety and even without any type of reboot , the driver door unlocks and mirrors unfold when approached with a key fob on.
  • edited October 2019
    Mine stopped working as well. Have tried rebooting the system but no luck. Tried calling Tesla but the waiting time to talk to a representative is over an hour. Any other tip on how to fix this issue?
  • edited October 2019
    Unfortunately mine appears to be an even bigger issue. I’ve had the car two weeks and really didn’t use the doors to physically unlock the car, always the fob. I discovered that not only does the driver side not auto open any more, I can’t open any doors the majority of the time without the fob. Including the passenger side when I approach and the car unlocks. I have to double tap the fob to open the drivers side and then I might be able to open the passenger via the door, but most times I’ve have to double tap the fob again to open it.

    I’ve called and expect a ranger to come next week.

    I stopped going the customer service route. Opt for Delivery and tell them you just got the car (If that is the case) and need service on the phone for help. The delivery center has walked over to the service center for me several times and gotten me a call right back within minutes.

    I’m sure they’ll get it fixed. Hopefully it’ll be this next week.
  • edited April 11
    Is there a resolution for this problem? I have a 2013 MS ""without"" the tech package and for six years I would just push on the drivers door handle when the car was locked (with a key fob in my pocket) and the handles would present. Now I have to double click the fob to unlock the car. I have tried all of the above fixes (except factory reset) and no joy yet.
  • edited April 12
    @pricee This is the model X forum try the model S forum
  • edited July 4
    collected new X. Autopark won't work and whilst the car recognises the key as you approach it will neither auto open the door nor can you press the handle. You have to click the fob

    service engineer can't fix wither and says its a firmware issue

    Has anyone else had a situation where service say sorry but we can't fix it. next service appointment isn't until August but i only have 7 days to return the car
Sign In or Register to comment.