Model 3

Can’t sign in to Google account

So I am considering changing streaming services from Hulu to YouTube TV. I just started the YouTube TV 5-day trial and I found I cannot get it to stream in the M3.

Apparently for YouTube TV to work in the M3 Theatre, you have to sign into your Google account where subscription status with YouTube TV is verified. The M3 browser appears to have insufficient security for signing in to Google.

Does anyone know of a work around? The free YouTube app works fine but the paid YouTube TV app has the sign in problem.

Comments

  • edited December 2019
    Open the YouTube app. Then click the drop down menu on the right side (9 squares) and you will see YouTubeTV and YouTube Music.
    Enjoy YouTubeTV in full screen.
  • @alnawazr - I tried that and YouTube TV launches. The error occurs when you attempt to sign in. That’s when you get the error message about the browser incompatibility.

    This also means that you cannot access your GMail account.
  • edited December 2019
    I am able to login with my google account no problem. I have a YouTube Premium and logged in for that as well as have used gmail on my M3 console.
  • edited December 2019
    I was able to sign into Google with my gmail. And also to you tube.
  • Thanks guys, I may need Tesla service to take a look.
  • CSTCST
    edited December 2019
    I tried to login, but it wanted to send me a two-factor code and I didn't have my mobile device so I canceled. Then Google lock me out of my accounts and forced me to reset my password, so be careful if you don't have a device nearby.
  • Thanks CST, although I can log into Yahoo and retrieve those emails, the Google site will only allow me to enter the Email address and password then complain that the browser needs updating before it will attempt sign in. Other than Google sign in issues, the browser and other streaming services like Hulu work fine.

    I went ahead and made a service appointment and included a picture of the display with the error message shown. Hopefully they can remediate with an OTA push or perhaps they can give me guidance on changing some configuration setting. I would hate to have to lose time at work just to bring it in to the SC for this.
  • I found a solution to the Google sign in issue I am having, which is preventing me from enjoying YouTube TV in the M3. Apparently this issue has been reported by others and someone posted a work around.

    You simply browse to plex.tv and choose log in with Google. With the plex.tv screen, the Google sign in works. After you are signed in, YouTube TV works and the emails in the Gmail account are accessible.

    https://teslamotorsclub.com/tmc/threads/unable-to-login-youtube.175623/
  • edited January 26
    I can’t log into Google for YouTube Premium in my 2020 MS either.
  • I don’t know why some folks can log into Google directly without issues or error messages while others like me and rsvandyke cannot.

    The work around with Plex.tv has been successful for me and others. If the Plex.tv log in method doesn’t work then the only recourse is to schedule a service appointment and have Tesla figure out how to fix it.
  • IoTIoT
    edited February 11
    Thanks Lonestar. I have the same issue. I’ll try it tomorrow.
  • The plex.tv work around doesn't work in my 2020 M3. I just tried it. Perhaps the workaround doesn't work with the latest software?
  • edited April 5
    I just tried the plex.tv work around yesterday in my 2020 M3 and it worked. I clicked to sign in to plex, then said sign in with google... then I was able to type in my e-mail and password. When I went back to the internet browser I was signed in and also signed in with youtube. Thanks for the work around!
  • edited November -1
    Flagged
  • edited April 27
    After signing into Plex website go to Google website and select Youtube from there.
  • edited May 9
    Same problem with signing into youtube/gmail/google. Lonestar, did you get a fix with the service appointment?
  • Didn’t need one. Once I got logged in via the Plex site using Google credentials I was able to access Google, YouTubeTV, etc. without any further log in requirements.

    I immediately cancelled my service appointment, but I wish the Google log in issue could be solved without the Plex workaround.
  • edited May 24
    Ridiculous this doesn’t work
  • @hurt- if the trick with Plex.tv doesn’t work and you cannot log into Google at all, then if I were you, I would schedule an appointment with the SC. You can’t fully enjoy your M3 if the bells and whistles are just partially working.
  • edited June 16
    Same log in problem with new model S. The Plex.tv trick worked.
  • edited June 19
    I have also had the same problem on signing into my YouTube account, thanks for the trick! I logged into Plex using my Google Account and it worked!
  • edited June 20
    Whoever figured out the Plex.TV work-around...THANKS!!!! You are a genius. It solved my issue with signing in to my Google account.
  • edited July 2
    Plex.tv method works!!
  • edited July 29
    It seems reasonable to expect Tesla to have a browser with good enough security to log into google. Just brought home my model Y, really surprised by this problem. I'll use plex.tv for now but its a Kluge.
Sign In or Register to comment.