Energy Products

Backup Only unable to switch to Self Powered

My app has worked fine for two years but yesterday it started NOT changing the power walls from Backup Only to Self Powered when I select the appropriate button. My power walls have stayed at 100% for two days which is great but they are not powering the house after sundown which I’ve requested them to do.
Has anyone else experienced this and found a solution? Tesla support says to uninstall the app and reinstall, turn off the phone etc... tried them all no luck.
Thank you in advance.


  • edited January 13
    Have you tried it from a different device?
  • 18R18R
    edited November -1
    Same issue. On 1.43.3 now.
  • bpbp
    edited January 13

    1. Connect to the Tesla Gateway through the browser interface and try to stop & restart the system
    2. Try rebooting the Tesla Gateway
    3. On the mobile device, try deleting the storage/cache for the app - and if that doesn't work uninstall and reinstall
    4. Try installing the app on another device
    5. Power down the Tesla Gateway - which may require disconnecting the Gateway from grid, solar and PowerWall (our installation has panel switches for all of the power sources)

    Though the best recommendation is to get someone on the phone from Tesla - and go through the steps while they are on the phone, to ensure you don't do anything that might cause permanent harm to your system.
  • edited January 14
    Same issue here :(
    How do I reboot the gateway? I managed to connect but there is only a Stop System button. Stop and then start is considered reboot?
  • edited January 14
    The gateway has a blue light with a reset button. You need to use a pencil to push the button. It will reset it. Don’t play with flipping the breakers... it won’t work...
  • edited January 15
    If I reset it do I need to configure it or it will still be configured? In other words is that a reset or restart?
  • edited January 15
    I just hit that reset button and I can confirm - settings preserved. System now works properly so reset fixed it for me!:)
  • bpbp
    edited January 15
    Settings are preserved during reboots.

    While I haven't tried it - it should be possible to power down the Gateway by throwing the breaker switch in the Gateway (at least ours is wired as the grid disconnect) and also disconnecting the power from the solar panels and PowerWalls - which would deprive the Gateway of power from any sources.
  • edited January 15
    The problem is that the communication cable between the gateway and the battery carries data and power. The comms are powered even if you flip the breakers. I’m not sure that it will perform a reset as clean as pushing the reset button...
  • 18R18R
    edited January 16
    Support told me a firmware update will resolve this. Pushed out in "a day or two".
  • edited January 16
    I have the same issue, the Tesla call center told me that it was a firmware issue that they are working to resolve. However I’m thinking about trying the gateway reset button as it its been like this for almost 2 weeks.
  • edited November -1
    Follows is my message to support (also included the various versions of firmware and apps) for the same issue:

    My powerwalls are working but I am no longer able to update any of the settings. I had recently gone to a new time of use plan with my utility and was attempting to update the price schedule (and reserve) settings. The updated settings are accepted by the app and all data is interpreted as per the updated settings, but the underlying performance of the powerwalls has not changed.
    For example - I changed the reserve setting from 60% to 50% and this shows on the app, but the powerwalls stop supplying power at the old 60% setting during peak time. Likewise, changes to weekend rates and schedules had no effect.
    I have logged directly into the gateway assess connectivity (active connections confirmed). I did not do a stop/reset or any other manipulation of the gateway. I have logged out of all instances of the app (it had been installed on several devices) and deleted the app, followed by a full reset of the primary IOS device - which is the only device where the app was reinstalled and login reestablished. Problem not resolved.
  • edited November -1
    Reset your gateway. It should solve the problem.
  • edited January 22
    I called Tesla, they said it's a KNOWN bug and should be pushing an update out sometime this week. It should correct the issues we're having with switching between the different customization's.
  • edited January 22
    I wish there was a flag we could set to stop all of the automated firmware updates to my Powerwalls that WERE WORKING PERFECTLY BEFORE.

    Tesla...stop breaking my Powerwalls with your incremental "improvements" that have nothing to do with me. I don't care if 1.43.3 fixed "grid balancing" issues specific to Australia. I'm in America. Leave mine alone!

  • bpbp
    edited November -1
    Hit this issue yesterday when doing some testing. I set the PowerWalls in to backup mode to force them to charge - and even though I put the app back into self-powered mode, the PowerWalls continue to charge.

    Resetting the Tesla Backup Gateway worked - and returned the system to operating as expected.

    Clearly a software bug that Tesla should be able to fix.
  • edited January 25
    I had no problems with any aspect of control until that point, could not adjust rate schedule or most other settings. It was frozen at the last change and would not execute updated settings.
    Just got 1.44.2 firmware and the control issue is fully resolved.
  • edited January 25
    One more nuance - I added ethernet connectivity to my gateway at the time of installation so that I had triple redundancy (cellular+wifi+ethernet). All three were quite stable until that time, the wifi got pretty flaky and would disconnect (and not reconnect) for unknown reasons. Obviously not a big issue because of the ethernet, but irritating nonetheless. The 1.44.2 update brought wifi back on line. No idea if there was an actual fix or if this was just because of a connection reset at the time of the update. Regardless - wifi is back on with 1.44.2
  • edited January 26
    Hi guys - I had an early PW installation that didn’t include the gateway. I am now considering installing the gateway for about £1300 but am keen to understand the additional features such as forcing to charge at certain times and holding onto reserve for more expensive periods of the day. I am just switching to Octopus Agile and would like to Best Wishes, able to turn on/off PW to use grid energy is that possible with a gateway? Cheers Nick
  • edited January 26
    Ignore Best Wishes, that’s an autocorrect meant to be, be!!!
  • 18R18R
    edited January 26
    On 1.44.2 now, seems more responsive.
  • bpbp
    edited January 30
    Ran into this problem again yesterday when doing an fully charged PW/off-grid test.

    After returning to grid power, the system was stuck in backup mode and refused to pull power from the PWs, leaving our 4 PWs at 98%.

    I brought up the TEG's web page and noticed that it didn't always reflect the changes being submitted from the Tesla app. However, even though the Tesla app and TEG web page indicated the system was in self powered mode, the TEG refused to pull power from the PWs.

    I noticed that changing the reserve % in the app didn't always get saved in the TEG - requiring multiple attempts to change the reserve % before the TEG accepted the change.

    I called Tesla Energy support, and after an extended wait, while I was on the call, the TEG finally started to pull power from the PowerWalls.

    Overnight Tesla pushed 1.44.2 to our TEG - and hopefully that will resolve this problem.

    Since the test I ran failed (the TEG was setting the power frequency so high that our UPS systems and some devices refused to work during the test), after Tesla makes changes to our configuration, I'll rerun this test, and see if we still get stuck in backup mode after we return to grid power.
  • edited January 31
    I just received 1.44.2 as well. I'm in So. CA.
  • edited January 31
    Just adding it here for others, had the same issue where updating % or changing the "modes" in the app wouldn't save on the physical hardware.

    Version: 1.43.3
    Issue started on:
    01/30/2020 (possibly it actually started on 1/29/2020 as that's the last time I customized the settings)

    Attempted the following:
    1. turn off/on the powerwalls => same issue/bug
    2. Reset system via the TEG's web page => same issue/bug

    What finally worked was resetting the actual physical energy gateway ( Powerwalls were on and house load was supplied by them). I might had reset the Physical TEG multiple times as I couldn't really feel the reset button on it...

    But it's working now.

    One thing that I noticed, is that when the bug was present, the TEG summary page would NOT show the Powerwall information and their serial numbers etc. Once reset and working correctly, the values would be there (I have 2 Powerwalls).
  • bpbp
    edited November -1
    The reset button appears to be towards the lower portion of the opening - below the status light.
Sign In or Register to comment.