Model 3

New album on USB drive not showing up in car

edited November -1 in Model 3
My USB drive has about 15 albums on it that i love to play. I downloaded a new album from a new artist to my laptop a few days ago. Then took the usb drive out of the M3 and plugged in to the laptop and copied the new album over at the same level all the other albums are. I was able to play songs from the new album on my laptop. But, when i returned the usb to the car, it did not show the new album or artist. All the others continue to play fine tho. the new album is mp3 format just like the others and every other attribute seems identical too. I have done a soft reboot and a hard reboot, and neither fixed things. What am i missing here?


  • edited November -1
    Reboot without the USB inserted, then insert the USB. If that doesn’t work, try using the other USB port. Sounds like it’s not reloading the USB. I have the opposite problem: sometimes my car reloads the USB when it doesn’t need to.
  • edited March 26
    On the Genre menu, did you try File and see if it appears in the file location? One thought is the id3 data is missing on the new mp3s so it will not index or show up in any other categories.
  • edited March 27
    Thanks EVrider and Teslatap -

    Teslatap - not sure exactly what you are saying. I had already tried going to genre jazz (since it is Mile Davis) and did not see anything there. after reading your comment i went back to the car to see if there was any 'file' button or someway to see tunes rather than their title. i couldnt find it. I also tried checking every other genre but none of the tunes on the new album showed up. guess next thing i will try is removing the usb and rebootin ad EVRider suggests.
  • edited November -1
    If that doesn’t work, you should verify that the files have “.mp3” extensions, and that they’re really mp3 files. Tesla’s music player is pretty picky that way.
Sign In or Register to comment.