Model X

2016 model X touch screen blank, MCU issue ?

I think my 2016 Tesla Model X 90D has the dreaded MCU failure. The car is at 56K miles and firmware version 2020.36.3.1
The first time it happens was on 7/24. When I returned to my car, the touch screen is blank. I tried the two scrolling wheels to reboot. same blank screen. The dash monitor shows "Please wait while vehicle systems power up". I left the car and return the next day and the car is fine now. I thought that is over.

But on 10/11, while driving, I noticed that the navigation is not responding and tried the 2 scrolling wheels to reboot the system. I got a blank touch screen. The screen did not come back until 1 hour later. on 10/12, I took it to the service center and the rep told me that is a results of 4 years of navigation history in the memory. He offered 5 solutions
1: manually delete the entried in the navigation bar (It did not work as I found later)
2: they erase the entried in the store, $156
3: they replace the memory module, $400
4: they replace the MCU, $1300
5: they replace the MCU with MCU2 and touch screen, $2500. but the AM&FM&XM are gone.

I chose the option 1 and deleted more than 200 addresses manually. but on 10/19 I noticed the loss of LTE/WiFi connection to the car. Later when I reboot, the same touch screen blank returned. about 1 hour later, the screen came back and I noticed that the deleted address showed up on the navigation search menu. So option 1 totally did not work.

Finally, I did my home work and found this link https://teslatap.com/articles/mcu1-flash-memory-analysis-and-failures/ and the forum discussion. It looks like I have a bad eMMC chip and need the option 3. Do I need to replace MCU ?

Comments

  • Options 3, 4, and 5 are all good options. The replacements all use a larger and newer generation of memory that should last many times longer - more than the life of the car.

    Option 2 may work for a few months, but the problems are going to come back.

    Also, Tesla is working on a separate retrofit to include FM/XM if you go with MCU2. It requires a new FM/XM radio module and harness. We think the price will be $500, but that's not official yet.
  • TeslaTap, thanks for the comments. About 5 hours after the reboot, my phone Tesla apps lost connection to the car. though I can still navigate on the touch screen. That was not the case right after reboot. Does it mean there is also a CPU issue in addition to the eMMC ? Or is that part of the symptoms of eMMC failure ? I am hesitant to go for option 4 as the value over option 3 is not clear yet.
  • Yep, just another sign. The eMMC stores all the code, settings, and other data. When it starts to get corrupted, it's hard to pin what quirks may show up. If you're not considering option 5, I'd go with option 3. There is no need to replace the MCU.
  • Thanks. That is what I will do next.
  • @EddieCA Thanks for providing the available options available to owners today. Please do provide an update after the memory module replacement to confirm that it's fixed the problem.
    I'm pretty sure that I'll be looking at this situation within the next few months on my 2016 MX.
    :smile:
  • I drove to the local service center and explained the situation. The rep noted them down and scheduled a appointment next week. some parts, like memory board, are not readily available. The touch screen function is gradually degraded after reboot. I first lost the internet access within a couple of hours. And then lost navigation, map update, energy consumption statistics, LTE connection over the course of a few days. Driving, charging (home charging), AM/FM radio, tire sensors are still fine. Did not test the supercharging. There is definitely something going on with the MCU. Will report back the result. stay tuned.
  • To report back on the repair. Dropped the car on Wednesday (11/4) 9am and told the service rep additional information for diagnostic purposes: the "PIN to drive" was turned off sometime ago after I noticed the blank screen issue. But it came back twice recently. I also noticed that the touch screen brightness was reset to 16% from time to time by itself. Service rep confirmed that is part of the eMCC issue and replacing the tegra daughter board can fix it.

    long story short, I picked up the car today (11/6) and everything seems to be fine: LTE and WiFi connection are fine, navigation works, voice recognition, energy consumption statistics, map update are all back. Have not tested the 2-wheel reset yet.

    The good news is that the cost is $488 including parts, labor and diagnostics. The tegra part is only about $120.

    Here is the rub: Tesla did the simple straight forward part replacement. No effort was made to calibrate and copy/paste any user data. so I have to manually calibrate the passenger side windows (it went pass the chrome when closing) and reprogram the address, profile etc. Worst yet, they did not even put all the part back, See https://photos.app.goo.gl/UHRAfBKxGEwaFhHe7. The cubby (the compartment under the touch screen) looks like this https://photos.app.goo.gl/YxHnNbWJvi2J87yeA. So check your car thoroughly before leaving the store. They are in such a hurry and I guess busy with other cars now, they did not return my messages and phone calls. BTW, I calibrated the window per this link https://teslamotorsclub.com/tmc/threads/driver-window-glass-calibration.82465/ and it works fine now.

    Does anyone have experience putting the cubby back ? the area is tight, I do not want to force it.

    Eddie
  • Cubby is held on with a tab in the back and two snaps. All that should be needed is to lift the cubby to snap into place. The snaps are very-very tight so you may need to apply a lot of upward pressure. Be sure the snaps are aligned with the holes before applying that pressure.

    I've taken my cubby out and many times (to get to the diagnostics connector).
  • TeslaTap, Thanks for the tip. I pushed it back in.

    I noticed the 2 connectors behind the cubby. one white with 4 pin, the blue one has more pins. I assume that they are the diagnostics ports. I have no needs for the data right now. But curious if any one of them provide 12v with at least 0.5A ? I have a dash camera, which is drawing power from the ODB2 port in the driver side. may want to switch to this one if possible.
  • Yep, both of these are diagnostic connectors and the 20-pin one does have 12v always on. It's actually the same circuit as the ODB-II power. I think it's fused for 5 amps.
  • That is cool. I will give that a try. Thanks
Sign In or Register to comment.