Model S

TESLA IPHONE APP NOT WORKING WITH CELL DATA

I just bought an iPhone 12, running IOS 14.1. I am using the Tesla app V3.10.9.
The app is not responding while using cell data from AT&T. But it works while I get connected through any available WIFI network.

Anyone can help me with this issue?

Comments

  • Are you sure you have cellular data enabled for both your phone and the Tesla app? For the phone it's in iOS Settings > Cellular, for the app it's in iOS Settings > Tesla.
  • i have the same issue. don't know why.
  • I am still having this issue. Can anyone or @Tesla help me with this issue ?
  • As others have said, this sounds like your iPhone has cell data disabled for the Tesla app. Go into the iPhone settings and type 'Tesla' in the search box. Select 'Tesla' and see if Cellular data is enabled.
  • I am having the same issue with Iphone 12 Pro. All settings are correct. I can only connect if I turn on Airplane Mode for about 10 seconds and then turn it off. I can connect but doesn't last long.
  • > @leonardo_93516038 said:
    > I am still having this issue. Can anyone or @Tesla help me with this issue ?

    Did you try what I suggested above?
  • I tried all the solutions proposed.
    I reset the car console pressing both steering wheel buttons in parking mode. After I deleted the app from my iPhone 12 pro and reinstalled. It worked with cell data only once, after that it returned to the same condition. It works only with wifi.
    I think is a bug of the app on iPhone 12 pro.
  • What exactly does the app do when it doesn’t work? Do your other apps work as expected without WiFi?
  • The app start and endless loop of updating with a grey banner on the bottom of the app. When I switch to wifi it starts to work in seconds.
    All other app are working fine in both modes wifi and cell data
  • I’m unable to reproduce the issue with my iPhone Xs running the same OS and Tesla app version as you, also using AT&T cellular.

    Are you using a VPN app on your phone? If you are, make sure it’s disabled for cellular data and see if that helps. Other than that, I don’t know why your phone would be unable to reach the Tesla servers on cellular only.

    Do you receive notifications from the Tesla app when your phone isn’t on WiFi?
  • I am not connected to a VPN, and I am not receiving notifications while connected through cell data.
    The app was working fine in my former iPhone 11 pro with the same IOS and ATT
  • I'm guessing it's not the phone itself, but some iOS 14.1 setting that was set differently on your previous phone. The two iOS settings I referenced in my first reply are the only ones I know of, but there might be others, so browse the Cellular and Tesla app settings and see if there's something else.

    For example, on my iPhone under Cellular > Cellular Data Options, I can turn Data Roaming on or off (mine's off), select either LTE or 4G for Voice & Data (mine's LTE), or turn Low Data Mode on or off (mine's off). If those settings are different for you, try changing them to match mine.

    I know I already asked you to check this, but re-check the iOS settings for the Tesla app (Settings > Tesla) and make sure cellular data is enabled there. The reason I'm asking is because you said other apps were working with cellular data, and this is the only setting that would make the Tesla app work differently from the others.

    Other than that, I'm out of suggestions.
  • PROBLEM SOLVED. Tesla updated the sw on the car to the version V10.2 (2020.36.11 ccacdb181f16) and started to work my iPhone Tesla app under cell data
  • Thank you all for your help and involvement with my issue. Thank Tesla as well.
  • I am having problem with both iPhone and ANdroid app connecting to my 2016 Model S for past two weeks. Tesla told me there is a known firmware glitch and they have been trying to fix. I was told this morning that they would try to push an update manually to my car. Shall see...
  • @x5liang_98208681, unable to connect to your car through the Tesla app is one of the first signs of a failing eMMC/MCU1.
  • > @akikiki said:
    > @x5liang_98208681, unable to connect to your car through the Tesla app is one of the first signs of a failing eMMC/MCU1.

    You are probably right, although the Tesla tech told me he didn't think so. I was planning to upgrade to MCU2 before this incident, so maybe it is about time to do so.
Sign In or Register to comment.