Energy Products

Tesla App does not connect to Powerwall

About 2 days ago my Tesla App would come up with an error when I tried to connect to my Powerwall. After reloading the App and logging back in today I am not getting error but not getting any power flow indications and it constantly appears to be trying to connect. I called help desk and all they did was make me reboot my wifi which did nothing and then pushed it to "tier 2" help desk. Any one have any ideas?


  • edited November 2017
    I have just had a tesla 2 installed and I can't get onto the app to view my solar usage
  • edited November 2017
    Mine was installed yesterday & worked perfectly, then today it's the same as you guys. It says "Standby", and can't view any usage, or power flow indications.
    It sounds like something is wrong on their servers. Hope the PW2 itself is operating as it should.
  • edited November 2017
    Actually... I just rebooted the gateway (cycled the circuit breaker), and it came back online a few minutes later. I did read someone else having issues with the gateway crashing a few times a week, and needing repairs.
    Hopefully it doesn't happen again to me.
  • edited November -1
    Maybe something was wrong with their server because it seems that yesterday's values were doubled. Both usage and generation.
    Anyone else?
  • edited November 2017
    10th Nov. Everything ok at 7:30 am but when checking at 11:00 app giving a connection error with a reference to one of the solar systems (we have 2 ). Switched off and on AC for solar system and gateway - still no connection - internet obviously working (I'm logged on to enter this).Any thoughts?
  • edited November 2017
    If you are using the 'phone App v3.2.1 it seems to have connectivity issues. Stop/start the App again.
  • edited November 2017
    Mine was installed on 25th September. Installer did not get it commissioned that day and in fact Tesla Support got it going remotely on 20 th Oct! Now wall is working well but app is not displaying correct info and I am trying to get installer back to check metering connections.
    At least I am not paying for electricity at the moment
  • edited June 2018
    I have the PW2 for a few weeks now. All fine until yesterday when the app did not connect anymore: "Home Energy Gateway: Unavailable" and "Powerwall Connection Error".
  • Hi all, PW2 installed but the app has always noted that the Gateway is on standby, how do I get this to move from Standby?
  • edited August 2018
  • edited September 2018
    Help, changed router/wifi password and I cannot get my PW2 to reconnect to the net and I get "site connection error" on my app.
  • edited September 2018
    Can you plug an ethernet into your powerwall backup gateway temporarily? That should get you online so you can login to the customer login and update your wifi password. You would need to go to it by using the IP address in your web browser once you plug in the ethernet between your router and your backup gateway. Or you can just email or call customer support, but they might take a little while.
  • edited January 2019
    My PW2 stopped communicating with the Tesla app.
    It was fine at 2:30PM this afternoon but nothing since.
    No errors just tries to connect but cannot.
    Tried to call Tesla support but hung up after around 15 minutes.
    Will try again tomorrow.
    The PW2 seems to be working but without the app connecting I don't know what its status is.
    Any suggestions would be much appreciated.
  • edited February 2019
    I've been experiencing this problem intermittently since mid December. Tesla support pushed a new firmware in December and followed up with a phonecall to confirm that my Power Flow data in the app was showing. It was. Then it stopped again in January. We were in the middle of one of the best "solar" days in our area, Mid Atlantic, since our system was installed in Nov/2018. Being an impatient data geek I went to the backup gateway, opened the cover, and used a screwdriver to press the reset button. That solved my immediate problem but I suspected the problem would happen again. It happened again in late January and then again twice yesterday evening and once again today.

    Power Flow data comes back online every time I press the reset button. That said, I don't think one should have to reset the gateway so often so I called Tesla Support and have been elevated to the next level of support. I was told that they would probably schedule a site visit and to expect a call in a "couple days."

    My gateway is connected via Ethernet CAT5e to a switch, which is connected to my router.
  • edited February 2019
    Mine is which I downloaded from appvalley app store :) here is the official appvalley site to get download working Tesla app.
  • edited February 2019
    I had to uninstall the app from my phone, reboot the phone, and reinstall the app. Then it worked.
  • edited March 2019
    I've tried deleting the app, rebooting the phone etc etc.

    Anyone have any solutions to this recurring problem?
  • edited March 2019
    My app intermittently fails to communicate with my beautiful Powerwall 2.
    This is may last for a few hours and in some case days,
    I am on the NBN here in Australia. The router is functioning and seems from checking to be working fine.
    (Browsing the internet to check)
    This situation happened again today. Just annoying when you pay for such a beautiful product.
    Any suggestions please let me know.
    Kind regards and thanks, John
  • edited April 2019
    I have exactly the same problem John. I'm also on the NBN in Australia and for the last 5 or 6 months my connection to the powerwall 2 was intermittent. For the last 4 or 5 weeks it hasn't connected at all.. Did you get any ideas from your post? I've tried rebooting the wifi, the phone,reinstalling the app and nothing works.Would be grateful for any ideas..
  • edited November -1
    An update. Had a very helpful phone call from Telsa Customer Support last night. They talked me through connecting directly with the gateway via the IP address.from the laptop. After a couple of hiccups it connected and displayed the the home energy use. And interestingly, the phone app started connecting again. Am monitoring it to see what happens over the next few days. A big thankyou to customer support
  • edited May 2019
    TutuApp which is an alternative to all the App Stores, be it in Android or iOS.
  • tutu app is a good alternative of app store and play store which provide paid apps to to download for free
  • I had to uninstall the app from my phone, reboot the phone, and reinstall the app. It worked for me you can try as well

    Thanks & Regards
  • I have repeatedly contacted Tesla support and have always received back a polite e-mail alerting me that Tesla would get back to me as soon as possible. A month later I have yet to hear anything except the auto response. I have since given up. I can no longer see any data on my desktop related to my energy consumption or usage. In the past I had used this data to illustrate to newbies how they can track the benefits installing solar panels. I can no longer do this, but at the same time I am no longer sure I would recommend this particular provider if one wanted to install solar panels. It might be better to go to a source better able to support their products.
  • edited September 2019
    The old saying about the definition of insanity comes to mind. Why do you repeatedly use e-mail when you get no response?

    CALL them!

    (877) 961-7652
Sign In or Register to comment.