Model 3

Tesla Forums are now read only. To continue the conversation with the Tesla community visit

Getting "software update failed" message

edited November -1 in Model 3
About 30 minutes after a software update is initiated, the center console tells me that the update failed and to wait for the update to be sent to my car again. I get a similar notification from the App. But, when I look at the software version in the center console and in the app, the version # indicates that updated software is in place.

I took the car in to the service center. They checked the log and saw the "failed" status for past updates. Next, they ran an update and got the same error message, noting that the update was installed - the erroneous error message was the open question. After some digging, they found that the cabin temperature sensor (near the camera located at the top center of the front windshield) was loose, which they tightened it and re-ran the update. This time it worked flawlessly, all the way thru with no error message. We concluded that the problem was solved.

Two days later, I got 2019.24.4. I ran the update and got the same error message that it failed (even though the update DID install.)

I am taking the car in to the service center next week, but in the meantime, wanted to see if anyone else has seen this error and what the fix was.



  • edited November -1
    I am sure you did, but just to be sure. You rebooted the car in between those tries?

    I had a fialed update once, but I went into chat and asked them to reset it. They reset the status and sent it again and I had the update an hour later.
  • edited November -1
    @Joshan, I did not reboot the car between the time the service center successfully completed an update and the time I got 2019.24.4. I didnt think it was necessary.

    I have rebooted the car several times since I purchased the car. However, on those occasions, the install left me this error message saying the install failed (even though the software update DID install.)

    If I get an update before the service visit next week, I will do a reboot before allowing the update to install.

    Thanks for the suggestion.
  • edited November -1
    Another thought - are you using a USB flash drive (for dashcam or music)? If so, try removing it and rebooting. Some USB drives are bootable, which might screw up the reboot process during the update. Ideally, all flash drives used in the Tesla should be non-bootable. A drive format does not affect bootability.
  • edited November -1
    @TeslaTap, the USB flash drive I am using is solely being used by the dashcam. I know I formatted the USB drive to FAT32 and did not specify anything to make it bootable.

    If I get an update notification before my service appointment next week, I will disconnect the USB drive, reboot the car and then initiate installation.

    Thanks for the suggestion.
  • edited July 2019
    I had this error a while back and they replaced something called a "temp sensor" I think. Good luck!
  • edited November -1
    @PhillyGal, good to hear that a temp sensor was causing a problem and replacing it fixed it.

    When I took my car in for a service appointment a few days back, they found a loose connection with the temp sensor affixed to the windshield and they tightened that connection. After that, the test update that they tried worked correctly. But 4 days later, when update 24.4 arrived and I tried installing it, the error message returned. Maybe they will replace that sensor at the next service appointment (next week).

    Thanks for sharing your experience.
  • edited April 2020
    I just got the same error updating my Model Y. They are sending the mobile service guys in two days. I tried rebooting without any change.
Sign In or Register to comment.