Model 3

Dashcam & Sentry "lose" USB drive

edited November -1 in Model 3
I've tried 2 different USB drives on my Model 3, both properly formatted for FAT32 with TeslaCam folder and nothing else. The first was not fast enough - the 3 gave me an error message saying so. However, its rated speed WAS fast enough. But no sweat - I believe the error msg my 3 gave me.

I tried a faster drive recommended on one of the Tesla user sites. Worked fine for a few days, then during a drive the dashcam icon entirely disappeared and Sentry failed to record. I checked the drive on my Win10 pc -- it had errors and needed "repair," so I let Windows do that. (Same deal as the first USB drive.) Tried it again, worked a couple of days, then same problem - no dashcam icon. But this time I got no error msg from my 3 about drive speed. Checked the drive again - it had recorded for a couple of days. The files are there. But it was corrupted again.

My 2 USB ports have only a phone cable connected to one (no splitter) and the USB in the other. I tried the USB in each of the ports.

Going to try one more time, but this is getting old! I see others have had the exact same problem. Is Tesla addressing this?


  • edited November -1
    One reason this can occur is if you pull the drive while it is recording. It's important to first turn off recording, wait 10-20 seconds, and then remove the drive. What can happen if you just pull the drive is a write is in progress, the power disappears and for a few microseconds the drive may write anywhere and/or can't complete the FAT updates as to what was written. In worse cases, some drives will go into a read-only mode that cannot be fixed.

    The other issue is drive size and use of Sentry mode. For a small drive like 32 GB, Sentry mode can fill the drive in as little as a couple of days. I always recommend 128 GB or larger to reduce the time between having to erase the files. The lastest software also warns when the drive is full - I think around v2019.32

    The good news is V10 is expected to allow overwriting the oldest Sentry mode video so the drive doesn't just stop recording.
  • edited September 2019
    Also, ensure the micro SD card is a fast card designed for video. I initially used one that wasn't and it worked fine for a bit, then it didn't. Since going with a faster memory card, all it good.
  • edited November -1
    Thanks for your suggestions, but I addressed all the issues you both raised after the first usb stick failed. I always turn off recording and wait before removing the stick. In fact, recently it turns itself off -- the dashcam icon just disappears. (It's possible, of course, that the write process is continuing!)

    My current device is a Samsung PRO Endurance 128GB Micro SDXC (100MB/s U1) in a SanDisk MobileMate USB 3.0 microSD Card Reader - SDDR-B531-GN6NN. Good quality stuff. But who knows? I wish Tesla would take this feature past beta!

    What always happens is the drive comes up needing "repair" because it has "errors." But how and why are they being introduced? BTW, I've been around digital tech since 1979. I might err sometimes, but I know how to handle thumbdrives and computers. Nonetheless, I'm sure many others will benefit from the tips you've both posted! Thanks again!
  • edited September 2019
    Just checking, but have you tried a car reboot? Hold down both scroll wheels until the touchscreen turns off (soft reboot). Or maybe a hard reboot doing the same thing but pressing and holding the brake pedal until the Tesla logo appears on the touchscreen. Always good to do, too, after an OTA.
  • edited September 2019
    I have the same setup as above. Samsung endurance pro128. First one worked for a few weeks, permanently corrupted after i pulled it out. Replacement worked for one car trip. Something happened when i parked and exited the car i guess. The drives still can store data, never say they need to be repaired, its just that tesla won’t recognize them. I had formatted them on msdos on my mac and put in the TeslaCam folder but no luck. 80$ and two microSDs down the drain.
  • edited November -1
    I’m puzzled why some people are seeing these issues and others with identical USB or SD drives are not. I’ll probably jinx myself by saying this, but I’ve used a few different products for recording video and have never seen the write speed warning and have never experienced data corruption. This is true for both our Model 3 and Model S.

    I’ve wondered in another thread whether the fact that I’m also always playing music from another USB has any bearing on this. Maybe the music playback influences how the video recording works, because the music keeps the media subsystem active in some way.
  • edited November -1
    Windows 10 will format it to FATex by default. This isn’t FAT32 and will not work. Oddly, a Mac will correctly format it to FAT32. This stumped me for a while until I did some digging about Win10 FAT formatting.
  • edited September 2019
    I agree with @ronocoug, It seems that whenever Tesla decided to "check" the write speed of the drive they also built bugs into whatever triggers the error, and it triggers at times it shouldn't. Maybe the triggers are too rigorous and trigger even if the drive only momentarily doesn't perform to the required threshold.

    I've found that doing the two scroll wheel reboot with the drive connected into the USB port resolves the problem, that is if you do have a drive that's fast enough and is properly formatted to FAT32 and has the proper folder.
  • edited September 2019
    Reboot worked for me when I had the same/similar issue.
  • edited September 2019
    I went through a cycle of frustration trying to get three different 8gb USB drives from the same vendor to work. I tried letting windows 10 "fix" the drive, I explicitly formatted it as fat32 under Linux, and of course I could use the flash drive(s) under Windows and Linux with no problem, but for some reason my M3 would not recognize the drive, no dashcam, no saved sentry mode events.
    Finally I tried a preformatted 32gb flash drive from a different vendor (a generic Staples thumb drive) and everything works.
  • edited September 2019
    I had issue with my dashcam here I find the best ways to fix videos from dash cam of any brand. I hope this information help you!
  • edited September 2019
    I know that there are several threads on this, and I will tell you the same thing I put on those other threads.

    For me, I was seeing similar issues, it would work for a while then stop or complain. Then maybe it would work again for a bit, then stop and complain. I had a SANDISK thumb drive the size of my thumb nail, 64GB I think, rated more than fast enough and verified in windows.

    *** Issue and Resolution for me *** For me, the issue was the thumb drive was overheating because of the constant writing to it. While on a long car drive, I would get it running for a bit, then disconnect. I found if I removed it and put it back in, still had an error. If I took it out, let the AC blow on it for a minute, then put back in, it worked fine for another long period.

    So for me, the issue seemed to be related to an over heating of the drive, and as the drive heats up the transfer speeds go down. That is why you might have something that is fine and then changes.

    My solution, I went with a larger SSD drive, it has better heat dissipation. We have not had any issues since the change. SSD's are more expensive than thumbdrives, but the parts tend to be better. Thumbdrives are not really designed for constant write cycles with no breaks.

    What makes this hard to narrow down is that there are a lot of factors. Are you running sentry mode, was it running for the past X hours or are you in a place that you have sentry mode disabled. If it is running sentry mode, then when you get in the car, it has already been writing to the drive for a while, so it is already warm. Take out the thumbdrive and see if it is how to the touch.

    Hope this helps.
  • edited September 2019
    I second the motion that SSD works very well.

    I took an older 256 GB Samsung SSD and put it in a cheapo USB enclosure that has a USB plug (sorry, that would be pretty obvious since it's a USB enclosure). I have partitioned things to have music on half and Sentry/Dashcam (TeslaCam) on the remaining half of the drive.

    Every once in awhile i need to reboot the car (steering wheel scroll wheels) when the dashcam icon disappears. or when my USB music doesn't show up on the screen. All's well after a reboot, 100% of the time.

    I'd seriously think about ditching thumbdrives and go the SSD in a USB enclosure route. it works.

Sign In or Register to comment.