My Car will NOT LOCK

My Car will NOT LOCK

Has anyone else had this problem after the upgrade? Not only does my walkaway not work (I have it turned on in settings), even when I double-press the top of my key the doors will not lock. The car will not start (as I have moved keys far away from the car) but when I touch the door handles they present, and I am able to enter my car. Can anyone give any insights? Thanks VIN 3519

AaronX | 27 January, 2013

Double pressing the key unlocks the door. try pressing once. | 27 January, 2013

Have not had this issue...I still walk away & turn back to check when leaving the car.

ThomasK | 27 January, 2013

KevinR, my door handles retract and the LEDs are no longer visible. Have you walked back without your key and touched the handle to see if it comes back out? That's what happens to me. It looks fine when I look back too, but the car is most definitely unlocked. Can't drive it, but you can get inside the car...

ThomasK | 27 January, 2013

AaronX thanks, the single press seems to work. If you hold it, all the windows come down, I learned... The walkaway still doesn't work though, after it worked perfectly before the 4.2 upgrade... | 27 January, 2013

ThomasK, I will try your test tomorrow & let you know. I have always just assumed the handles retract & the headlights flashed that it was locked. Thanks.

JThompson | 27 January, 2013

Make sure you send a note to about these problems.

bp | 27 January, 2013

While I have the autolock enabled - it does take a while for the car to timeout and do the locking.

I'm probably going to keep autolock turned on - but when parking in a public lot, with other people around, will probably use the remote to immediately lock the car.

ThomasK | 27 January, 2013

Bp, agree and I wait for that to happen. Then I walk back without the key, touch the door handle, and can get into the car.

dbourne | 27 January, 2013

I have software version 4.2 on my 85kWh standard Model S and my auto-lock features work as expected. I've definitely tested walking away and coming back to the car without the key after the door handles retract and the car is definitely locked (i.e. pushing the handles doesn't make them extend). I Do however wish that the timer for how long it takes to lock up after you walk away was about 5 seconds shorter so I don't have to look over my shoulder and wait if I leave the car parked on the public street

noel.smyth | 27 January, 2013

i got the 4.2 update, no issues here. | 27 January, 2013

ThomasK-- tried walking back to the car without the key this evening-- all locked up (no door handles extend when touched). Sounds like you need to open a service ticket with Tesla. Please post what the issue was when resolved.

ThomasK | 27 January, 2013

That's great. I hope this is an isolated issue with me that can be resolved with a software patch or something. Good to go, KevinR!

Carmine | 27 January, 2013

ThomasK, Nope,it's not an isolated issue with you. Had no problems with the autolock feature with all revisions to date until 4.2 (V1.19.42) was installed. Left the car in the garage, returned 10 minutes later without the fob to find the car unlocked! I think, but not sure, V1.19.41 was installed on 1/26 without issue but the problem began with the 1.19.42 upgrade on 1/27.
Are you running 4.2 V19.41 or .42?

JohnEC | 27 January, 2013

ThomasK, this may sound silly, but are you absolutely sure all the doors are completely closed. If a door is not closed, it will cause this behavior.

ir | 28 January, 2013

Does anybody know if attempting (and failing) to lock due to an open / ajar door generates an audible alert?

Every car that I've ever owned makes a satisfying chirp / beep to eliminate any doubt whether its locked or not. My Camry goes one step further with a long continuous error beep when it fails to lock (eg. Door open or keys would be locked in car).

Carmine | 28 January, 2013


Don't know about ThomasK's car but all my doors were, closed. As I said, the car sat for 10 minutes, when I returned without the fob I was able to push on the handle and enter the car. Again, the problem started when 4.2 v1.19.42 was installed.

John70 | 28 January, 2013

I had the same issues you reported. I realized after awhile that I had left my second key fob in the car. Is it possible that your second fob is within range of the car?

Carmine | 28 January, 2013

No, my second key fob expired in the washer several days ago!

Brian H | 28 January, 2013

Send it to TM to do a forensic examination.

ThomasK | 28 January, 2013

Hey folks, the walk away now works. So, I can only conclude: a) the magic upgrade fairy came by and fixed it; b) I was somehow being thick; c) the upgrade needed to get complete; d) Volker is somehow punishing me for not using the right thread to post my issues...

Just so everyone knows, the two key fobs were far away when I did the various experiments yesterday. I made sure all doors were closed and key fobs far away....

It's a mystery to me... just to be safe I think I might still push the key once to lock versus assume it works.

For what it's worth, Tesla responded immediately when I sent them an email. And I got a follow-up call too.

Carmine | 28 January, 2013

What version of 4.2 are you running, v1.19.41 or .42 or is there a subsequent version out now? I'm still having the locking problem on v1.19.42. I notified ownership, received a return email but the magic, fix it upgrade fairy hasn't shown up yet.

olanmills | 29 January, 2013

@ir, no sound, but parking lights flash to confirm lock.

@ThomasK, I suspect that double tapping the button, even from far away is telling the car to unlock. Then wehen you come close to the car in your test, the door handles don't extend obviously because you don'thave the fob, but they are unlocked and respond to touch.

ThomasK | 29 January, 2013

Olan, yeah you are right that double tap unlocks it and someone clued me into that, but even when I didn't touch the key, walk away did not work. This was just a glitch of some kind. As I have said in a subsequent post, it appears to have "fixed itself." Carmine, I feel your pain - because with a car like this I found myself asking - okay, just how stupid am I?

DouglasR | 29 January, 2013


Have you tried standing on your left foot and touching your right ear while you hold the button down? I find that sometimes helps.

Brian H | 29 January, 2013

Post a photo to show the exact correct technique. Please!

Carmine | 29 January, 2013

Well, all my trials have failed including DouglasR's suggestion. A Tesla ranger will be down on 2/1 to check it out. I still maintain that it is a glitch in the .42 software or it occurred during the installation process of that version.

ThomasK | 29 January, 2013

I have no wisdom to offer, Carmine. Only my sympathy.

Carmine | 30 January, 2013

I was very happy last night because I believed that the upgrade fairy came to visit my MS as well and the car autolocked perfectly on multiple attempts without fail; however, by this AM the Autolock Grinch (or the ghost of Volker.Berlin) stole it away again.
Reconfirmed my appointment with my local Tesla Ranger on 2/1.

Robert22 | 30 January, 2013

Carmine, have you tried rebooting both screens to see if there might have been an installation hiccup?