Navigation V.9 won't accept directions from mobile device

Navigation V.9 won't accept directions from mobile device

V. 9 says you can share directions from mobile apps from your iPhone. Every time I try I get a message saying. Your vehicle does not support starting navigation from a mobile device. All my software is up to date. Anyone else have this problem? I tried google maps and apple maps. Same result with both.

Stiction | 6 October, 2018

Google maps works for me. I put in a destination and then click the share icon (that looks like a sideways V with little balls on the ends.

Then you see a bunch of apps you can share too..and Tesla should be in there (Assuming you have the Telsa app running on your phone....if not that's your problem !)

barrykmd | 6 October, 2018

Where is the share icon? I don't see it on the main screen nor when I press the menu (3 horiz bars) button.

aj | 6 October, 2018

Where do you see that? I don’t see a way to share from the map once I have a location entered. I must not have something set up correctly. Do you have to have location sharing with others turned on? What am I missing?

Stiction | 6 October, 2018

Hmm. Not sure why this is so hard.

In the search window in google maps type in some destination
At the bottom of the screen you should get a results box that blocks the lower part of the map
that has a big blue "Directions" button you would press to get directions to that search results.

To the Right of that blue button there is a "call" button (if its a business) and to the right of THAT is
a button called "Share". (and with the little tilted V symbol google always uses for sharing.

If you hit Share you see the list of apps you could share with.....including the Tesla app.

Mike83 | 6 October, 2018

Using Google Maps it works easily. Pretty cool.

aj | 6 October, 2018

Thanks Stiction, I figured out what was wrong. When I clicked on share I didn’t see the Tesla app listed because I didn’t scroll far enough to the right in the list. Once I found it I was able to turn sharing with the Tesla app on. I have moved the Tesla app to the front of the list so I don’t have to scroll. Thanks again!

barrykmd | 6 October, 2018

"To the Right of that blue button there is a "call" button (if its a business) and to the right of THAT is
a button called "Share". (and with the little tilted V symbol google always uses for sharing."

Not on my version. I put in a hotel and to the right of Call is Book.

However, once I hit the Directions button, then go up to the top and press the 3 vertical dots, then there's a share button. Seems like a lot of work when you can just use the voice command in the car.

Rt. 66 | 7 October, 2018

I had trouble with “sharing” until I downloaded latest version of Google Maps. Works fine now.

Neptune Blue | 7 October, 2018

I experienced the same error message, saying the vehicle didn’t support navigation from a mobile device, using both Apple maps & Google maps. I have an August 2014 model S.

baldwin | 7 October, 2018

I had trouble doing this until I updated both the Tesla app and the Google Maps app-- then worked

joey.froehle | 13 October, 2018

“You vehicle does not support starting navigation from a mobile device“. I am having this same issue. I have a 2012 Model S P85

Shirihai | 13 October, 2018

If Tesla App does not appear on the list of Apps to share with, you need to update the Tesla App. To Update the Tesla App go to Application Store, search for the "Tesla". If you need to update your application, you will see an icon "UPDATE". Click on UPDATE. If you your Tesla application is already up to date, it will say "OPEN".

Ruby110 | 14 October, 2018

You may have to scroll over to “more” and select Tesla.

Ruby110 | 14 October, 2018

Also, I can’t get it to work with waypoints in Google Maps.

PBEndo | 14 October, 2018

"Seems like a lot of work when you can just use the voice command in the car."

I can see that, though for some addresses you already have in your phone (from a web page or an email) it may be easier.
I wish this would work in "reverse" allowing me to send navigation waypoints from my Tesla to my phone. I prefer using Waze to navigate but I find entering new waypoints while driving easier to do with the Tesla voice navigation than with Waze on my phone. Most of my infrequent use of Tesla navigation is when we are in an unfamiliar location and want a quick location found - i.e. "Where is Starbucks". Using the Tesla voice control is usually the quickest way to find something close and for short distances the routing is usually the same with both systems. However, If I could then send it to my phone with one tap, I'd use that feature.

smathews | 17 October, 2018

Had the same error not being able to start nav from iPhone. I had the latest Tesla iOS app but found thag google maps needed an update. So I installed the update and it works great. Seamless.

Lulu-z | 17 November, 2018

It was working then not working. I was using google maps. I went to the iOS App Store and into the Tesla app that way, and it started working again. It didn’t. say I needed to update the Tesla app, but maybe something needed convincing it was up to date.

PrescottRichard | 17 November, 2018

A better way to phrase it is - sending addresses to your car, the actual route is not transmitted, right?

mhayos | 13 January, 2019

I fixed this exact problem by uninstalling and reinstalling the Tesla option in the ”share” menu. Here’s the details: go into the map application. Go through the normal process to send the directions to the Tesla app. But instead of selecting that, press the 3 little dots to open the options window. Deselect the Tesla app.. Exit back to the main screen. Close the app. Reopen the app and reverse that process and reinstall the Tesla app into the opens for sharing. All should work fine.

Thepatelguy | 25 March, 2019

I tried sending the directions from my Galaxy S10 to the M3 and it showed that the directions were shared with my car.
However, when I entered the car, I realized the address received was incorrect and nowhere close to what I had entered on the phone. The same thing happened a couple of times and I am not sure why.

TranzNDance | 25 March, 2019

Did you send the address of the desired destination? I understand that the way it works is that you send the address, and the car gets the addresses and sets up directions from there. I don't think the car receives directions as an input.

Roel Lamb | 29 March, 2019

try to send it twice that usually works for me

lilbean | 29 March, 2019

I have no idea what you guys are talking about. Haha!

dave | 1 June, 2019

It used to work for me as well. Just updated to v2019.16.2 on my 2015 model s 85d and it doesn’t appear to be working anymore. Tried removing it from more, closing the app, rebooting and trying again it I’m getting the aforementioned error message: “you vehicle does not support tarting navigation from a mobile device”. Did they kill this feature?!

dave | 1 June, 2019

Scratch that. Figured it out. Car needs to be “woken up” or connected to the app... then it works!