How long to drive until autopilot calibration is completed?

How long to drive until autopilot calibration is completed?

I received my M3 on Friday and have driven it for about 200 miles and on the display above the vehicle image it says "Calibration in progress" while driving.
I assume this is for the AI/learning and camera tuning. How many miles are normal to have to drive before the calibration completes and you can use AP? Is it some setting that you need to invoke?
Any feedback is appreciated!

rkalbiarEV | 8 May, 2019

Both my cars happened in more like 20 miles, max. You may have a problem...

rchau28 | 8 May, 2019

Mine took 10 miles or so. I've seen others say up to 50 miles.

ODWms | 8 May, 2019

Mine was easily 10, 20 miles. No more.

EVRider | 8 May, 2019

It depends on where you drive. Here's what the manual says:

"Calibration typically completes after driving 20-25 miles (32-40 km), but the distance varies depending on road and environmental conditions. Driving on a straight road with highly-visible lane lines allows Model 3 to calibrate quicker. When calibration is complete, the features are available for use. Contact Tesla if your Model 3 has not completed the calibration process after driving 100 miles (160 km)."

Since you've already driven 200 miles, using your mobile app to make a service appointment.

Go Sailing | 8 May, 2019

I had the same problem when I picked up M3 a couple of weeks ago and it has HW3.0 and 2019.7.102 version. Calibration would not work with that version until I got it upgrade to 2019.7.105 or above. Right now you should have 2019.12.1.2. If you have 2019.7.105 or more and still wont calibrating, call customer support.

EVRider | 8 May, 2019

@Go Sailing: That's right, I forgot about the HW3 factor -- that's unknown territory.

p_dahlgren | 8 May, 2019

Thanks for all your replies. Mine came with 2019.7.105. Maybe, I should just upgrade the firmware to the latest and test it out before scheduling service. If 2019.12.1.2 is the latest, weird that they provided such an old revision on a car that was ordered just 3 weeks ago. I received it on Friday.

EVRider | 9 May, 2019

@p_dahlgren: 2019.7.105 isn’t that old, but that release is only going to cars with HW3. I don’t know if HW3 cars are getting the newer updates (they might be).

hokiegir1 | 9 May, 2019

2019.12.1.2 only started pushing to cars last week. Many people are still on older versions (I'm on 2019.8.5 still -- which is the parallel release to your 7.105, but I have HW2.5).

jenni | 9 May, 2019

I am having the same issue and I am currently updated to the 2019.12.1.2. I called and was told that there is a firmware update coming out to fix this issue.

Ⓣⓘⓖⓖⓔⓡ Ⓤⓟⓟⓔⓡⓒⓤⓣ | 11 May, 2019

Just picked up my M3 on 05/08/19. Came with v. 2019.7.106. Car was built this month. I believe this version I have is a February revision.

Just hit 109 miles today. Calibration still hasn't completed. The steering wheel icon has a little blue bar, but it hasn't moved one bit.

(off topic: No Sentry Mode in this fw version either )

john | 11 May, 2019

Picked up my m3 yesterday with 2019.12.1.2 and calibration was done in about 10 miles.

Coloradofun | 14 May, 2019

I picked up my may 2019 build HW3 model3 AWD LR FSD on Saturday and at 178 miles 0% calibration - tried the reboot too at ~50 miles. Software was 7.106 from factory. Today I sent a note in and within hours was pushed to 12.1.2 so will see if this fixes it.

whisky7 | 15 May, 2019

I had same experience when I picked mine up 1 week ago. It had. 7 version from factory and received .12 update next day and it calibrated just fine in less than 20 miles. Does anyone know how I can verify that I have HW 3 ?

Goose66 | 15 May, 2019

Frankly I am a bit surprised that HW3 and HW2/2.5 can run the same firmware releases. Seems like the code would be completely different for the neural net.

EVRider | 15 May, 2019

@Goose66: It’s not that surprising, since HW1, HW2, and HW2.5 can all run the same firmware. HW1 and HW2+ are very different platforms. That doesn’t mean all versions run on all hardware — for example, I think the 2019.7.x releases were only for HW3.

kcheng | 15 May, 2019

Mine never said it was calibrating when I got it, and it only had 6 miles or so on the odometer.

CharleyBC | 15 May, 2019

@whisky7: two pieces of evidence that you have HW3:

1. Newness of car. Everything built after 12 April has HW3

2. Original software. 2019.7 was exclusively for HW3.

suchang | 20 May, 2019

I run 250mile, still calibration is in progress
set schedule service, but I got this message in stead

Hi, I am in the process of diagnosing your vehicle for your upcoming service appointment. I looked into your concern and there are no faults stored for the autopilot system. Your vehicle has the latest autopilot hardware that requires more driving than previous hardware versions. Please continue to drive your Tesla and the autopilot calibration will continue to progress. There is no need to bring your vehicle to the service center so I am going to cancel your schedule appointment for you.

Coloradofun | 20 May, 2019

My AP 3.0 model 3 was delivered with 2019.7 9 days ago, no calibration after 178 miles. Sent note into support and next day upgraded to 2019.12.1.2. Calibration completed in under 10 miles. Two days latter upgraded to 2019.16 everything is working great now.

suchang | 25 May, 2019

337miles run.. Autopilot is not activated and GPS doesn't say it is from software error.
I returned it before 7 days of purchasing and dealer promised me to fix this issue in 1-2 days, gave loaner car for 2 days
I need to return this loaner car and get refund back
It was not good experience for me
ver 2019.12.1.2

suchang | 25 May, 2019

337miles run.. Autopilot is not activated and GPS doesn't say it is from software error.
I returned it before 7 days of purchasing and dealer promised me to fix this issue in 1-2 days, gave loaner car for 2 days
I need to return this loaner car and get refund back
It was not good experience for me
ver 2019.12.1.2

lmorda2 | 28 May, 2019

Yes I don't think I ever saw that and I definitely started using Autopilot after 20 miles

p_dahlgren | 30 May, 2019

Sorry for the late update on the resolution of my issue but I just returned from a trip abroad.
Thanks for the comments. Interestingly, I see there are other new M3 owners with similar problems.

Some background: My model is an M3 AWD Perf. model, which was was delivered on May 3 and came with firmware version 2019.7.105. I assume this is HW 3.0.
The symptom was AP not working and a "Calibration in progress" message at the car icon on the display continuously while driving and never any surrounding vehicle objects popping up around my car icon.

I took it to the service center in Fremont on 5/13 and they kept it for two days.
Firmware was upgraded from 2019.7.105 to 2019.12.1.2 but that upgrade alone was not enough to resolve the AP failure to calibrate.
According to what they said, the first attempt of diagnosis indicated that the radar and cameras did not properly connect to the computer so they checked these hardware components and communication individually but there was nothing wrong there. Finally, they needed to do some type of software initialization procedure in diagnosis mode (they did not explain more details) in addition to the upgrade. This special procedure was a bit new to the staff at the service center. At the end it was only software.
I know it's hard to develop efficient tools for software diagnosis that cover all possible corner cases. Anyway, everything works fine now so I'm happy with my M3.

I would suggest for those of you with similar issues of failures to calibrate after ~100 miles to book SC appointments as soon as possible.

As a loaner I got a Model S P85, so at least I got the opportunity to try out the S for two days.


smar737 | 31 May, 2019

Just another data point...M3 LR with FSD. Delivered @ 1pm, 29 May.
Drove 110 miles (70% highway) with calibration icon frozen at around 5%. Stopped by service/delivery center after 75 miles, and they patted me on the head and said "Be patient. I've heard of it taking 300 to 500 miles." Of course, they'd also told me when DIRECTLY ASKED at delivery that software was up to date with the most recent update. It was not. I had version 2019.7.
I emailed to inquire at about 7pm.
That night (9pm) the update (2019.16...) came available to schedule, so I requested it immediately.
I drove it after the update and the calibration was finished withing 10 miles of driving on roads with good lane markings.
Tesla deliveries called the next day to check up.
All's well!
Steve M.

nash07 | 1 July, 2019

My car was still said 'Calibration In Progress', stuck at almost 95% complete, driven for 50 miles, I did the below and AutoPilot was enabled. Not sure if that helped or just a coincidence.

1. Hard restart the car by pressing the Left and Right buttons on the steering wheel.
2. Drove on well marked roads for 5-10 miles (90% highway)
3. Did NOT drive like a dirtbag (meaning drove straight changing lanes only when needed)

If this fixes your issue please let us know so other drivers can benefit from this

joonrhee | 4 July, 2019

I took delivery of my M3 standard range + last Sunday. I have driven for little over 200 miles now, but calibration is still in progress and has been stuck at around 95% since like 100 miles. I tried hard reset and factory reset but didn’t resolve the issue. I chatted with a Tesla rep via Tesla Support and was told to drive until 500 miles.

I would like to ask for your opinions. I have an appointment this Sunday to tint my windows (which will cost $750) but wondering if I should be postponing it. Reason being, I did request for a mobile service next Thursday and plan to call Tesla if I can take it in any sooner for a checkup. What do you guys think this is a big issue and might need to exchange the vehicle? I don’t want to tint the windows just to find out I have to exchange it. Also, this Sunday marks my 7 days return period... Any thoughts and opinions would be greatly appreciated. Thank you.

DV_T3SLA | 5 July, 2019

Mine was done in about 10-15 miles. I agree, that yours might be having an issue.

lbowroom | 5 July, 2019

Joon, they don't exchange cars over the counter. They repair them.

calvin940 | 5 July, 2019


Mine was probably more like 50 miles, but did finish. You seem to have a different issue. Most of the threads I have read about calibration was either automatically resolved at some point or resolved through a service center visit.

Tesla will absolutely get that fixed. However, your own comfort level will have to be the item to dictate whether you utilize the 7 day return period. Personally I would not return it for the issue you are experiencing, but it comes down to you and comfort with proceeding through the resolution process.

shank15217 | 5 July, 2019

@joonrhee, I doubt they would exchange your car,

rwa | 5 July, 2019

Mine was calibrated before the end of my drive home, about 65 miles.

Devilstower | 5 July, 2019

I picked up a Model 3 SR+ on Jun 28. Software was (and still is) 2019.15.103.

Autopilot kicked in before I hit even 20 miles. I was able to test it without an issue on the drive home from picking up the car.

SplashAttack | 5 July, 2019

I was having the same issue as other people on here and it finally resolved itself! 300 miles later, I was getting desperate so I turned off Auto-pilot in the menu and cleaned all the lenses on the car. There was a very tiny white streak (bug or bird poop) on the front windshield in front of the cameras that I wiped off that I think might have been causing the issue. I wiped and blew out the dust on the cameras below the side mirrors. 5 miles later it finished. Hope this helps someone else. Good luck!

ODWms | 6 July, 2019

If I remember correctly, my AP calibrated less than 20 miles into my 100 mile drive home.

darayush | 18 August, 2019

So I had an interesting observation on the calibration. I have driven about 100km and it was stuck at the last point to complete and the blue ring was just not closing and I was going thru the forum responses and decided to wait till about 160km before putting in a service call. Then while driving today I noticed the right side of the car on the screen has squiggly road lines and the left side was straight. I realized I mainly drove in the city and my tendency is to drive on the far right lane and so I figured the sensor could not calibrate as it could not see the road lines as there are none on the curb side of the lane, just parked cars so I drove in the centre or far left lane and within 5km my car completed calibration. Maybe it was just coincidence but it worked for me without throng rebooting etc.

dipen | 16 September, 2019

Initially I contacted Tesla support for this issue after driving for 250 miles. They are quite busy these days (40+ minute wait time). I spoke with the representative and she was unwilling to acknowledge the issue because she could not see any errors from the vehicle. I asked what I should do next and her repeated response was that I don't see any problems. Eventually, we agreed that I should take it to the service center. Unfortunately, I had to prompt the support person to try different things (normally its the other way around). The earliest appointment was 4 weeks out Phoenix area.
In the mean time I updated to the latest firmware and after reading this thread I decided to try again and just keep driving until it calibrated. I deliberately chose a route that had clearly visible lane markings. After about 10 miles it completed!!
I am assuming that my typical route had poor lane markings and the duration of my driving was probably too short where it was properly marked.
Maybe Tesla can add to the FAQ (and update tech support) to indicate that the driver should drive on roadways with well marked lanes.

dangerl7e | 9 October, 2019

I've had my car for over 3 months. I don't remember seeing any kind of calibration at the beginning - AP worked flawlessly. Yesterday, when I put the car into "D" going home from work - it started showing a circle around the steering wheel button and saying "Calibration in progress". OK. I drove maybe 2 minutes, then it finished and had a pop-up which I couldn't read, was busy driving. But it said something about autopilot...
Going home on the freeway it did the famous phantom braking TWICE, which I have never experienced before (like I said - the AP worked flawlessly).
Now I am pretty disappointed - I didn't call for that calibration, nor I needed it. AP worked before better than after... Should I call tech support or is it just a waste of time??? I've done some googling and many people say, the response from Tesla usually is "Well, it's still in beta... Wait for SW updates... Be ready at all times to take over... It will improve in the future...".
Has anyone else experienced it on V10 HW3???

vmulla | 9 October, 2019

It is possible something affected your system without your knowledge. It could be something as simple as debris/dirt blocking a sensor/camera. I've experienced what you described a few hours after my car had an accident, a sensor was knocked out of its position then.

I suggest you take it easy and avoid Autopilot until you get an all-clear from the system or service center. Good luck


I've helped other owners at their delivery. Some cars finish calibration in a few miles, and some took over 100miles. The service center folks advised us to drive as much as 300miles to calibrate the system.

dangerl7e | 9 October, 2019

thanks for your response. What boggles my mind is that the car has almost 4000 miles on it. The AP was working just fine, actually it worked better before it decided to calibrate itself. I gave it a good wash yesterday, but I usually wipe sensors and cameras in between car washes.
This morning i was APing and had 1 short hard speed drop for maybe a second, nobody was behind, so I didn't intervene, and the drop wasn't a hard brake either.
We'll see on the way home - I'm kinda scared at this point. Instead of keeping my foot on the brake (like I'm supposed to), I am keeping it on acc...