Model 3 Disappeared From Account

Model 3 Disappeared From Account

Hi guys, I posed this on the TMC forum but am hoping someone here might be able to help:

-Took delivery of my Model 3 in December

-Car linked up to my account and everything was great until April 30

- Noticed April 30 my car disappeared from my account. Doesn’t show on under account information, and signing into the app yields an error stating “There are no products linked to your Tesla account.”

- Went into web chat on May 2. Tried troubleshooting app and car settings. No success. Rep said she would escalate.

- Called in on May 3. Rep said there was something wrong on Tesla’s end but wouldn’t state what. She said they would get the car linked back up and to check in a few hours. No success.

- Called on May 6. Rep said it has been sent to a different team for processing and could take a few days.

- Did web chat May 9. Rep said he doesn’t know why this would happen and would look into it. Chat abruptly ended 10 minutes later with no follow up or resolution.

I am at wits end at this point and very frustrated with everything. Has this happened to anyone before? I don’t know what to do. I am tired with chasing someone down for an answer and not having access to my vehicle for service requests, remote access, phone key, etc for over a week now.

Thank you,


sal.hashimi | 11 May, 2019

I see the same thing but unlike you I haven’t taken delivery of my car. Although I was able to access the app before this issue.

jjgunn | 11 May, 2019

This should never happen after you take delivery of your vehicle.

Tesla showroom / Service Center option? If so, go in there & don't leave until it's resolved.

jjgunn | 11 May, 2019

Also. Try logging out, reboot phone & logging in the App.

Also login to from a different never before used browser. (Verified browser cache isn't an issue)

ignazw | 11 September, 2019

This just happened to me as well. See my comments under

With me it looks ownership of the car was transferred from my account to someone else's. I am sure this is a human error. at Tesla's side Someone somewhere typed in a wrong VIN or other ID. Very annoying.

Can you elaborate on the final resolution?

andy.connor.e | 11 September, 2019

i can elaborate on my flags

jimglas | 11 September, 2019

tjhis happened to me
Resolved by signing out, then back in to the app

ignazw | 16 September, 2019

Doesn't work for me. Can't sign into the app because no products linked to my account.
Car says the same when I try to disable remote access from the touch screen.
On the web I do see my car.

At the service center they told me my car was linked to someone else. Someone in Norway.
To me it seems a human error in transferring a car is the cause of me being locked out.
Going on for almost three weeks now. Still no way I can access the app.
And some security settings in the car also require a account + password, and I can't use that either.

fbc178 | 26 September, 2019

i have just recently experienced the same issue. The person I was chatting with wouldn't tell me who my VIN was associated to. After 30 mins the chat ended. Trying to get back in but the wait is excruciating.

neilldorn | 2 January, 2020

Just happened to me, at Wendy's! I did not want to get stuck there.

Fortunately, after 20.minutes or so, I was able to log in and drove home.

smoak888 | 5 January, 2020

Happened to me yesterday. Still no resolution. Vin number shows correctly at but my app is like pre delivery status (just the welcome splash page and links to video). Emailed my service advisor but still no solution. Frustrating for sure.