FM radio stuck loading

FM radio stuck loading

Our FM radio will not play. It is stuck with loading symbol. Internet radio ok. Multiple reboots. Soft and hard. Nil fix. Anyone else. It was great before.

Frank99 | 15 August, 2019

My wife pointed out the same thing to me today (she listens to the radio, I don't). Must have gotten broken in a recent update.

gmr6415 | 16 August, 2019

Do you have an LTE signal?

MrSexyTime | 16 August, 2019

Happened to me yesterday. I did a full power cycle and it didn't come back (though after power off, the car restarted before I touched the brake, and before the Tesla suggested three minutes. The radio was still hosed, but then did a hard reboot, and all was well. (2019.28.2)

cnk | 16 August, 2019

Had this a couple of times. Two-button reboot fixed it.

ColoDriver | 16 August, 2019

Mine stopped working after the update to 24.4. A power down reboot from the menu solved it until I parked the car, when it stopped working again, but then a soft (scroll wheel) reboot then fixed and no issues since. So maybe try both one after the other.

ormandy | 16 August, 2019

Had same issue last month. No fix worked at home. Scheduled mobile service, they rescheduled to service center. FM unit replaced - took 1 1/2 day fix.

bjrosen | 16 August, 2019

My radio was wedged also, did a reboot and that fixed it.

dfellinger | 16 August, 2019

I had it at the shop for a noisy AC fan. Replaced the blower motor. They tried a reboot for FM with no fix. They pushed the latest software patch for me to install at home again. Nil fix. Back to the shop again. What a pain.

rxlawdude | 16 August, 2019

Same here, two-button reboot while driving fixed it.

gwolnik | 16 August, 2019

I haven't experienced this problem yet, however my Sirius XM Onyx receiver is dependent on the FM radio because it retransmits the signal to the car that way, so I'll be very upset if this happens!

mike.munrow | 19 August, 2019

Had the same problem; two button reset did not fix it. What did was starting streaming audio, then going back to FM. Still working fine.