Tesla mobile app doesnt show the solar panel usage

Tesla mobile app doesnt show the solar panel usage

This one is really time consuming experience.
Had solar signed in Feb. Installation done in June. Activated in Aug.
All working fine, but can not have Tesla mobile app display the solar panel usage.
Tried everything, delete app, reinstall, relogin etc.
Have spent about 3-4 hours on phone call so far.
A tech rep came after 2 weeks and said everything is fine, he could see usage in the tesla side and just left.
Still nothing shows up in mobile app for solar usage. Always see the car and the solan advertisement.
Have spoken to agents multiple times and answer been "we have to update some spreadsheet, check back in 48 hours"
Really waste of time for many.

smaches | 22 August, 2019

A little confused on your term "solar panel usage." But it sounds like you only have panels and no powerwalls? If so and there was no consumption sensor or similar unit (PowerBlaster) installed in your breaker box, then you will not see any consumption in the TESLA app. All you will see is production.

gregbrew | 22 August, 2019

Yup. For the three years late 2015-2018 I had solar only (no Powerwalls), all I could see was production because local building codes don't allow PowerBlaster installation.

Since I got two Powerwalls last January, I can now see production *and consumption* via the Powerwall TEG and its CTs.

kgkiran | 26 August, 2019

Yes, I meant only the production. It feels like Inverter and Gateway take a break from communicating quite often.

gregbrew | 31 August, 2019

I found that on the solar side, the little CAT5-wired gateway box needed to be in a line-of-sight with the inverter in order to get reliable Zigbee radio communication between the two. Try moving the gateway as close as possible to the inverter. If that's not possible using your existing house wired Ethernet infrastructure, you might consider a power-line Ethernet extender into the area that houses the inverter, and put the gateway there.

Fgrange | 3 September, 2019

The solar city app worked great as does the Tesla app. When the solar city app was discontinued the solar generation numbers did not show up on the Tesla app as advertised. All their conversion instructions were followed and the usual reboot, uninstall, reinstall, change passwords on both didn’t work.

Did anyone out there get their solar city solar generation numbers to show up on their existing Tesla app and how did you do it? Epic Tesla Fail!!

dinucatona | 3 September, 2019

@Fgrange, good luck. The whole conversions is mess. Missing data, mismatching data, people not able to see anything, you name it. Emails t support take 3 weeks to get a response.

I got mine up and running but i have mismatches between months, days, missing data etc.

Fgrange | 6 September, 2019

The app is working! Contact, report your error, leave your phone number, and they’ll call you back in about a month! Really! In my case, the error had something to do with signing up for the solar city and Tesla apps with my email address which I changed over the next several years. The problem had to do with one or both apps storing my old email address even though I updated my new one on both apps. Nothing you can do, they have to set your new email address internally on their end. from the browser only shows my car, not solar, but so what, the app is finally working, but you will like the old solar city app better. Lots of patience! The data is good.

cherislaa | 9 September, 2019

Unf)@&($& believable. Why change over from Solar City to Tesla if the system doesn't work. You just want to take out foq39587q98w money and not give any service. I have emailed and now called to get this resolved.

drclay | 13 September, 2019

Is there any chance of lost data features on the old MySolarCity app ever making it into the Tesla app? I used to be able to see solar installs in my region along with estimated savings. It was a useful tool to help Tesla sell to my friends and neighbors. Any chance of getting a more robust app for home installations?

jan85310 | 17 September, 2019

I can not see my daily usage solar panel display in Tesla site, I could see my year to year, month to month and daily usage in my old solar city app. I can't see anything in usage with my Tesla.

moz1058 | 22 September, 2019

Same here. Impact and Energy usage doesn't show any solar production history. On occasion I will see some solar production when I open the app but it doesnt save any history of solar production. Will try to move the gateway box closer as I have already powered off the system twice and emailed Tesla twice. I think I will call them tomorrow if moving the box doesnt work.

rasmith | 8 October, 2019

I just got my system turned (Tesla Tech and Power Company Inspector/meter installer) on Yesterday 10/7/2019 (started process around 7/18/2019) and at least it is working via looking at the meter only ... Thank you all. You have saved my time and aggravation :) by lowering my expectation on seeing current Solar Power production, consumption, etc. on the useless Tesla App if you only have the solar (no PowerBlaster and no powerwall) panels. I will try to get this so call gate way (from hell if I let it consume my time and aggravation) closer to the Inverter. The customer service was no help yesterday. I just got my email (10/8/2019 10:45 AM MNT) that I can turn on :) lets see if I get this app closer to working for me to see production at least.

rasmith | 8 October, 2019

Quick update: as of 10/08/2019 around 12:40 PM MT ... my app is showing current Production (3.9 kW), Home Usage ( 0.6 kW) and Grid Storage (3.3 kW ). Steps that contributed to a happy ending where: 1) Got Gateway as close as possible ( within around 7 Ft. distance at a first floor corner bedroom) to Inverter with antenna 2) CALLED Tesla Customer Solar Service (she was very helpful and nice attitude) and she walked me thru the steps to restart both the Gateway and the Solar System Inverter with antenna ... 2-a) Rebooted (Turn Off - unplug from outlet ... waited 5 sec. and then Turn On - reconnected plug) the Gateway ... 2-b) Rebooted ( Turn Inverter's circular switch to the OFF POSITION ... Then moved to the OFF POSITION the Cut Off Lever that is on the right of CUT OFF BOX which is at the right of Inverter ... waited 5 sec. ... Then moved to the ON POSITION the Cut Off Lever ... Finally TURN Inverter's circular switch to the ON POSITION ) Solar System Inverter with antenna ... waited maybe less than 20 min. and with any good luck your app should be getting information. NOTE: You need to wait for the email telling you that your system can be turn on and thus, Tesla would have setup your account correctly with your Solar System Setup (i.e. power wall, solar panels, etc.) ... I only had panels (no PowerBlaster and no power wall). NO NEED FOR PASSWORD wifi setup that is if your gateway can be close enough to the Inverter with antenna. GOOD LUCK !!!

moz1058 | 13 October, 2019

Update: after many phone calls they finally discovered that my Inverter serial number was entered wrong in their system. It took 2 days and it finally started showing solar production. Not from the date of install but whatever. I got to speak to 9 different reps. They didn’t seem very knowledgeable. Glad it works now. Call. Don’t email. They will not respond to you by email.

freddypaul | 15 October, 2019

I would like to post my experience(still going through the pain) if getting my gateway working.
Got my solar panel + inverter + powerblaster installed almost a month back. System was enabled two weeks back and since then I could see the Solar Panel production in my app. I had trouble getting my powerblaster working and showing the consumption from grip and panel correctly. Nothing from powerblaster shows up. Multiple call over two weeks and online debug by rebooting the system did not help. Finally they agreed to send someone onsite to fix it and scheduled for Oct 15. Yesterday(Oct14) afternoon all of a sudden powerblaster started showing some data, but weired even in the night 8PM full dark it shows my Solar panel is producing power(~0.8kW). am i lucky to get a panel that produce energy from the dark LOL not that luck. Something really wrong with the powerblaster, looking at the main meter and NEM meter and inverter all looks good showing what is being generated and consumed. Today on oct15 a technician came to check the system, as per him he did something the previous day to get the powerblaster working. Still the data seems to be incorrect and started working on the system. After around 20 minutes he comes back and told me everything is working fine and the problem was caused due to wrong serial number registered in their system. Happy everything working fine, since I was not feeling well today I did the mistake of not going out in the early morning cold to check if it is really working. Looked at the app and there was solar generation and fully consumed by my home. After some time when the sun really came out I check the system again and it still shows wrong data. Main meter says system is feeding power to grid(-ive reading), NEM meter says almost the same as the inverter. The App say same KW shown on the Inverter/NEM meter as consumed by Home, and the part of it is coming from Solar panel and part from Grid. I dont know what was fixed system still shows wrong data. Again back to call with customer care and they say at their end everything looks good and if there is something wrong with your meter call the utility provider to fix it(Now they started doubting the main meter that was there on my home for years). I contracted Tesla to get this system up and running and paid them to do this end-to-end. Again explaining to them with great patience they agreed to send a technician but with a rider: If there nothing wrong on our side you will be charged service fee!(First show me this thing working end to end as promised at least once). Finally they say wait for 24/28 hours for their system to get updated and app to sync before asking another technician out on the property and save the service cost. Well someone is looking out for the customer to save some money. I decided to wait since it is big enough amount to be saved. Now what another half hour app is stuck with old data, no more update of real time data, checked two hours later same story no more real time data.Hopefully I will have some time in my day after talking to the customer care to update the experience here. Looks like I will have spend another long hours with Tesla customer care.

reilly | 19 October, 2019

Panels via renting with no power wall has been installed.
Just got permission to turn on.
I turned it on and it looks like it is generating.
The gateway is plugged in for power and internet, no red lights indicating issues.
My app is signed I. Yet I can’t see ANY info. Just says there is an error trying to receive data....

gregbrew | 19 October, 2019

We're customers, just like you. That's something that Tesla Customer support should be able to help you with. Call them. E-mails seem to get lost is the Ether.

Paolobeltran | 23 October, 2019

@reilly, I am in the same boat. I am also a subscriber, and the only info the app shows is the production. I don't see the screens for energy usage, impact and grid flow as shown on this page:
Have you had any luck with yours? I will try moving the gateway closer and also reboot it, as well as restarting the inverter. I did that today already with no luck. I have a ticket in with Tesla and I may call them by Friday this week if it still doesn't change.

gregbrew | 24 October, 2019

Paolobeltran, You will only get home consumption data if you had a PowerBlaster consumption monitor device installed in your mail electrical panel during the PV system installation *or* if you have Powerwalls. If you have a PowerBlaster, you'll see a dedicated, labeled breaker in your main electrical panel. Powerwalls have their own, independent monitoring system that includes consumption. If you did not have consumption data prior to the changeover from MySolarCity to the Tesla app, it means you probably didn't have the PowerBlaster device installed, and the Tesla app does not have access to the data that's not being measured. Without either a PowerBlaster or Powerwalls, you won't see "Energy Usage" or "Impact" in the Tesla app, as both require consumption data for their calculations.

Paolobeltran | 24 October, 2019

@gregbrew thank you very much for making that clear. I had no idea. I am very disappointed that Tesla didn’t install the power blaster as the app is incomplete without the usage and energy impact data. I will contact them to ask about it. They never even mentioned it to me. I wish I had known ahead of time so I could have asked during the installation. I wonder if only the Power Blaster is compatible with the Tesla app or if I can use another energy monitor like Sense or something. Thanks again.

jamespetchonka821 | 25 October, 2019

It seems like I'm in the same boat, Paolobeltan. I was given permission to turn on my solar panels on October 18th and couldn't figure out why I could only see solar production. A PowerBlaster was never mentioned to me and you would think it would be part of the standard installation to monitor your home power usage. I have to say that I'm a little disappointed/upset at Tesla over this.

Patrick | 25 October, 2019

FWIW many solar inverters do not include home energy consumption monitors as a standard feature. A relatively easy fix is adding a whole-house energy monitor like those available from Sense or Neurio (now Generac).

We’ve been using the Neurio/Generac solution for about two years with good success. Fairly easy to install, free cloud-based data storage, nice mobile app for remote access. Monitors both solar generation and home consumption data with good accuracy compared to inverter data stream.

Make sure to get the version with 4 current transformers (CTs) - two are clamped on the 240VAC solar inverter output (measures generation), the other two are clumped on the 240V feed into the main breaker panel of the home (measures consumption). You may be surprised when you see EXACTLY how much energy is being used by various devices in the home.... Very educational.

Noam | 25 October, 2019

The PowerBlaster (a customized device that is only available from Tesla) is the only thing that can send usage data to the Tesla app (if, as Greg pointed out, you *don't* have a Powerwall).
However, there are other third-party devices out there (the Sense is just one of them), that can measure both consumption and solar production, and provide their own apps / web interfaces for monitoring.

Keep in mind, however, that there are technical and electrical code limitations in some cases (and locations), which may be why Tesla couldn't install a PowerBlaster. If that's the case for you, then those same limitations might prevent installing a different monitoring device, too. I recommend you check with a licensed electrician (who likely would have to come take a look at your breaker box to make that determination).

Paolobeltran | 25 October, 2019

I called Tesla and they confirmed that a Power Blaster was supposed to have been installed in my panel. They will send a field service technician in the next week or two to install. Hoping it goes through, you never know with Tesla. I was quite pleased though with their telephone support. Much easier than online.

Paolobeltran | 26 October, 2019

Update: I was curious so I opened up the MSP and removed the metal cover and it turns out that they did install the PowerBlaster. It is on and functioning, however for some reason it is not sending the consumption data to the Tesla app. How do I "force"it to do so? I googled and can't find a user manual for the PowerBlaster PB1 model. Frustrating.

Noam | 28 October, 2019

They would need to tie the registration of your PowerBlaster to your account. Take a photo of the serial number label (so you can read them the numbers), then call back to Customer Support, and ask them to add that information to your ticket, and escalate it to the troubleshooting department. Or, just wait for the tech to come, and do it for you.

ssinboston | 13 December, 2019

I and another friend are no longer getting solar data to the app. The last data is from 12/8/19. I definitely am generating as I can see it in the inverter logs. I've re-booted the routers, deleted and re-installed the app. The app says that it is up to date but I have "zero" generation for the week.

Wondering if others are also having this issue.

gregbrew | 13 December, 2019

My data is reporting just fine. I'm in So. CA. Running the Tesla app (3.10.1-384) on the latest PW firmware (1.43.3) on an old Android (5.0) Samsung Galaxy Note 3.

ssinboston | 13 December, 2019

@gregbrew Thanks for your info. I have an iPhone SE, and I have an iPad and my friend an iPhone 6. The app "works" in that I can see data prior to 12/8/19, but all data after Sunday is not showing.

I was thinking of trying the other rebooting techniques listed from October in the Forum.

rogerdata | 15 December, 2019

ssinboston Same problem since Nov 22. I have rebooted several times and call several times. They now say that I need a firmware update. They scheduled for Jan 13. Very inexcusable response. Since the system was working for months before this I don't see how a firmware update is going to help. I still get immediate info but no IMPACT or ENERGY USAGE data in the app. If you find out what the problem is for you that please keep use in the know as will I.

ssinboston | 15 December, 2019

Still isn’t working and now I have a Fault on the inverter. How did you actually get to speak to someone? I filled out a form a few days ago and just filled out another. (The form says someone will contact me in three business days)

@rogerdata Did you reboot the inverter too or just the gateway?

I get no new data in the app and now it says “graph data unavailable”. I guess the production is still going to the grid, just not reporting? Sure hope so. Losing the energy too would super suck

rogerdata | 16 December, 2019

@ssinboston I called 877-961-7652 Tesla Solar Support. Yes I rebooted the inverter and the gateway several times. Still have the same issue. Can see immediate data but not IMPACT or ENERGY USAGE data in app. only Home grid values show there.

gregbrew | 16 December, 2019

Rogerdata, The fact that you see production data says that your inverter and Communication Gateway are working just fine. "IMPACT" and "ENERGY USAGE" both require that you have either a consumption monitor (PowerBlaster) or Powerwalls. If you have neither a PowerBlaster nor Powerwalls you will *never* see consumption data in the Tesla app, and the two app functions ("IMPACT" and "ENERGY USAGE") will never work, as they both require consumption data.

birkey | 16 December, 2019

I'm in same boat as many others. I have a PowerBlaster but do not see the "IMPACT" or "ENERGY USAGE" screens.

My question is: Rather than wrestle with Tesla support ... can I just remove the PowerBlaster and install the Sense equipment?

Note:I already have the Sense HW and need the real-estate inside of my main panel currently occupied by the PowerBlaster and CTs.

rogerdata | 16 December, 2019

gregbrew You are wrong! As I saw all of the info prior to Nov. 22. End of that debate!

rogerdata | 16 December, 2019

And by the way I do have PowerBlaster

abhir.ranjan | 17 December, 2019

Anyone has any information on how to escalate this to someone in Tesla who can ACTUALLY help? Its less than 6 months since my system was installed, i have had the inverter replaced once already, since it was bad. Took 4 weeks to get that done. Now the new one has gone down again, been 5 days and the customer care has no people to come take a look until Jan 3rd so another 3.5 weeks of downtime. I dont know why I even wasted money on going with Tesla energy (btw, I love my model 3, dont take me wrong) but Solar business with Tesla is kind of very frustating. Do they have a issue department for escalating such bad customer service issues?

gregbrew | 17 December, 2019

Sorry, rogerdata, I did go back and scan the thread for more info on your setup, but missed your Dec 15 post. Sounds like your PowerBlaster died.

Birkey, If you're not getting consumption data through Tesla anyway, I'd (very carefully) give it a go. Sense will work, but it won't report through the Tesla app.

birkey | 19 December, 2019

Got my issue resolved by providing the EUI # off of the Powerblaster to Tesla who then registered it to my account. Sorry for the thread mini-hijack.

ssinboston | 3 January, 2020

Update: The reporting started again, but was sporadic. Some days everything worked, including reporting to the app, others it would just show generation on the inverter and the rest of the days my inverter was in fault mode.

A few weeks after my issues started, a squirrel moved in under a panel. I had an appointment today from my first support request while also trying to move forward with "pest" abatement from a follow up call. Guy today says that the squirrel has chewed on some wires and while the nest is newer than the problem, he suspects they started chewing earlier. He mentioned that there is some soy product on the wires, which annoyingly is attractive to squirrels.

So, he shut down my inverter as the continued faults can wreck the equipment. He is going to escalate my pest abatement to get it moving sooner.

Sigh. Zero generation now.

gregbrew | 4 January, 2020

In the days of Solar City, the company would come out and install screens around the array to keep out critters...for free.

MattV | 6 January, 2020

@Freddypaul, did your issue get resolved? I have almost exactly the same problem... I posted a screenshot of my tesla app on this thread: , but it sounds very much like your issue...

rogerdata | 15 January, 2020

Well Tesla came out on Monday the 13th and updated the firmware in the inverter. Just as I expected this did not solve the problem of not seeing Impact and Energy usage data. From what I understand now Solar Edge and Tesla are pointing fingers at each other and claiming the other is at fault. I have not had data for over two months. I called again and was told that the tech had not yet turned in his notes, so they cannot tell me how they are going to proceed. To make matters even worse today I do not even have instant data in the Tesla app. No info showing for solar,grid or home.These people need to get their s*** together before I seek legal remedy.

rogerdata | 17 January, 2020

Everything magically back to normal today. Obviously a problem with computer outside of my control. Exactingly what I told them was my opinion of the cause of my data loss. Could have saved them money they spent to send someone out for several hours to upgrade firmware for nothing. Of course they are not being forthcoming as to the specific cause just a phone call saying we see production data now. lost all history from Mid November till today!

jonhgaarg | 17 January, 2020

have the same problem guys.

rogerdata | 20 January, 2020

I guess I misstated! All of the data seems to be there but the instantaneous readings on the main solar page are only updating every 20 minutes or so.This makes it totally useless.

toshaldudhwala | 22 January, 2020

i have a new system installed and activated last week. it took them 5 days to figure out why I can't login on my mobile app even though my system was registered under my account. finally this morning, they fixed some issues. They said that they are having issues with the data cloud.
now that I have my app working, i don't see the usage data. so i called customer service. they said that since there was no space on my main electrical panel, they didn't install the powerblaster. they created a new sub-panel to install the solar.

vonsevilla | 26 January, 2020

I wrote this email to Tesla Support:

To whom it may concern

I bought sense solar (an energy monitoring equipment that measures both solar output and house appliance usage) from Amazon during black friday.

On Dec 3, 2019. I asked the solar installation crew if they could install my sense energy monitor since they will be messing with the breakers anyway. I told the tesla electrician Brian I’ll even pay him in compensation for the labor of installing my sense solar monitor. He and another crew member looked at my sense solar and said “Oh hey we have something already like that, you won’t really be needing that since we will be installing our own. It will monitor your solar output and home usage and what comes out from the grid. I told them yes but yours does not monitor home appliances and it gives me more details than that can as I point at their energy monitor (it was black and looks just like my sense solar) it even has the same dimensions. I told them it also monitors my solar output. Brian and another crew member sure thing we’ll see if we can install it and let you know. When the solar system was finally done and before they left, I asked Brian if he was able to put it my Sense energy monitor. Brian said they couldn’t put the sense solar in because they don’t want to be charged with “tampering of meter”. I said ok I’ll return my sense solar then since you will be putting in your load monitor anyway. I said my goodbyes thanked them for their services and returned my sense solar to Amazon.

A week later I finally receive PTO. I was so excited because I wanted to see the power flow on the Tesla app just as any other person who recently installed Tesla Solar Panels. I noticed I was not seeing the power flow from solar to grid or solar to home. All I saw was solar output from solar panels. I called Tesla support immediately and this is what I was informed:

Mr Sevilla, according to the notes they wrote “ They could not install their Tesla energy/load monitor because according to the comments left there was

“Not enough room in breaker panel”.

Imagine how upset I am. I’ve already returned my sense solar energy monitor back to Amazon and Brian or any of the installation crew failed to inform me that they were not able to install their side of the Tesla energy monitor aka Solar Blaster as what they call it.

One of the bigger reasons why I’m upset is I paid A LOT of money and chose Tesla over any other Solar companies because of their reputation over something as little as “Not enough room in breaker panel”. Whatever it takes, make room. Seeing the Tesla Power Flow monitoring over the Tesla app to a PAYING customer is 50% of the satisfaction of the Solar installation.

Please see if you can make this situation right or direct me to whom I can speak to in regards to this issue. Thank you so much for your time, looking into this.

Sincerely, Tesla Customer
- Von Sevilla

rogerdata | 27 January, 2020

vonsevilla As I stated above their system (Tesla) has not been working properly for over 2.5 Months. So I have ordered a monitoring system for $197.00. It is from IoTaWatt. It not only monitors the home draw but solar and 11 other circuits individually . Not that it will matter but I will send the invoice to Tesla and ask for compensation since their system has not worked in so long! This system would be installed by an electrician and will need software that is free on GitHub. I am an electrical engineer and do software so I expect to be able to install myself. The only problem I see with sense solar's system is it tries to identify loads based on its data base of known draws. A lot of people have problems with it identifying the appliances that way.Also if your electrical panel is very full you may not have room to mount the 14 coils that the IoTaWatt can use. but take a look at and see that system.

baldocchi | 29 January, 2020

Looks Like I am joining the club. Got to turn on my solar panels yesterday, after waiting nearly 6 weeks for submission and approval. I think the solar system works, as the light is green on the inverter when the sun is up. But I dont see the system production on my app and the gateway does not see the inverter. I have rebooted both inverter and gateway, moved the gateway closer to the inverter, emailed and called Tesla. So far little help. No email response, as others testify. The person on the phone told me to wait 24 hours and it will fix itself. this sounded like a nonsense answer. Hope this forum is being read by staff and they get on the ball and fix the system all of us. It surely seems to be more difficult than it needs to be.