iOS 13.1.2 bluetooth problems

iOS 13.1.2 bluetooth problems

since updating my iPhone to iOS 13.1.2, Bluetooth has been very problematic with my Tesla model three. I can only unlocks the doors by using the app. It no longer his senses the phone by proximity. After connecting with the Tesla app there is only one Bluetooth sensor noted in the iPhone settings. There used to be 4. Anyone else having issues like this? My car has not received the V 10 update yet. I’ve tried all the usual fixes, restating everything signinging out and in etc with no change at all. My wife is also having bluetooth issues between her phone and fitbit, but that’s a different story for another place.

Mikael13 | 8 October, 2019

I’ve had the same problem with the new update as well. Never had the issue previously (6 months of ownership). Anywho, my solution was to remove all apps connected to my M3. Then re-installed app (including Stats), including bluetooth and as key. After a few tries, it works 90% of the time. Once in a while, I have to reach in and wake up my iPhone 11 then door opens. Kinda annoying. Not sure if it’s due to update or new iPhone to be honest.

EVRider | 8 October, 2019

Go into Controls > Locks, delete the phone key, and set it up again. You’ll need the key card to do that.

I’ve noticed that since upgrading to iOS 13.x, sometimes my phone doesn’t automatically connect to my Model S and I have to connect it from the touchscreen, so there could be an iOS Bluetooth issue. We’re on a Model S road trip and the Model 3 is at home, so I don’t know if we’ll have phone key issues. Haven’t upgraded to V10 yet.

jacques3dogs | 8 October, 2019

I am not sure if my issue is caused by upgrading to IOS 13.1.2 but I am unable to use the Tesla App to connect to the car. The app will not show my car, nor will it show the charge status or any of the other features that are normally displayed on the main screen. Instead i get a black screen with a black car (mine is white) and a message in the middle of the screen that says "Vehicle Connection Error". I am able to access my account via the app so somehow I am connected to my account but not to the car. In the car ( in the garage) I tried to connect to WIFI but I get an a message : "MAC address not available"
I deleted the app and reinstalled it, same issue..turned phone on and off, nothing changed...
Any body ran into a similar issue?

tbevivino | 8 October, 2019

Same issue here as well. Glad to know I am not the only one.

Rllhkeller | 9 October, 2019

After upgrading to iOS 13.1.2, the phone key does not work. Apple released this version to fix Bluetooth (maybe other thing too). Bluetooth music streaming still works and the Tesla app still works because it used the internet, not Bluetooth. iOS 13.1.1 Bluetooth does still works. Have appointment with Tesla Ranger on Friday to demonstrate. This is either Apple’s problem or Tesla’s problem. If enough people complain, maybe it will be fixed. I gave an old iPhone available just to unlock car!!!
I normally don’t upgrade iOS for several weeks until problems like this are found. This time my wife’s phone was set to automatically update and now I am paying the price.

Rllhkeller | 9 October, 2019

My wife’s iPhone asked to be upgraded (it was not automatic) and I forgot to tell her to ALWAYS decline. Do it manually after reading about problems.

r0yster.richardson | 9 October, 2019

I tried reconfiguring the iPhone as a key, no change..... So lame. I have to use the app to lock, unlock etc. One in the car I can close the app and it works, but missing the convenience of walking up and opening the door and walking away to hear the horn beep as it locks. Thanks Apple, awesome job.

Rllhkeller | 9 October, 2019

Wow! Got a solution!! It now works with iOS 13.1.2.
Just got a call from Tesla Orange County CA mobile service team. They said to delete the Tesla App, download a new copy from Apple App Store and reinitialization. My phone now works and unlock as it should.

petegajria | 9 October, 2019


Settings -> Tesla -> "Allow Tesla to access" -> Bluetooth -> enabled

petegajria | 9 October, 2019

You DO NOT need to delete the app. You just need to allow the Tesla app to always access bluetooth, even if its not running. I had the exact same issue earlier.

in7 | 9 October, 2019

Today I wanted to make a call from the car and my car wouldn't connect with my iPhone.
The help menu said to remove the phone from the car's bluetooth menu, then re-add it.
After I did that everything was fine.

jim | 17 October, 2019

I am having the same connectivity issues with my model S. I deleted the phone, turned bluetooth off, restarted and and re-paired the connection successfully yesterday. However, it will not connect today.

kinupeiphone | 17 October, 2019

It will be fixed in the next update. I am on the beta team and my resolved within 13.2

goddesavatar | 17 October, 2019

I have 2019.32.12.2 58f3b76 software and i have same problem. I tried rebooting system, deleting tesla app on my IPhone xs Max and other couple things but connection somehow fails again.

rob | 18 October, 2019

I'm seeing the issue as well. I have iOS 13.1.3 and 2019.32.12.2. But I don't think it's Tesla's issue.

EVRider | 18 October, 2019

Since upgrading to iOS 13.x, my iPhone Xs occasionally fails to connect with my Model S when I get in the car. The calendar doesn’t automatically appear on the touchscreen, and when I try to display it, the car tells me there’s no phone connected. I display the Bluetooth screen and my phone is listed, and I can connect it there and all is well. I think this started happening before upgrading to V10.

I haven’t had access to our Model 3 since upgrading the phone because we’re traveling, but I’ll see how that works when we get home.

paulsurette71 | 18 October, 2019

In the latest iOS 13.1.3 update includes the following:

"Fixes an issue where Bluetooth may disconnect on certain vehicles"

I have an iPhone 11 Pro, with iOS 13.1.3 and haven't noticed any changes. The odd time my iPhone won't get me in the car, but a few times it wakes up and lets me in.

jwalkeromr | 20 October, 2019

I'm also having this issue. Recently upgraded to an iPhone 11 with IOS 13.1.3. Also updated Tesla SW to V10. iPhone won't pair with Tesla entertainment system for phone / media. The iphone 11 does pair with car's computer for proximity door lock / unlock and other features.

My iphone 11 does pair with Subaru bluetooth entertainment system. Also, wife's iPhone 6 with IOS 12.4.2 pairs with Subaru and Tesla systems.

I'm thinking there's an sw interface problem between IOS 13.x and Tesla's Entertainment System. I've done all the usual reboots and checked bluetooth privacy settings with no resolution to the problem.

For now I'm waiting for an update from Tesla (most likely) or another IOS update.

EVRider | 21 October, 2019

@jwalkeromr: When you say your iPhone 11 won’t pair with the Tesla for phone/media, do you mean the phone is detected but not connecting, or you try to pair the phone as a new device and it doesn’t work? Either way, go into Bluetooth settings in the car (touch the Bluetooth icon) and delete your old phone if you haven’t already.

ptn.frcpc | 21 October, 2019

Similar issue with latest iOS updates: 13.1.3 and Tesla v10. Entertainment/phone won’t connect but can use phone as key only.

ptn.frcpc | 21 October, 2019

Similar issue with latest iOS updates: 13.1.3 and Tesla v10. Entertainment/phone won’t connect but can use phone as key only.

jwalkeromr | 23 October, 2019

Here's an update that might be useful.

Decided to try and pair my iPad running iOS 13.1.3 to the Tesla phone/media system running V10. Surprise!! It worked.

After the iPad bluetooth connection decided to retry pairing my iPhone 11 (iOS 13.1.3) to the Tesla. Suprise!! it worked. I'd tried to pair the iPhone to the Tesla just prior to trying the iPad with same result... no discovery.

I have no idea why this worked but now I'm up and running with a phone connection to the media system. Thought I'd repost, maybe this will help someone else.

rob | 24 October, 2019

I'm using iOS 13.1.3 on an iPhone 7. Car is running 2019.32.12.2.

That combo doesn't play well. I frequently have to use my card to unlock a door or start the car. Sometimes, it will work. Then I get out of the car for 2 minutes, get back in and its nagging me for the card on the dash.

The most annoying thing is that I've left my wallet on the console a couple times. Other than that it's not too annoying.

I know they'll address it in a future update.

SnowZA | 24 October, 2019

@rob you don't have to leave your wallet or the card on the console - it needs to be there long enough to be recognised, the car will authenticate it, and start. as soon as the car is started, you can put the card or your wallet away again immediately. That way you won't forget it there...

h2ev | 24 October, 2019

I'm still on 12.4.1 and was just about to do 13.1.3. Will hold off now after seeing this thread.

SalisburySam | 24 October, 2019

Datapoint: car on v32.12.2, iPhone7 on v13.1.3. Both working well, not experiencing any connectivity or operational issues, and did nothing to car or phone after updates.

SnowZA | 24 October, 2019

My car is also on v32.12.2, iPhone 7 on v13.1.3, also no problems.

CaliforniaMaki808 | 24 October, 2019

I have a Note 4 (yes, you heard it correctly). My bluetooth (Bluetooth 4.1, A2DP, EDR, LE) keeps dropping and connecting. Not sure if it's my phone or the software updates.

jvcesare | 24 October, 2019

13.1.x is very buggy. DOD has told it's employees not to install it. My phone works fine on 13.1.3 but it's brand new. Meanwhile my wife's iPad Air 2 has a major issue. When charged to 100% it thinks the battery is zero and reboots. 13.1.2 had a bug that would not charge above 98%. IMO they screwed up something in a major way. I opened a ticket with Apple and talked to a CS rep. She says they have been inundated with calls about v13.1.x. My suggestion is not to upgrade to it until a new bug fix is released.

wb808 | 24 October, 2019

The iphone update seemed to have defaulted location access on all apps back to "while using the app."

Go to Settings -> Tesla -> Location -> Always

Not sure if that's a fix for everyone but worked for my wife and I.

RobAuto | 28 October, 2019

I had the same issue after the update: The Doors not unlocking when I came to the car. I had to use the app or the key card. This is what I did to make it work like normal again. I went int my iPhone-->Settings-->Tesla-->Location (Change it to "Always". After this, it now works everytime... Hope this helps!

SalisburySam | 29 October, 2019

NOTE: iOS v13.2 is now available. Comments indicate Bluetooth improvements.

mps331 | 29 October, 2019

thank you, I checked my iPhone and it was changed to only when using app, I changed it to always allow... I guess that's why I was also having issues, il update later, if it does work...

xhs | 31 October, 2019

I have the same issue, my phone key doesn't work with my Model 3 once a while, always need to carry my card key since I changed my phone to apple 11 pro, very annoying.

mps331 | 1 November, 2019

well, here is an update, after signing off to my app and signing back in, and keep "allow always" these have helped with sensing my phone now... I didn't have to delete (yet)...

hope this helps...

rbelot | 5 November, 2019

FIX..........In iPhone go to settings then all the way down scroll to the TESLA app. Click on it and turn on BLUETOOTH.
It's off by default with the newest iPhone upgrade.

bobd78 | 28 November, 2019

Same problem with iphone 11 - works as key but will not connect to phone/media.

Rock1982 | 28 November, 2019

I’m having problems with Bluetooth. Connects fine with my model 3 but people say they can’t beat me on the other side properly.
I reseted my phone and the car but still no improvement. Any suggestions please.

Rock1982 | 28 November, 2019

Hear me*

EVRider | 29 November, 2019

@bobd78: In the car’s Bluetooth settings, delete the phone and then re-pair it.

bobd78 | 30 November, 2019

i did that and still get message that says can not connect. Appears iphone 11 operating system will not pair with Tesla?

EVRider | 1 December, 2019

iPhone 11 works fine with my wife’s Model 3. Check the settings for the Tesla app (in iOS settings) and make sure it has access to Bluetooth. Also check your phone’s Bluetooth settings and make sure everything looks right.

bobd78 | 7 December, 2019

Thanks but I have done all that a number of times. My iphone11 IOS is 13.2.3

Yiliayang0809 | 15 January, 2020

Here are solutions to fix your iPhone Bluetooth not working iOS 13 issue:
Tips 1: Restart the Bluetooth and the Bluetooth Device
Tips 2: Force Reboot iPhone
Tips 3: Forget Bluetooth Device
Tips 4: Reset Network Settings
Tips 5: Fix with Joyoshare UltFix Losslessly
Tips 6: Contact Apple