Finally getting Text Messaging feature

Finally getting Text Messaging feature

Can’t wait to receive this update. Been waiting a long time.

lbowroom | 23 December, 2019

When a new message is received press the right scroll wheel button to have your text message read out loud and press again to respond by speaking out loud.

raqball | 23 December, 2019

Wow, can't wait... The car just keeps getting better and better!

M3phan | 23 December, 2019

Incoming texts will chime. Also, I like how the texts will be located in the cards section of the screen.
No group texts though (yet).

jamilworm | 23 December, 2019

I am also excited about this update.

WW_spb | 23 December, 2019

Finally getting basic functionality that everyone has already. It's should have been priority for Tesla bc it's safety problem.

Slonkis | 23 December, 2019

I wonder if WhatsApp messaging will be subject to the same treatment. Texting is of limited use to me.

EVRider | 24 December, 2019

@Slonkis: I think Tesla would have to create a WhatApp app for the car, and I don't see that happening because there's not enough demand.

Frank99 | 24 December, 2019

By the time Tesla creates a WhatsApp app, all the cool kids will have moved on to the next messaging app. See ICQ, AIM, Talk, Chat/Messenger, WeChat, SnapChat, WhatsApp, and Slack. Almost seems like it's not worth the effort to keep up.

Frank99 | 24 December, 2019

Played around with it a bit this morning. Still can't figure out how to get it to actually send a text - can get it to recognize the command, voice-to-text the message, but tapping on the screen to send the text causes it to disappear.

bcmusik | 24 December, 2019

Are you on an iPhone or Android?

tdwin2000 | 24 December, 2019

Frank99 I downloaded the new update. It is NOT recognizing my voice when I push the button at all. it used to before the update. The fact that you are having the same problem there must be a bug with this software. Hoping a bug fix comes soon.

Frank99 | 24 December, 2019

I'm on an iPhone 8+. Based on all the other threads flying about, it seems like I'm in good company having issues with this. I'm sticking with "It's a feature my car didn't have when I bought it, so I'm willing to be patient while they get the bugs worked out of it." Besides, I won the first game of backgammon I played, so I'm


Slonkis | 24 December, 2019

@EVRider, @Frank99
I was thinking along the lines of how Android Wear (now Wear OS) operates. It does not depend on having a native app for displaying notifications on the watch. Tesla could implement something similar for reading aloud notifications from essentially any apps the user selects, configured in the Tesla phone app. I think there's value to that. For sending I agree, you still need a native app.

Sarah R | 25 December, 2019

With a Samsung Galaxy Note 8, I had to first enable message sync on the car, then on the phone, disconnect Bluetooth, then reconnect.

I did not unpair/re-pair. Simply disconnect, reconnect. Android detected that the car was along four a new privilege and prompted me with a settings screen that included all of the previously enabled privileges and a new one: messages.

Once this is set, you can

"Send text to 《name》"

And a card will appear telling you to tap the card to dictate text. Do it. Them another card will appear telling you to tap to send the text. Do it. It's kinda lame needing two touches to do a voice command, but it works.

Magic 8 Ball | 25 December, 2019

I am not able to get the car to "sync" to text messages. Tried both my iphone 10 and wife's iphone 10. I click on the slider in car to "sync" and it disconnects phone and reconnects but slider does not go to "on" position. HW 2.5. Anyone else able to get the message sync working on 2.5 with iphone 10? Any tips?

Scrannel | 25 December, 2019

Magic 8 -- was having that issue -- but got in this morning, disconnected and reconnected BT and phone asked if car could read messages -- then the slider worked. Sent myself a text and that worked.

craigwilliamson1 | 25 December, 2019

Having no luck with iPhone 8 Plus or 11 it displays the message but I can’t send I also can’t sync I guessing it has something to do with iMessage vs standard text. I’m sure the will get it fixed lots of iPhone users out there

Magic 8 Ball | 25 December, 2019

I thought I tried everything but I will play with it more in a bit, thanks.

Magic 8 Ball | 25 December, 2019

Woo Hoo, got it.

I went to far in the phone menu and should have just stuck to the clear instructions which I misunderstood. It is starting to feel a lot like Xmas...

craigwilliamson1 | 25 December, 2019

Magic 8 what did u misunderstand

Magic 8 Ball | 25 December, 2019

When I went into my phone settings I went past "Bluetooth" and scrolled down to "Tesla" and opened it. Within that menu you can turn bluetooth on/off and your notification settings. That was the wrong place to be.

I should have opened "Bluetooth", in the phone settings, and I would have seen "Tesla Model 3" with the "information" Icon (like it says in the release notes), Doh! After getting to the right place in the phone everything made sense and worked.

craigwilliamson1 | 25 December, 2019

Never mind I can’t read and comprehend either.bluetooth settings !!! Thanks I got it

roccosima | 25 December, 2019

It's working, sort of, once I figured out how to sync the Blue Tooth notifications. It reads texts great. It's hit or miss on replying. When it does work my response is only occasionally displayed even if the reply actually goes through.

EVRider | 25 December, 2019

The release notes include instructions for enabling this feature, and those instructions worked for me.

rasinas | 25 December, 2019

Our Android Messages app was recently upgraded to use RCS instead of SMS/MMS and the messages don't come in legible. I hope they update the app to work with it going forward.

mlspropertiesllc | 25 December, 2019

We have 2 model 3s, one the voice commands don’t work at all, the other works somewhat. One of them keeps butt dialing the same number over and over. Both cars receive texts fine but neither will reply to texts nor can you initiate texts. Not uncommon to have bugs with new updates so look forward to the fix. (Yes I followed all the instructions regarding Bluetooth and tried the disconnect/reconnect.)

RP3 | 25 December, 2019

sorry for hijacking this thread to ask a question, but I can no longer post a new topic. (requesting verification now)

- Today I have NOT been getting any of the group text messages sent to my phone. I'm at home and connected to the model 3, but I've tried turning off bluetooth on the phone and still not getting any of my group text messages. I've also unchecked the 'sync messages' on the bluetooth menu in the car, but still not getting any of my group text message. This only started after the latest Xmas update to the Tesla.
Anybody else have this issue? Any fix for the issue?

njelectric | 25 December, 2019

The release notes say you will not get group text messages. The car cannot handle them in this release.

RP3 | 25 December, 2019

But I stopped getting them at all, even when I’m disconnected from Bluetooth. Arg!

sced06 | 25 December, 2019

The update is horrible. Didn't Tesla test this? I've gotten the voice commands to change climate and open glove box sometimes but other times it just ignores the command all together. If I say send a text message the card will come up and say "tap to dictate" I tap it and it says "listening." but then I speak and nothing and the card just feezes and I have to swipe it away. after about 20 tries it finally actually dictated my message. Then it says "tap to send." but when I tap it it doesn't send it just erases everything and says "listening" again. It took Tesla years to offer something cheap Honda's and Fords have done for years and they couldn't even get it right. I expected way more from a 50K car I purchased instead of a Mercedes.

apodbdrs | 25 December, 2019

@Sced06, when you tap to send, it does erase everything, but it actually send the message.

Alan_F | 26 December, 2019

Google Pixel 3a with RCS messaging - I can confirm the text to voice is useless with RCS messages. The header and footer information that is displayed and read out loud makes the message unintelligible. Hopefully there will be a fix soon.

lordcn1 | 26 December, 2019

Works as advertised (use the info tab on the Bluetooth page instructions) on my May 2018 Model 3.

wiscy67 | 26 December, 2019

I tested briefly and got the text messages to send and receive. The command "Text " pops open the window that you have to tap to initiate dictation. When finished with dictation you then have to press the screen again to send. (So that's two screen taps.) I did this with my phone out of view on the wireless charge pad.

Someone posted that you can also use a "Send " all in one step without having to touch the car's screen. I'll test that next.

gparrot | 4 January, 2020

So how does one correct an inaccurate text? I dictated "I’m leaving for Hudson now" to my wife, but the card displayed "I’m leaving for Roxanne now". Obviously I didn’t want to send this, but I know not of a way to erase or cancel a message.

EVRider | 4 January, 2020

@gparrot: Good question. Maybe the card just goes away if you don't do anything with it?

r1200gs4ok | 2 April, 2020

I have an iPhone 6Plus....I can receive text mis but cannot see a reply button.....what am I doing set up to sync and use contacts....I gt the txt pop up on the dahs and press the scroll but to hear it....but never see a reply please