Software Update 4.0 Received

Software Update 4.0 Received

Who has received the latest update? I was told that updates go out in batches to make sure if there are bugs that the fewest number of people possible have an issue, but I am getting really anxious with this update. I was just curious how many have gotten the update so far.

mkh1437 | December 4, 2012

I have *not* received the update yet. I'm beginning to feel left out!

Kauai | December 4, 2012

VIN457, an no update yet

MitchellK | December 4, 2012

VIN 277 (Sig), no update yet

mkh1437 | December 4, 2012

VIN 871, Signature, no update yet.

Afilm_Guy | December 4, 2012

VIN 579, Signature, no update yet.
I'm beginning to feel left out!

BYT | December 4, 2012

VIN 882, no update yet!

WSE51 | December 4, 2012

VIN 121, no update yet

BYT | December 4, 2012

Sounds like nobody at all has the update outside of new and very recent Model S deliveries?

joepruitt | December 4, 2012

VIN 342, Just started the update. Fingers crossed...

Dogface | December 4, 2012

VIN 405, no update. I called yesterday to inquire about it. I was told it was indeed going out in batches. Rep had no idea what the sequence or logic was behind the roll-out. Said to call back at the end of the week if I had yet to receive the update.

mohan | December 4, 2012

VIN 467, no update yet.

Brian H | December 4, 2012

There're only so many radio waves (and servers) to go around ...

bfranks273 | December 4, 2012

Yeah but could we get two or three? Vin 96 no update yet.

Timo | December 4, 2012

It should not be server/bandwidth problem. If they have problem in those areas now, imagine what it would be when there are ten or hundred times more Model S out there.

pilotSteve | December 4, 2012

Sig vin00912 got it upon delivery. Be glad you didn't get the first release of 4.0. Flashing driver display, phantom errors about charging and charge door open, dinging sound that would not stop (like the car thinking it was not in park when it was, or that a door was open and you were in drive, which also was phantom).

However, the second "1.4" (I have not confirmed but the version number may be the same) software upload completely fixed the issues and the new feature are very desirable.

So.... perhaps Tesla rolled it out too early/too fast and they are being more cautious. Or possibly the software was not flawed but it failed to install properly. In any event, I'm sure you will get it soon and be happy.

Brian H | December 5, 2012

4.1, surely. Those who got the "gong show" now know better than to freak out at every unusual ding-dong or flash display, though.

Michael Emrich | December 5, 2012

Sig 1,267 (VIN: 0961) just received firmware update 1.17.50 (Vers. 4). Everything works perfect. It also fixed my HomeLink issue. Very happy.

MandL | December 5, 2012

Nothing yet. This puts me in mind of a mobile device app feature request (which I'll add to the appropriate thread).

Notification on mobile device of the availability of a software update for the car and the ability to initiate or schedule it remotely.

drripps | December 5, 2012

Sig 192 no sign of update yet.

roundh | December 5, 2012

Took delivery November 25 at the factory. Sig #967. no update yet.

Richard M | December 5, 2012

Signature VIN 372. No update for me yet.

Brian H | December 5, 2012

Anyone who gets the "gong show" reaction, please video and post!

Carmine | December 5, 2012

VIN 622 no update yet; but, more importantly, no Sig yet!

William9 | December 5, 2012

VIN 1572 got the update on 11/29, no problems. Not sure why I got it so quick as I picked up my 11/28 at the factory.

chort67 | December 5, 2012

Sig VIN 989 delivered 11/30/12. No update yet.

jd3tm | December 6, 2012

Perf Sig 692, VIN 00465, delivered 11/2/2012. No update yet! grrrr.

mkh1437 | December 6, 2012

Sig VIN 871, delivered 11/16/12, still no update.

STEVEZ | December 6, 2012

Sig VIN #118: I got the update this evening.

Teoatawki | December 6, 2012

Sig VIN 752: No update yet.

Very much looking forward to it. I have phantom AFAICT dings, phantom charge port open messages, and very interesting nav system gremlins, where it thinks I'm really close to my next turn, then where I really am, rinse, repeat.

John S | December 6, 2012

Can anyone tell me the specific version of software/firmware that you're talking about when you say "4.0 update"? I'm assuming its the version # that's listed when you hit the "T" logo on the top of the Nav screen? Something like "1.14.XX"?

Klaus | December 6, 2012


Amos' Tesla | December 7, 2012

Vin 207 got it this evening. My wife is going to vomit if I walk by the car one more time and ask her if she sees how the handles automagically extend. I absolutely love this car!

Brian H | December 7, 2012

Just tell her to keep well back. The stomach acid wouldn't be kind to the finish.

mkh1437 | December 9, 2012

Still no update for me (Sig VIN 871). Was it something I said?

blurry_eyed | December 9, 2012

VIN # 532, Received the update Wednesday night, December 5th. Very nice update to squash some bugs in the software and improve the functionality of the car!

Brian H | December 9, 2012

Yes. Try politeness instead of raging insults next time, 'kay?


Jon Wray | December 9, 2012

Vin 939. Got the update Friday. One glitch Saturday night: after putting the car in park, when I tried to open the left rear door to let my son out, it wouldn't open. Then the handle retracted (others remained open, despite sync door handles enabled). I could not get the handle to extend, so I let my son out the right rear door. Then I drove the car to a parking spot and tested the door handle and it worked fine.

jd3tm | December 11, 2012

Sig 692/VIN 00495...

Got my 4.0 upload yesterday while at work! Noticed a few things that I haven't seen reported anywhere so I'm trying to understand if these behaviors are bugs or what!

1. Acceleration is certainly smoother and perceptibly quicker as indicated in release notes; BUT, regen braking is ALSO very noticeably changed! In standard mode, it is much more aggressive at slow speeds. As the car slows to close to Zero MPH, the car continues to move forward as in CREEP mode without actually stopping. If I touch the brakes, car stops. This is very new behaviour for my car. Prior to 4.0, regen braking stopped providing braking power at a much higher speed such that you had to use the brake earlier in stopping sequence. Has anyone else noticed this change?

2. CREEP Mode is now grey'd out and can't be selected! I didn't find anything in the release notes about eliminating CREEP mode?
It has apparently been removed as a feature although the selection is still there but can't be programmed either to enable or disable. The behavior is that it is DISABLED.

3. Lost the driver profile setting for mirrors when in Reverse. I had to reprogram both forward and reverse settings for both outside mirrors after the update. No big deal, just unexpected!

4. Brightness was reset to ZERO percent! Caught me by surprise and took me a second to realize that is what had happened! After readjusting, all seems to be back to normal...aka, it hasn't gone back to ZERO again.

5. Not a bug I hope - Performance of Maps is much faster than before! Both when displaying Traffic and when not! Thanks.

So much for things I found after 24 hours on 4.0 SW update!



HaroldS | December 11, 2012

@jdt3m -

1. Yes, I thought the regen had changed noticeably. Kind of disconcerting that it gets really strong at low speed, whereas before it backed off at about the same speed level.

2. Haven't noticed anything about Creep, since I don't use it.

3. Yes, same here. As you say, easy to reset.

4. I can't seem to bring up the brightness control on the roller wheels now, although I reset it in the Control Panel. I think perhaps I don't completely understand the modifications of the right wheel and perhaps the brightness control is in that set of menus.

5. I noticed sort of the opposite. The car has a very difficult time establishing connectivity, even though it had no problem before in the same areas.

Other issues:

A. The sound system zeros out when the car goes to sleep. The prior operation is lost and the system has to be reset manually.

B. The selection of metric display only lasts until the car goes to sleep, then everything goes back to English. This one is quite annoying, since I understood that this selection was to be part of the driver profile. I thought perhaps when I readjusted the tilt down mirrors and saved that to my profile it would save the metric settings, but it didn't. Grrrrr.

Overall this is a great update, and the features are ones that we wanted and will use regularly. I'm sure that these few issues can be fixed shortly.

gimp_dad | December 11, 2012

Did anyone notice how long the actual SW update took for your cars? I finally had the notification this morning and set the car to update after my workout this morning an hour before I planned to leave for the office. When I went to leave an hour later it did not appear to be done. The car was off and not responding.

This is my fourth SW update and none of them have taken an hour so I was just wondering if this was expected and would love to hear form someone who
a) has actually done the update (no thanks, on speculations),
b) watched how long it took.

Just want to make sure my car is not somehow "bricked".

Thanks for any help.

jd3tm | December 11, 2012


the update takes 2+ hours depending on your 3G connectivity. I noticed that having a strong 3G connection seems to enable quicker updates generally and in this case enables the update to be done in just at 2 hours!

Bill Tracey | December 11, 2012

Vin #450 no updates yet ????

blurry_eyed | December 11, 2012

I would recommend doing a reboot of both the touchscreen as well as the instrument display just after you install the update. I had some issues right after the update, but after rebooting, it seemed to take care of the glitches I had.

To reboot, hold down both the left and right steering wheel scroll wheels until you see one of the screens go dark. I can't remember which screen it reboots. The other reboot will happen when you hold down both the left and right steering wheel control buttons above the scroll wheels. You have to hold down one of the button combinations for quite a long time (Maybe 30 seconds to a minute) to get to the reboot (The screen will go dark).

Creep mode should be working (You should be able to turn it on and off while in park), so if it appears to be disabled, the reboot should bring it back.

Dripps | December 13, 2012

No update yet! VIN 192. What's taking so long!! I want the magic door handles.

Michael23 | December 13, 2012

Vin 1709 I got it. I had an issue where my power was reduced s they bumped me up the list to fix it.

Michael23 | December 13, 2012

Harold I Definitly have creep working, I would reboot your screen to see if it fixes. My fav parts of update are the smoother throttle (you can barely press the pedal now vs. before you had a dead zone), the voice update with slacker search, the letters for scrolling, and the door handles of course!

William9 | December 13, 2012

I read in Wired Magazine something I didn't realize. The software is apparently uploaded to the car while out driving around when the 3G signal is strong. Then when you plug in the car at home, it displays the clock which allows you to initiate the installation. If correct, the "bricking" process time should be independent of the 3G connection at the time of installation. Anyone have confirmation of this? Here is the article:

HaroldS | December 13, 2012

Just another positive thing about the V4.0 update. Previously, the energy use by the climate control and other ancillary systems wasn't reflected on the Kw meter in the speedo cluster. Now at least some of those power uses are included. For example, when the car is sitting still and the heater is on, the kilowatt draw now shows in the dial. I find that helpful.

The metric settings still don't "stick", and have to be reset after every "sleep" period, but a Tesla rep tells me they are working on that issue.

As other posters have noted, the change in throttle (and regen) taper is an excellent improvement once you make the mental adjustments.

StephRob | December 13, 2012

Vin 626 hasn't gotten it yet. :-(

jd3tm | December 13, 2012

quirky things after 4.0 udpate installed:

in addition to those I already mentioned, I have now had 2 instances of the:

"Tire Pressure too Low" - check Tire pressure Warning indication. This indication goes away after a few minutes. Has happened on 2 different occasions in the past week.

I also had a "unknown error bit nnnnn" Warning that vanished before I could take a photo so didn't get the full readout.

Still can't get CREEP mode back; not a problem since I wouldn't use it anyway but suspicious that it is grey'd out.

My SW update info: V4.0 (1.17.50)

I wish there was a way to submit a bug report directly to TMC rather than just posting to various forums.