Forums

Phone app takes a long time to wake up

Phone app takes a long time to wake up

(forgive me if this has been addressed before but I see no way to search the forums for previous topics).

I've got a Pixel 2 and often the Tesla app takes forever (like more than a couple of minutes) to "wake up." That's rather inconvenient when all I want to do is open the charge port or check the miles charged instead of unlocking the entire car. Is this a problem for anyone else, and is there some way to get the app to be more responsive?

wildblue | July 30, 2018

required

qqaaplz | July 30, 2018

I did not measure how long it takes for mine (Android) to wake up because I always manually press the "unlock" button. What interesting is, the trunk reacts really fast, whenever I stop by and open it, it opens, and then I walk to the driver's door and push the handle in, it does not react, and the app is still either waking up or updating, then I just press the "unlock" button then everything works.

I should have tried to open the trunk with my phone left far away from the car to see if the trunk is actually locked.

qqaaplz | July 30, 2018

Just tried with phone far away. All doors locked including trunk.

Good.

ron369 | July 30, 2018

I have an iPhoneX, and the wake-up time varies. Sometimes it is almost instant, and sometimes it can take over a minute. Just tried it now, and it took 8 seconds.

Does your phone always take a long time to wake up? Where is your car parked when it takes a long time? My car seems to wake up faster when it is at home and connected to WiFi, but seems to take longer when I am away from home and on LTE (which maybe is a function of bad LTE service where I'm parked?).

Chris35 | July 30, 2018

Tesla should either offer a keyfob or improve the performance. If Tesla or someone else on here says “it’s your phone” then that’s even more of a reason to offer a keyfob. The credit card key is a PITA sometimes.

wildblue | July 30, 2018

Ron, the slow wakeup time is a regular occurrence when it's been awhile since the app was opened, and it's usually when I'm home and only 10-20 feet away from the car. Hadn't thought about spotty LTE, which might be an issue here.

ron369 | July 30, 2018

The LTE could be the problem. The unlocking function is over bluetooth with the phone directly communicating with the car, and does not rely on a cellular connection. But the app does not talk directly to the car, and requires that the car is connected via LTE. If you had no cellular service, then the app would not work at all (even though the phone would still be able to lock / unlock the car).

sroh | July 30, 2018

Good call @ron369. That explains it for me. The LTE connection in our garage is ok, but not great. That would explain why it's slow to connect.

mattmannino65 | July 30, 2018

I have an older iPhone 5s and it only takes a few seconds to wake car up. I do have long delays when using the Summon function, even if I'm just a few feet away from the car. Frequently, the Summon connection just fails and I start over. Any suggestions? (Maybe new thread for Summon connection needed)

roger.klurfeld | July 30, 2018

I have a Pixel XL running Android 8.1. Wake up timing is very variable. The LTE service doesn't seem to matter because my car is now hook into my home internet. In addition, sometimes my car refuses to open even though my phone is right next to the door. Even when the app says the phone key is connected. Turning on airport mode and then off seems to work then. Very frustrating.

Atoms | July 30, 2018

Tesla has a server problem as far as I can tell. There is a large distribution in response times from the app from seconds to hours. It depends upon time of day. I suspect their loading on the server is variable.
My hope would be that they have a simulator going all the time checking the connection/wake up time of a dummy “car” and text someone when it exceeds a threshold.
Maybe Tesla just needs to scale up their server but this is not occurring as fast as they are delivering cars.
One can only guess what is going on at Tesla. The results show room for improvement.

xabbi | January 23, 2019

I have iPhone X and wake up time is usually about 8 to 10 seconds. There has been a significant improvement since 22-Jan-2019...about 1 to 2 seconds. I updated my phone to iOS 12.1.3 . I don't know if this was Apple's problem all along or did tesla make any improvements recently or both?

ahmedh | January 23, 2019

Noticed the same thing today. Updated to 2018.50.6 4ec03ed last night and app now connects within seconds. Haven't updated to iOS 12.1.3 yet so I think Tesla fixed something.

ILoveMyModel3 | January 23, 2019

I have this same issue when I'm at home, and the car is connected to my home wifi (100Mbps.) Therefore, is not an LTE connection issue.

rmlee | January 23, 2019

New update fixed the problem for me...