Forums

[Resolved] "Maps not loaded" alert since update 2018.32.2

[Resolved] "Maps not loaded" alert since update 2018.32.2

Hi,

More than a week ago, my 2014 Model S received update 2018.32.2 (third update; got updates 3 days in a row).
After getting the update installed, my navigation system got unusable ("Maps not loaded") error.

I've brought the car to my service center, they confirmed the issue and tried manually pulling the maps from their systems to the car (the whole process took 1 hour). It did not fix the issue and my navigation system is still unavailable.

Is this a known issue, that may be fixed in next firmware updates? I see a 2018.32.4 on https://ev-fw.com/track-reports.php that appeared a few days ago.

I'm planning a long roadtrip on 10th Sept., I just don't want to use my iPhone's navigation system as a fallback.

Cheers,

Valerian.

NKYTA | September 3, 2018

That’s a new, crappy, issue. :-/

txakoli | September 3, 2018

I installed 2018.32.2 on 9/1 on my 2014 S. I used the nav the next day without any map alert issues.

Valerian Saliou | September 3, 2018

@txakoli did you get a daily update 3 days in a row? (3 updates over 3 days) That's what happened to me. Maybe it somewhat confused the maps updater system.

txakoli | September 3, 2018

@Val,

No. My last update was 2018.28.1, installed on 9-Aug-18. There was an update a few months back that included an extensive map update. It could have been 2018.16, but I'm not sure.

EVRider | September 3, 2018

@Valerian: Which firmware version did you have before the 3 updates?

Valerian Saliou | September 3, 2018

@EVRider I don't know. But it got lastly updated in the beginning of August, without any issue. Looks similar to @ txakoli update flow; I got the extensive map update around June/July.

Valerian Saliou | September 3, 2018

So, firmware was up-to-date before that "broken update" if that's what's behind the question. I did apply all updates when available, and did have 2 updates from June to beginning August, that went fine. They were well-spaced (multiple weeks between the 2 I got).

Valerian Saliou | September 30, 2018

My issue has been resolved by my local Service Center. They forced a maps download remotely and asked me to ensure the car was connected to a WiFi hotspot w/ good connectivity.

Also, I had to disable "Energy Saving" mode that seemed to disconnect the car from the WiFi after a while (a few minutes / hours?) and seemed to prevent any maps update.

Upon Service Center forced maps download (remotely), I've seen almost 6GB of data being download. Then, 1 day after the download happened, the alert disappeared from the car and navigation system was back up again (seems that maps extraction can take a lot of time).

No hardware issue, it was all software + patience. That may help anyone w/ a similar issue in the future.

pssarah304 | November 19, 2019

Dear all, I have the same issue.

After update, the screen pop up "navigation unavailable, incorrect navigation maps are loaded".

I just received my new model.3 yrs, really sad. Can I fixed this issue by myself?

EVRider | November 19, 2019

@pssarah304: Are you connected to WiFi? Did you try rebooting? Which version did you update to?

pssarah304 | November 19, 2019

thanks EVRider for your prompt reply.

I ve checked the navigation data: CN 2019.24-10522

I remember that I ve connected to WIFI during downloading the updates but then left the car thereafter. Dont know if it interrupted the updates (power off?!) . So frustrated.

Reboot? you mean pressing the two scroll dials at the same time to wait the console reboot? Yes, and actually I tried factory reset the console as well but it didnt help.

EVRider | November 19, 2019

@pssarah304: I meant which software update version did you get? Yes, I meant rebooting with the scroll wheels as you described.

If the car has access to WiFi where you park it doesn't matter if the car is on or off. The car will be notified via cellular that an update is available, and will then connect to WiFi and download the update.

The error message you reported is a bit unusual, so it's not just a case of not having the latest map update. Is that interfering at all with your ability to use navigation? If not, just give it time -- maybe it will get resolved automatically.

pssarah304 | November 19, 2019

My software version is 2019.36.2.1.

The GPS signal seems working but no navigation available at all. The system has a exclamation mark on top which tell me "service required" as navigation is unavailable due to iincorrect navigation maps are loaded.

Lucky that at least I have GPS signal. srrhhhhhh.

EVRider | November 20, 2019

I suggest using the app to request a service appointment to update the maps, and in the description explain the problem and make sure you say that nav is disabled. Chances are they can fix it by pushing an update to your car.

failito | January 8, 2020

I had this problem back in November 2019 and once I connected the car to wifi the new navigation maps downloaded, apparently they will not download OTA due to their large size. I thought I was set but yesterday I got the same error again but this time the navigation maps didn't download even while connected to wifi and it doesn't even show that the map needs to be downloaded. It shows and up to date on the software screen so it doesn't look like anything needs to download and maps are just not working. I tried rebooting the MCU but error (red circle with exclaimation mark) still is there on top left of screen and maps aren't working. I will schedule a service visit but it will have to be at the service center in case they need to manually push the maps to the car, and I was told by last mobile tech that it can only be done at a service center because the car will not enter service mode outside of the service center geo fence. I'll report back when I have them look at the car.

murphyS90D | January 9, 2020

My car currently has no maps loaded and is not trying to download them. A service appointment has been scheduled. The car is in my garage with a WiFi access point about 10 feet from the right mirror. The map disappeared at least 4 days ago. A reboot had no effect.