USB files loading error

USB files loading error

Since the last update all my USB music files come up "loading error". Now what ?

spatters805 | April 2, 2019

Happens to me too. Music that played fine before now has loading errors. These are standard mp3 files and I tried to play song I had played successfully many times before.

Why o why can’t this basic technology work in the Tesla. Between the inability to have both skip forward and chapter forward for podcasts, the inability to navigate through large playlists in Slacker without swiping up and down the screen (distraction), and a lack of a reliable, basic compressed audio player in the car, I feel a backslide coming.

We’re all used to the convenience, performance, simplicity, and environmental benefits of a Tesla, but it won’t be long before “the others” catch up in those areas. If Tesla doesn’t bring the other features along, it will be surpassed by those who have already figured that basic tech out. I’m all for Tesla focusing on its product line, developing autopilot, and developing production, but they have also got to improve on the basics through updates.

I’ll take an audio player with reliable basic functions any day over fart noise gimmicks and cowbells! Please spend the R&D time more wisely!

Dadof5 | April 3, 2019

Are you using the USB stick for capturing dash cam video (with the TeslaCam directory). I figured out yesterday that this is an either/or situation. Lost access to my audio until I deleted the Teslacam file then it came back.

jamenendez01 | April 3, 2019

I’d like to share with you my experience with this.

The loading error issue has been around for a while and many of us have experienced it. Then sometime in January or February my app alerted me to an update so I thought, “cool, sentry mode”. The update installed but I noticed the release notes hadn’t changed and the version was still 2018 something or another.

So a few days pass and then I noticed all the settings (except for homelink) had been factory reset. Then about three weeks ago I noticed all my tagged favorites on my USB stick had been removed which meant I needed to go back and star those songs all over again; you can imagine how I felt as I was now blaming that phantom update. If you wonder why I hadn’t noticed it was because I had been listening to sports pidcasts and not music on my USB so I didn’t notice until later.

Anyway, a week and a half ago I was doing a 40 min+ drive so I figured it was a good time to start starting songs in the playlists. I was about 1/3 to 1/2 way through when I noticed something: not one loading error. Going on almost two weeks now not one loading error when I average 10+ errors a day before and I have haven’t changed the drive or files on it.

Could I be lucky? Maybe. However, but my gut tls me it had something to do with that phantom update.

EVRider | April 3, 2019

@judge: Which update did you get, and have you tried rebooting since the update? Remove the USB while you reboot.

I used to have loading errors, but they have disappeared in recent updates. I did see loading errors immediately after updating, but rebooting fixed them. | April 3, 2019

For software problems it's helpful to state what version you're on. I have 2019.8.1 from a few weeks ago, but I think they are now on 2019.9.x. It appears 2019.8.x and later correct the loading error issue with Apple sourced files.

I suspect EVRider nailed it - reboot first, as it often solves oddities like this.

EVRider | April 3, 2019

@TeslaTap: 2019.9.x, which has Enhanced Summon, is currently only going to people in the early access program (aka the "other" EAP :-).

judge | April 3, 2019

Thanks for everyone's responsive help. I'm not using the USB stick for any dash cam video--- only MP3 audio files. All 1900 files were copied from CD to hard drive and to 3GB stick using media monkey. All played without problem until my last upgrade 2018.50.6. Now each appears to get accessed properly, the graphic gets displayed but immediately comes up "loading error". | April 3, 2019

@judge - Odd - I had 2018.50.6 for about 6 weeks and no loading errors. I also have most of my library from CDs using Media Monkey to rip into FLAC. Also have some MP3s, also without issues.

1) Did you try a reboot (first removing USB drive during the reboot)?
2) I may be a corrupted software load, although I've not heard of that happening before. You may have to wait for the next software update, which should be arriving shortly (within 2 weeks?).

EVRider | April 4, 2019

@judge: Maybe the USB stick got corrupted. Check it on your computer, and even if it looks okay there, reformat and recreate it. Make sure you’re using a good quality USB stick, because some of them are crappy. | April 4, 2019

@ECRider - Excellent point! In fact quite a few are fake drives or factory rejects sold as new drives and may have far less capacity than stated or will not last long. Here's a write up I made on how to avoid bad drives:

spatters805 | April 7, 2019

For me, I have a 2017 MS75D with AP2 on software version 2019.8.3. I tried removing my USB stick and checking files in my computer. All files I checked were ok and songs that won’t load in my car have no issues loading in my computer to play. I also checked the drive itself for errors and it was fine...Same issues in the car. Reboot with no flas drive in didn’t make a difference for me. I can see the files, they index, but most won’t load to play (a few do):

Not a new USB stick and it is a reputable manufacturer, that worked fine up until a month ago. Remember, I checked the stick on my computer, so no data degradation or other integrity issues were found.

EVRider | April 7, 2019

@spatters805: In my previous 2016 Model S, the loading errors I encountered were intermittent and inconsistent, and a song that wouldn’t load one day might play without issues the next. It sounds like your files won’t play at all, which seems like a different problem. What kind of music files are you trying to play?

Loading errors were much less of an issue with my current Model S, and have pretty much disappeared with the recent updates. I still have playback issues when I first get in the car, where the music sometimes won’t resume, but even this has improved a lot in the latest updates.

judge | April 8, 2019

I have done several reboots and no change. I have duplicate sticks one for the tesla another in a Ford Explorer . Switched them and results the same... no go in tesla, explorer no problem .

spatters805 | April 9, 2019

@EVRider: I have mp3 files, and as a reminder, these files played without much difficulty before (never perfect, but biggest issue then was excessive load time, not the load errors I see universally now.

I just got 2019.8.5 this morning, so I will try again and see if anything is resolved.

Thanks for the advice.

paul | April 20, 2019

I waited until I was pretty sure it was resolved to say anything. I waited so long I forgot exactly when the ‘loading error’ problem disappeared. Now however, I’m pretty sure that on my Model S the problem has been resolved. It took years to fix but all is forgiven now. Thank you for fixing it.

memcd | April 29, 2019

Just got 2018.50.6 last week. My Model S is 6 years old (young?) and I've loaded over 3,400 songs on my USB and now 90% of what I get is "loading error." Tesla's suggestion is to make an appointment at a Service Center. Can't imagine that will help much. My love affair with Tesla is slowly ending but it was a good 6 years.

EVRider | April 29, 2019

@memcd: I wouldn’t bother with the service appointment— there’s nothing they can do. I don’t remember which update started to improve the loading errors, but it’s also possible you have a bad USB stick. Try using a different one and see it that helps. If not, you might have better luck when you receive one of the 2019.x updates.

spatters805 | April 30, 2019

So far 2019 updates don’t solve the issue. My USB stick works perfectly in every other device I tested since this issue popped up. It’s not the stick.

Why is this even an issue? Tesla is a technology company with one of the most advanced processing units on Earth yet they can’t seem to get MP3 player right?? Aside from not being able to play mp3’s In general, the GUI is poor and hasn’t advanced over the years.

EVRider | April 30, 2019

@spatters805: The GUI hasn’t advanced over the years? That’s BS, and you know it.

spatters805 | April 30, 2019

@EVRider, I have had my MS75D for 2 years now and the GUI for mp3 management is the same now as it was then. Of course the general GUI has changed. That’s not was is being discussed here. Doesn’t matter, because the usb reader doesn’t work.

Why on Earth would you have a driver go through endless swipes for long playlists or albums on the USB (or LiveXLive/Slacker or TuneIn for that matter) where you can separate into page views or index better? No song scrubber on music played through connected phones? Hope they address sometime. | April 30, 2019

Well... in about 99% of the case of Loading errors, the songs were sourced from Apple's non-DRM files (Apple DRM files will never work). All other sources (rips, Amazon downloads, etc.) work fine. I did some work trying to find out what Apple does differently (and I'm not blaming Apple), but didn't see anything obvious in the meta data. I did find that taking Apple format files and converting to MP3 eliminated loading errors in the tests I ran.

EVRider | April 30, 2019

@spatters805: Sorry, I misread your comment to be about the UI in general, not the Media Player UI specifically. While that has changed too, I agree it hasn’t improved much.

@TeslaTap: I don’t think the file format is the culprit for many people having this issue. I say this because when I had frequent loading errors, converting my Apple files to FLAC made absolutely no difference. And, when the problem started to go away, especially in my new MS, I was using exactly the same USB that was causing problems before. The only time I see loading errors now is occasionally immediate after a software update, but a reboot or two fixes it. I still have issues with USB playback not resuming automatically in many cases, but no loading errors or other issues once playback starts, which is a big improvement over the frequent loading errors I used to get.

spatters805 | May 1, 2019

@EVRider and @TeslaTap, I wish I could say it is an Apple DRM issue. However, about 80% of my mp3’s were ripped from original CD’s. Some Apple Music songs were converted to mp3 over time, but those played without a problem until recently. I have rebooted about 5-6 times since my last update.

My only problem up to this recent issue was the frequent “reload” of the USB stick and excessively long load times (as well as the poor GUI) for that function. I doubt taking it to the SC will fix the issue, but it seems like a little investment to improve USB and phone connectivity and enhance the user interface would go a long way to enhance the multimedia functionality of the car, especially if they have no interest in Android Auto or Apple CarPlay. Imagine a long drive through an area with poor cellular coverage. | May 1, 2019

Likely there are multiple issues - Apple content seemed to be the most common, but perhaps masked something else. EVRider - good to know your experiences.

Another thought is the USB drive itself. I've tried dog slow and very fast drives without a problem, but perhaps there is another factor we don't understand yet. Still if you have a few different drives handy, worth a try.

EVRider | May 1, 2019

@TeslaTap: Because of the non-deterministic nature of the loading error issue (when it's not caused by file formats or USB quality), I've always thought it was related to multi-threading or resource conflict issues in the code. Another symptom that supports that theory is the fact that when a loading error occurs, other sounds (including turn signals) temporarily stop working while the Media Player tries to load the file.

spatters805 | May 1, 2019

I just installed 2019.12.1.1 and the issue is still there. Rebooted and also re loaded the sandisk thumb drive. Works flawlessly on my pc or anything else I put the drive in. I might try a few more drives. Wish this would resolve itself.

BlueRadish | May 1, 2019

I can't speak to the loading errors. But my contact at local service center tells me the USB always re-loading problem has been fixed in v9.2019.16.x, I'm still at .12. I sure hope it's really fixed in .16, because I've tried way too many USB drives to count.

EVRider | May 2, 2019

@BlueRadish: I also had the issue where the USB reloaded almost every time I got in the car, but that was mostly fixed for me when I got 2019.8.x (don’t remember if it was 8.3 or 8.5 that improved things). Since then, the reload happens once in a while, but infrequently.

spatters805 | May 2, 2019

I think my USB reloading issues resolved a couple updates ago. It did completely reload on it's own with this more recent update, but I figured that was normal.

Anybody know what the latest update is? I am hoping there is some sort of resolution in one of those. | May 2, 2019

@spatters - Most of us are getting v12.1 or v12.1.1 now.

EVRider | May 2, 2019

According to, 2019.12.1.2 just started coming out. Some people on the Model 3 forum reported that 2019.12.1.1 was recalled due to bugs, but it looks like Tesla is still pushing that version to lots of cars. Neither of our cars has been on 12.1.1 long enough to experience any new bugs.

gdelgado | May 3, 2019

Once you load music from a flash drive, whatever was there as far as album art or order will stay in the car forever, even if you change it on the flash drive it will still show the original you loaded

EVRider | May 3, 2019

@gdelgado: How do you know that? | May 3, 2019

@gdelgado - I think that was partly true in v8, as long as you didn't reboot. I'm fairly sure with V9 cover art is only scanned when needed and is no longer pre-scanned and saved.

spatters805 | May 5, 2019

I am going to try a few more things and see if it makes a difference, but my point in my posts is that I feel this is something that should be figured out already and significant groups of people shouldn’t be complaining about their mp3’s not loading from their USB sticks (especially when they did before).

Again, as a tech company who apparently develops their own software, cleaning up and improving the functionality should not be this difficult. Making Easter eggs and adding TeslAtari games are great dog and pony show tricks, but i’d Much rather they focus on continually improving the stuff we already have.

spatters805 | May 5, 2019

I am going to try a few more things and see if it makes a difference, but my point in my posts is that I feel this is something that should be figured out already and significant groups of people shouldn’t be complaining about their mp3’s not loading from their USB sticks (especially when they did before).

Again, as a tech company who apparently develops their own software, cleaning up and improving the functionality should not be this difficult. Making Easter eggs and adding TeslAtari games are great dog and pony show tricks, but i’d Much rather they focus on continually improving the stuff we already have. | May 5, 2019

@spatters - What makes it difficult is the wide range of USB drives - from fakes and counterfeits that are truly awful, to just the slow and cheap drives. Some drives may also be infected with viruses or other nasties that impact operation (although the Tesla is resistant to such viruses, things like boot records can stop Tesla's boot process). Then there is the files, which come from a wide range of sources.

Yes, we do wish Tesla would look into it more, but it is far from a simple to solve issue. There appears a very large group of owners without problems, but enough with problems that it would be nice to know what the issue is.

judge | May 14, 2019

V19.1.1 was downloaded to my P100DL last night and the loading error I still present, change

EVRider | May 15, 2019

@judge: There’s no 19.1.1 yet. Did you mean 16.1.1?

the.hulk | May 15, 2019

I'm on 2019.12.1.1 and my USB music is now no longer sorted alphabetically. The folder view is still alphabetical, but the songs within each folder is in a totally random order. For some folders, I added 01, 02, 03, prefixes to enforce proper sorting, but not for all folders. The ones with prefixes still sort fine, but not the ones without the prefix.

Anybody else notice this?

Chunky Jr. | May 15, 2019

IMHO, Tesla should either make this a really good user experience, or kill the feature. Right now it is so half baked and buggy that it is a negative experience. | May 15, 2019

@the.hulk - Just confirmed that using Files now uses the track tags to sort the songs within an album (12.1.2) where it used to be alphabetical. So working the way it should now, instead of the old alpha sort via title method. | May 15, 2019

@Chunky Jr. - What feature are you talking about? Are you suggesting they remove USB music altogether because a few owners have problems? Seems drastic.

EVRider | May 15, 2019

@Chunky Jr: USB music works well enough for many owners, so there's no reason to ruin it for everyone.

judge | May 15, 2019

Sorry . version is 2019.12.1.1

judge | May 15, 2019

Every file results in the graphic being displayed and then "loading error" and then everything suspended . ..... it use to work nice..too bad Tesla programmers

judge | May 15, 2019


judge | May 15, 2019

Suck | May 15, 2019

@judge - While I'm sure Tesla can improve, before you blame Tesla or the software, have you considered it may be your flash drive, or the files on the flash drive and nothing to do with Tesla software?

There are a lot of fake flash drives in the market that look good on a PC, but most the files are trashed and not really readable. Another issue is what file format or source of the files. For example, Apple DRM files are never going to work. Even regular Apple files seem to have problems for some owners, which I suspect is a Tesla problem. Using FLAC seems to be the best, with MP3s 2nd best for reliability.

judge | May 15, 2019

I have two identical sticks, identicalLyn programed with mp3 files made from CD. Both sticks play perfectly in my Ford Explorer and my wife's Lexus 460. Both sticks fail in the Model S