Forums

A long road trip with extensive sentry mode ruined USB drive

A long road trip with extensive sentry mode ruined USB drive

Just got back from a long road trip and every night I turned on Sentry mode. After 3 or 4 nights my 32GB USB drive must have filled up because when I got home and tried to see the files on the USB drive it was totally corrupted.

Could not open it on Windows PC. Got error message saying drive could not be accessed. So I couldn't scan it, format it, nothing. Up until the trip it had been working fine.

So what must I do in the future:
1. Wait until new software allows managing the USB drives from inside the car?
2. Take along a PC and check the USB drive every day and clean it up if it gets full?
3. Use a 256GB USB drive?

Also does anyone know how to rescue a USB drive that Windows can't access?

jimglas | April 22, 2019

Get a SSD and dont worry about it filling up?

Magic 8 Ball | April 22, 2019

USB drives vary in quality.
A high quality drive will not corrupt files even when it fill up.

lbowroom | April 22, 2019

Your conclusion that the car ruined the drive isn't necessarily the correct conclusion.

hamiltonned | April 22, 2019

@lbowroom: Let's hear your theories.

jdcollins5 | April 22, 2019

Have you tried to repair the USB? Every time I read mine I get a read error on my Windows 10 PC. After a quick repair scan it works fine.

sheldon.mike1010 | April 22, 2019

#lbowroom Nothing else could account for my USB drive failure.
It was new and formatted FAT32 with TeslaCam folder.
Was a high end 256GB Sandisk (genuine from Amazon) that Sentry just destroyed after 1 month.
It can't be accessed from any computer so no repair scan is possible.
Fortunately, Sandisk has a lifetime warranty and immediately replied to my RMA request.

EVRider | April 22, 2019

Did you pause the dashcam and wait 20-30 seconds before removing the USB? If not, that’s why the drive is corrupted.

bj | April 22, 2019

A lot of USB drives are crap and die after only a few read/writes. Buy good quality ones - it does make a difference.

Atoms | April 22, 2019

Make sure you stop recording before disconnecting. Get an SSD drive which can handle power downs with out corruption. Use a SSD which is robust to continuous writing. Samsung 883 DCT Series - 480GB and StarTech.com 2.5" External Hard drive enclosure Supports UASP - Aluminum - USB 3.1 Enclosure - SSD/HDD. Had to find freeware to partition and format the drive but works well and should last a long time without failure.

Tesla should offset a pre-formatted SSD drive for this purpose that you can buy and plugin with no effort on their website.

TeslaEdison | April 23, 2019

high endurance SD card is the answer. Flash memories has limits on number of writes. Teslatap has an excellent write-up on this topic. https://teslatap.com/articles/usb-flash-drives-for-tesla-dashcam/

TeslaEdison | April 23, 2019

one of my low quality Lexar USB drive got ruined also.

derotam | April 23, 2019

Lots of non-genuine "genuine" crap on Amazon. Buyer beware. Maybe you just got a dud too.

Techy James | April 23, 2019

If your using Sentry Cam, it will likely fill up a 32GB USB drive in a few days. I upgraded to 128GB Drives and can usually get about 2 weeks before I need to replace the drive due to being full.
Just remember before removing the USB stick, make sure you press the DashCam Icon and wait the for the system to clear the dot in icon before removing the USB Drive. Another issue that can lead to corrupted data, is if the USB drive can't handle write speeds. I look for USB Drives with Read/Write Speeds => 100 MB Sec.
The reason drives are being filled up when you have Sentry Mode enabled, is it writes the data every time an event triggers the sentry mode and unlike the data from the Dash Cam mode, it doesn't auto erase after hour loop.
I also recommend the Micro SD designed for Action Cams over a USB Stick, these Memory cards are designed for Multiple Rewrites and will typically last longer than an USB Drive. You will be doing a lot of erasing and rewriting no matter which option you use. I typically scan a few random Sentry Camera recordings, sometimes it's funny to watch the little kids that seem to be attracted to nice cars like Tesla.

Kary993 | April 23, 2019

I have a 512 GB SSD, never worry about it and checked it recently and it is only about 175 GB used. Each day at work in parking garage cars and people are buzzing by and it is recording constantly, can see the battery drain at times though very small.

RedPillSucks | April 23, 2019

@Techy James I tried a 64G microSD card plugged into a USB adaptor and the car couldn't read it.
I got a grey x on the camera icon. The card came preformatted as FAT32, and I did create a TeslaCam folder.
Not sure what else I need to do to make it work. As an FYI, I've got a 64G Flash USB stick that works fine.

gmr6415 | April 23, 2019

200GB Connect Wireless drive here. https://www.sandisk.com/home/mobile-device-storage/connect-wireless-stick

It has a relatively slow write speed but so far I haven't had any issues. I can connect to it with my phone and erase old files while sitting in the car. You do have to unplug it from the USB port first, but I find it very handy.

If you needed you can also bring up the video on your phone on the spot.

RedPillSucks | April 23, 2019

@gmr6415, so you need WIFI to be available before you can connect from your phone, right (like be in your garage, or parked where wifi is available)

LostInTx | April 23, 2019

Quality is key. My Samsung 256G has been plugged in since March 18. Just checked and it's exactly half full. I have Sentry on everywhere except in the garage at night. No issues.

LostInTx | April 23, 2019

an ancillary question: How do they determine the time stamp on when creating directories on the USB?

The video time stamp is correct but the directory time stamp on the USB, when viewed in Windows Explorer, is several hours off. It's actually 4 hours ahead of my current time. Anyone else seen this?

SteveWin1 | April 23, 2019

@RedPillSucks, what's the write speed of your microSD card? I use a 64GB SanDisk Extreme and its worked flawlessly for months. $27 on Amazon.

TeslaTap.com | April 23, 2019

@TeslaEdison - Thanks for the call out!

@hamiltonned - I believe the most common "drive destruction" is cause by pulling the drive while writing. This is bad on any computer too, except in most cases, no writes are occuring when you pull the drive from a PC. In the Tesla (or a dashcam) a massive amount of data is being written to the drive. When you pull the drive without turning off video recording, it might luck out and only corrupt one file, but it is as likely to corrupt the FAT (file allocation table), which is fixable with a format. The problem is as power is lost during the write, it may write anywhere in the drive, and there are key areas that will destroy the drive. For example, there is a permanent write protect flag. If this gets written - game over, the drive is toast. There are other areas used as a map to replace bad sectors - overwriting this area is really bad too. There is not much drive manufacturers can do about powering down the drive while writing. Best not to pull the drive without disabling writes first.

miyoboo4 | May 12, 2019

My model 3 has bricked two 16 GB USB Flash drives is just two weeks. Somehow, the flash drives become unreadable/unusable after using TeslaCam. Somehow, the car is corrupting them. They will not reformat, they are totally useless.

Tropopause | May 12, 2019

I went on a 5,000 mile roadtrip, used Sentry Mode every night for three weeks and another couple of weeks after I got home. My 256 Gb stick was only 45% full and still going. Took me two days to go through all the saved threats and highlights from our journey. No problems here.

tibor.blomhall | May 13, 2019

I have the same issue. So far has my Model 3 destroyed 5 USB memories. Noname, expensive brand doesn't matter, after a week or two it gets destroyed. The camera icon disappears from the Tesla screen (not crossed out or anything, the entire icon disappears like there was no USB memory connected at all). The USB memory stick is HOT to touch when I remove it. When connected to PC it is recognized as USB memory with FAT32 format but the size is 0 bytes and it cannot be scanned for errors nor formated as PC complains it cannot access the drive.

jithesh | May 13, 2019

I had bad experience with Sandisk, patriot, etc even on PCs. Then I moved MicroCenter drives and found them to be very reliable. + they are much cheaper compared to these big brands. I am using MicroCenter USB drive on my Model 3 from many months now and had no issues. I would definitely recommend to give MicroCenter a try if you have a store nearby.

jball | May 13, 2019

You might want to try a different card reader as well - I had the camera go away, removed the micro SD with 0 bytes, Erase on a Mac failed, put it in a different card reader and was able to format. I'm going to try a different reader in the car to see if that was the problem.

jforbes77 | May 13, 2019

I am getting a different issue, since the latest update. If i use sentry mode when sentry mode stops , the dash cam wont work until I format the usb. Anyone else have this issue?

TeslaTap.com | May 13, 2019

ANSWER TO DESTROYED DRIVES

Ok, you have to stop video recording before pulling the drive. Consider that Tesla is writing a massive amount of data to the drive in multiple areas of the drive (three video streams). When you pull the dive without stopping the recording, as power drops some writes will occur anywhere on the drive - including critical areas. Very easy to trash a drive this way, even on a PC or MAC. The difference is, most owners are not writing to the drive when they pull it from a PC or MAC - so no apparent problem. There is nothing Tesla can do in software to fix this user error.

In some cases, a format may recover the drive, but often it becomes read only or destroys other critical areas and the drive is a goner. Some specific drives and manufacturers might be less sensitive to these failure modes, but cost and performance is no indicator of sensitivity failure when to pulling the drive while writing.

@jforbes77 - Get a larger drive. The issue is Sentry mode fills up the drive and when it becomes full, it stops all recording. You can remove the drive (after stopping recording) and either erase or format the drive every month or so (with a 128 GB drive). Smaller drives require more frequent format/erasures.

I wrote a detailed guide to selecting, formatting and troubleshooting here: https://teslatap.com/articles/usb-flash-drives-for-tesla-dashcam/

TeslaTap.com | May 13, 2019

@hamiltonned - You might change your misleading title. User error cause the drive to be damaged. Nothing to do with Sentry mode or dashcam recording. See my notes above.

jforbes77 | May 13, 2019

@TeslaTap.com both times it happened my drive was not even half full, it only started to happen when i got the latest update. It works fine until I use Sentry mode, when i come back to the car and drive the dash cam is not on. Almost as if I dont have a usb in

TeslaTap.com | May 13, 2019

@jforbes77 - sounds like a different issue. Any chance the drive is a counterfeit or fake drive? There are a ton being sold on eBay, and even Amazon has been getting hit with these drives. Usually the drive appears to have the full space, but are a fraction of the size stated. When you write beyond the real memory, it seems to work but is really just ignoring the writes, or worse, overwriting other areas of the drive.

Depending on what versions you updated from, Tesla may be writing more data than before, which could fill the drive faster and/or get to an area of the drive that is bad or doesn't exist.

tibor.blomhall | May 13, 2019

@TeslaTap.com please understand that the reason is NOT us "removing the USB memory wrong". I didn't even attempt to remove it at all. However after a week or two the camera symbol on the car's screen suddenly disappears. Even though the memory is still there. After a couple of days I realize the icon is missing THEN I remove the USB memory. At that time you cannot stop the camera recording as there is no camera icon to press.

legna_fo_htaed | May 13, 2019

I have had constant issues with my files being corrupt. That includes holding the dash cam button for a couple seconds until it turns grey. Not sure what i'm doing wrong. Brand new 128 GIG flash drive that has been properly formatted to FAT32.

Syed.Hosain | May 13, 2019

After my USB stick fills up, I still see the icon, except that it has a small gray 'x' in it. When I pull out the stick, the icon entirely disappears, of course.

tibor.blomhall | May 13, 2019

@Syed.Hosain my camera icon disappears ENTIRELY. No gray, no x the camera icon completely disappears.

Syed.Hosain | May 13, 2019

@tibor.blomhall "my camera icon disappears ENTIRELY. No gray, no x the camera icon completely disappears."

Yeah, that is indeed unusual.

Have you tried another USB stick? The first one I had was not fast enough for three cameras to be recorded without corruption. My current is not great either, but it does the job for now.

Am looking to see if the Sandisk postable 500 GB SSD does a good job - it is small and quite nice! Someone here posted a link to it on Amazon.

tibor.blomhall | May 13, 2019

So far I have tried with 5 different USB memories, different brands. My Model 3 destroyed each one after a week or two. Today I bought one that works well for two other owners - if this one dies too I will know that this is a hardware issue. Will see in a couple of weeks time.

rxlawdude | May 13, 2019

@LostInTx file timestamps are Coordinated Universal Time (aka, GMT).

sheldon.mike1010 | May 13, 2019

#TeslaTap:
My thumb drive failure had nothing to do with removal method. I inserted it after shutting the car off in Settings.
After several weeks of normal commutes and occasional use of Sentry, the icon disappeared. I removed it with car Off same as when inserted. The drive was not visible on home computers. Sandisk replaced it free under warranty.
Got the 250GB Sandisk Extreme SSD mentioned above by Syed. Works grrreat.

jestrada3 | May 28, 2019

Add me to the list of people having issues with sentry mode and the icon completely disappearing. I've used sentry mode for about 2 months since I got my model 3 and just yesterday I had 1 sentry event and a camera icon which had disappeared. I got home and took it to my PC which recognized it immediately and erased all the saved files as I figured the drive was getting full and causing the issue. Plugged the USB drive back into the car and all was well and the camera icon reappeared.

Today I get to work and turn sentry mode on, get back to the car at lunch, again 1 sentry event reported and the camera icon has again disappeared. The USB drive is hot to the touch and the light on the drive is flashing off and on as if it is trying to read the data.

I am running a Sandisk 32GB USB 3.0 thumbdrive, which has not given me any problems in the past. Something is definitely going on here. I am on software 2019.12.1.2

jestrada3 | May 28, 2019

Something else I'm curious to know, is of the people having issues with their USB sticks, how many of you are connecting your USB stick to a splitter and how many of you are connecting directly into the USB port? I am using a splitter since I have a Nomad wireless charging pad, so maybe that is causing an issue?

Iwantmy3 | May 28, 2019

I removed mine yesterday to check ot and clean it out. When I pulled it out it was hot. I can imagine that a poor quality stick could overheat.

I am on my second stick. My first one bricked when I pulled it out without stopping the recording

jestrada3 | May 28, 2019

Looks like mine just bricked as my PC and multiple laptops no longer recognize it. What is a high quality USB stick? I actually misspoke and I have a WD Easystore USB stick which was bundled with an external HD I bought, so this isn't some Amazon knockoff. I also don't want to spend money on a "Premium" stick, when that not be the issue at all and I throw money down the toilet for no reason. Is their a rating Tesla requires for these sticks?