Model S Android App

Model S Android App

Just downloaded the Tesla mobile app for Android. All I need now is my S.

Superliner | February 1, 2013


Well who was driving your car down NY Ave. before you got it??
I downloaded the app but got the "not so long" dreaded "no vin" etc. associated with this account. lol!! Indeed!! From what I've heard here and a few screen shots / video on the TMC Suddenly my nearly new Lincoln ICE seems like the Fred's Flintmobile!

tvntesla | February 1, 2013


Schlermie | February 1, 2013

For those who wanted a way to remotely open the charge port, you can also do that from the mobile app.

mkh1437 | February 1, 2013

@Schlermie where is that option? I didn't see it on the charge screen. Maybe it only appears if you are not charging, though.

Getting Amped Again | February 1, 2013

I was told the app would precondition both the cabin and the battery, and there seems to be nothing about the battery currently. Could someone please try preheating their cabin on a cold day and see if regen is immediately available?

Also, are the menus any different for a non-charging vehicle?

Thanks much!

Schlermie | February 1, 2013

It's on the Charge screen. There's a button in the top-right corner that says "OPEN CHARGE PORT". I'm not charging right now, and my charge port is closed.

Schlermie | February 1, 2013

When I open the charge port, the button changes to "UNLOCK CHARGE PORT" and there's a message that says something to the effect of "Plug in charge cable to begin charging".

Jewsh | February 1, 2013

F'in great. I don't even have my car yet but I loaded it anyways. :-)

Schlermie | February 1, 2013

It has a good 10-15s response time. I guess that's to be expected though. It's not like a TV remote. Even if you're standing right next to the car, the signal is traveling for miles and miles, through several exchanges and protocols before it ever hits the car. | February 1, 2013

For the location - the blinking blue dot is where the phone thinks it is located. At first it was several blocks off, until I realized the phone's own GPS was off.

The Red arrow, like the car, shows the cars location and was dead on.

mkh1437 | February 1, 2013

Slightly disappointed that there are no options for setting charge time. That has been promised since the beginning. But... this is a great start! Now, if only the iOS app would be released!

sandman | February 1, 2013

Just a friendly reminder review common password blunders if you are using this app now. If you are like me and setup your Tesla account forever ago and there was very little reason to protect it, then you may have a fairly hackable account. Well, now there is a reason to protect it.

Especially if you've posted your email address here or over at TMC.

Pbfoot | February 1, 2013

I don't have an Android phone so I downloaded Bluestacks, but can't seem to find it. I logged into my Google account, then used the 'Search' function in Bluestacks (in upper right hand corner) and typed in 'Tesla Model S'. All I get is a clock and compass function in the search results. Appreciate any help in determing what I'm not doing correctly...

Schlermie | February 1, 2013

I'm not sure if this link will work for you, but try this...

It's not on the Amazon App Store for Android yet.

mbcaffe | February 1, 2013

in the location screen, anybody know the functionof the blue square button and the car button to the left side of "map view" and directions"

djp | February 1, 2013

try "Tesla Model S Beta"

Schlermie | February 1, 2013

The blue square button with the target on it will center the map at your mobile device (blue dot) location. The blue square with the car on it will center the map at your car (red arrow) location.

Pbfoot | February 1, 2013

@Schlermie: thanks, I downloaded it and it now says 'installed', but doesn't show up in bluestacks. Still trying...

mkh1437 | February 1, 2013

There is a post over on the TMC forums which explains how to install the Tesla app on Bluestacks. You have to install the Google Play app first, then login with your Google account, then download and install the Model S app.

djp | February 1, 2013

Saw screenshots of the app. Does the MS on the screen match your MS? Color, wheels, roof?

Pbfoot | February 1, 2013

Got it. Thanks! For anyone else who wants to know(thanks to user dmizock):

Search for "Google Play." Then download "Movies & TV," enter your Google account information, then use Google Play to search for "Tesla Model S." Install, and log into your MY Tesla account!

mbcaffe | February 1, 2013


Schlermie | February 1, 2013

Yes, the image of the car on the app is color-coded and semi-wheel-coded to match the color and wheels of your car. The wheels on the app are correctly identified as the 21" wheels, but the app shows silver wheels and the wheels on my car are grey.

Schlermie | February 1, 2013

The roof is also correct, and it shows whether the roof is open or closed.

Dave-LasVegas | February 1, 2013

How frustrating! I have an unlocked Android tablet, but the Tesla app appears to be restricted US-only, and for some unknown reason Google Play thinks my table is in some country other than the US. I have no idea where, it won't tell me. This isn't the first time I've run into this issue.

I didn't want to root the %&$# thing, but maybe I'll have to now...

John-V707 | February 1, 2013

Can someone post a link to the APK itself? I want to try it on a Kindle Fire HD but need teh APK to sideload.

mkh1437 | February 1, 2013

Someone mentioned that there was a 10-15 second delay. I'm not seeing that. When I press the Honk Horn button on the app, I can hear my horn beep within 1 second. I'm running the app on Bluestacks from my Windows PC, and my car is in the garage. Not that location or platform should matter... it still has to go out over the Internet and over 3G to the car. But I was impressed by the near-immediate response time.

Superliner | February 1, 2013

Amazing!! Every other remote access to any car on the planet has been rendered obsolete in a single day. My current car seems like i'm a caveman rolling on a stone wheeled cart! and just got an opportunity to drive George Jetson's daily ride!!

This changes EVERYTHING!! Most all other manufacturers are years behind this kind of capability as far as a driver user interface.

Thank you Elon / Tesla team!!

Sudre_ | February 1, 2013

Is there a place to report on bugs besides this forum? I hate bug reporting in the apps comment area.

I tried to install it on my Acer 10" tablet and it reports I do not have enough memory. I have around 26 gig free.

On my Samsung Galaxy S 7" Tablet and I am not able to log in. There is no response from the app no matter where I tap on the logon screen.

I installed it on my Samsung Galaxy II phone and it works but remote access is not on. The car is at the shipping phase.

Schlermie | February 1, 2013

Agreed. I think the first button-push only SEEMED like 10 seconds since it wasn't immediate. It's really more like 2 seconds worst-case and 1 second typical.

DouglasR | February 1, 2013

I closed Bluestacks, and when I reopened it a while later, my Model S was still connected (there was a message: "Are you still there?. App has been inactive . . .").

I'm not familiar with Android. How do you close out of an app? Just hit the "Back" or "Home" button?

DickB | February 1, 2013

To close the app go to the home page then click the on the account at the top right and sign out. You will have to sign back in once you sign out.

Thumper | February 1, 2013

Installed easily and works close to flawlessly on a Droid Maxx. Only glitch I can discern is the location page knows where the car is and exactly what direction it is pointed, but thinks I am several blocks away even though I am with the car.

Thumper | February 1, 2013

To make the app as strong of a theft deterrent as possible, we need password protection on the car screen for toggle on/off of the phone app access. If a thief can just turn the phone app off from the car, it would make it impossible for the owner to track them. | February 1, 2013

Sudre_ "I tried to install it on my Acer 10" tablet and it reports I do not have enough memory. I have around 26 gig free."

The amount of free storage memory is actually not relevant. Each Android device manufacturer decides on the amount of RAM memory to allocate to each app, anywhere from 12 MB (very rare, old stuff), to about 128 MB (also rare - latest hi-res tablets). For example most tablets provide at least 64 MB (but some quite a bit less). As the displays get larger (in resolution and size) the app is typically forced to use more memory.

I suspect the Acer being 10" and higher-res, forces the app to require more memory than it is given - causing the out of memory error. These are really painful for the app developer to fix, and often you just give up on the 1% that have the poor luck not to allocate enough memory to do what's needed. You as the device owner have no control on RAM allocation.

The big guys (who have close to infinite resources) can spend lots of time testing and tweaking to get around some of these limitations, but I don't see Tesla in this category, especially for a free app.

Schlermie | February 1, 2013

You can Back out of it to close it without signing out. Hitting Home won't close it though. It will just continue running in the background.

buckeyevet | February 1, 2013

This app has already helped me! I am RN 5431 and have been told my VIN has been coming for over a week but that my vehicle was in the final stages of manufacturing. I have emailed several times and have been told my VIN has not been assigned despite adelivery window of 2/1-2/15. I downloaded this app and entered my password and found that a VIN has already been assigned! 47XX. I am going to have to email my delivery specialist and ask whats up! Thanks jcoles3800 for posting this! BTW it says that remote acess is not activated yet. Wonder if that means that it is still being built?

jbunn | February 1, 2013


My car came with the remote access off when I received it two days ago (before the release). You may not be able to monitor it until you take delivery and enable remote access.

Sudre_ | February 1, 2013

Got the app on my Acer tablet. Just had to move a few things onto the external SD card. It has the same problem as my Samsung Tablet, I get no response at the log in screen. Has anyone got the app to work on a tablet? It seems to only work on my phone. The app runs fine on my laptop with bluestacks.

Now I just need to get the guy in the truck to turn on the remote access.

strengthcoach4 | February 1, 2013

So I can see the app in Bluestack when I search for it, but when I hit install it doesn't show up under Google MarketPlace. Anyone else have that issue? | February 1, 2013

downloaded to my droid2-- easy link to account & car. Cool :o)

DouglasR | February 1, 2013


Someone further up in this thread posted the solution. You need to first install Google Play, and then search for it within that app. But read his instructions.

Steve P5664 | February 2, 2013

Anyone know if you can move an app icon onto the wheel that comes up when you first turn on the phone.I'm talking about the circle that offers camera, text,,phone, and unlock
I n this way u get to the app in 2 buttons...on and app
I get to texting this way all day long
I'd love to have direct access t the tesla app .


wbrown01 | February 2, 2013

The app appears to work great, but the climate controls keeps turning off and says the cabin is still at 37 degree, but it is set to 73. The app keeps also showing its working on something. I have 4G and that is working. This is the best feature, it needs to work. I want a warm car before I unplug in the morning.........

Shelmire | February 2, 2013

Whoaaaaaaaa! i just downloaded the app and not only did it know my VIN # (which was assigned two days ago)but it is trying to connect to my car, WHICH IS STILL ON THE ASSEMBLY LINE. This is just getting weird!

dirk.saenen | February 2, 2013

@Steve P5664

May depend on the rom your using, but the apps on the start-screen are the same as on the lower part of the 'normal'-screens.
This part is customizable (as any other screen). Just keep pressing the app-icon you want to remove, and swipe it to 'remove'area on top of the screen.
Then you can add any app-icon you like.

good luck.

jchangyy | February 2, 2013

needs some help...downloaded tesla app using bluestack and I was able to get to the sign in page, but email and password input fields are grayed out. can't input anything. please help. thanks.

jchangyy | February 2, 2013 it work after playing with keyboard settings. very finicky program. interesting soon as I type in my username and password, I get a message: no vehicle associated with my account....mine's really NOT ready and my delivery window started already...

Brad Holt | February 2, 2013

I spoke with a rep yesterday who said the iOS app should be here any day now. I'm expecting delivery on Thursday, and he said the app release should coincide with my delivery. EEEE!

Leofingal | February 2, 2013

I spoke to someone at Tesla, and I think they are not enabling the app on the vehicle until the local delivery. I do think this would be a great feature, but I understand that in the case something awful happened (like the truck got into an accident) they might want to manage that information delivery... Anyhow, my car should be somewhere between Freemont and Queens. Perhaps the folks that saw the location of their vehicle on the line have seen it before they disabled the location feature in settings!