Forums

Navigate on Autopilot disappeared from my car

Navigate on Autopilot disappeared from my car

I purchased FSD about 3 weeks and since then I have been using Navigate on Autopilot daily. As late as this morning, I used it. This afternoon on my way back home, I first noticed that on the map it no longer showed the option. I thought maybe it was due to the location I started the route and NoA was not available. I tried a couple of times on the highway by changing the destination, it still did not show. After I got home, I reset the screen, again no help. Then I checked the AutoPilot setting, I noticed the option "Navigate on AutoPilot" no longer exists as if I did not purchase the option.

Does anyone else have the Navigate on Autopilot gone?

DermMD | April 11, 2019

Same here

Mwoosley71 | April 11, 2019

I have noticed that the “Navigate on AutoPilot” is grayed out if you haven’t selected it before initiating the drive, but the option has never disappeared altogether.

RoadDevil | April 11, 2019

Mine came back after the recent software update 2019.8.5.

Czardmitri | April 11, 2019

Mine disappeared yesterday afternoon along with cruise control. Did a reset and then a hard reset. Still missing. Drive most of way home without it. Picked up daughter at school, still gone. Drove home, went in house briefly. When I got back in car a few minutes later NOA and cruise control were back. Weird.

johnmagyar | April 20, 2019

Mine disappeared yesterday. Soft reset and hard reset multiple times - didn’t help. Support told me to schedule service, so I set an appointment. Today, it’s all back. Canceled service appointment.

louiselouis1 | May 4, 2019

Same happened to me this morning. No more nav on auto. Also the app doesn’t display the summon or sentry option. Any insight is appreciated

raffidesigns | May 4, 2019

I have noticed this as well. I believe this is a way for Tesla to weed out owners with FSD and those with just autopilot. Similar to the premium connectivity. After a year it disappear until you pay monthly.

Or maybe I’m wrong and our cars are glitching out.

EVRider | May 4, 2019

@raffidesigns: Yes, you're wrong. :-) The people who are temporarily losing navigate on autopilot already paid for it. No one with the new basic AP ever had navigate on autopilot or Summon.

louiselouis1 | May 4, 2019

I just find it interesting that the free 14 day trial had it on the car and app as of yesterday. That’s why I opted for the upgrade to AP. in addition the sentry is gone and i haven’t checked dog mode yet. I know the games are still there. And sentry and basic summon was on the regular update and working until I purchased AP.

In a business environment we would call that false advertisement.

Thx again for ur responses

louiselouis1 | May 4, 2019

Just read the Tesla info about the trial. They mention the trial was for FSD and the upgrade was for AP. pretty sneaky in my book. Always helps to read something before a purchase.

Still does not explain summon and sentry. Still ha e 2019.12.1.2 showing and that was working in 12.1.1.

Davindersekhon | May 5, 2019

I am having the same issue. Was told by the service centre that map update need to happen via WiFi but it is still haven’t kicked in after 4 days. Scheduled an appointment to get it fixed.

Howieshagen | May 17, 2019

Davindersekhon, did you get it fixed? My autopilot disappeared after 2019.16. Just made an appt with the service center. Did they help you?

danwassink | May 19, 2019

I had the same issue - no cruise, cameras, or autopilot. I tried resetting and powering off numerous times. Didn’t fix it. I talked to Tesla, they couldn’t fix it. They wanted me to schedule a service appt. I then went and did some research and I read in a forum that the car does diagnostics upon waking up from a sleep. If it finds anything wrong, it shuts everything down. So the key is to let it sleep and when it wakes up, it will do another diagnostic run and, if all is OK, everything will be back. This is what I did and my cameras, cruise, and Autopilot came back. Why wasn’t it able to sleep in the first place? I had a few third-party apps connected to my car. This kept my car awake. I looked at the log files and it has been days, if not weeks, since she slept. So I needed to disconnect all the apps and start over. To do this, I just changed my password to Tesla. Once I did this, all the 3rd-party apps were disconnected. Now I needed wait a few hours so my car could go to sleep, I waited overnight. When I went back to my car the next morning, everything was working once again. I had a 10 hour drive back home, I was glad to see it all back! Now I can’t say this is for sure this is what fixed it, but I tried everything, including resetting and powering off. Nothing worked, until I changed the password. Could be coincidence, but if you are having the same issue, give it a shot, change your Tesla password, let it sleep for a few hours. It may work for you too.

Marvelones | June 1, 2019

I had the same issue since I received the car in May. Talked with the programming team and it turns out the issue is related to Sentry Mode. They know about the issue and have been working on it. Now it is an issue with the current 16.2 update as well. They had me disable the sentry mode, remove the flash drive and allow the car to sleep.Letting the car sleep will temporarily fix the issue but if you don't disable the sentry mode and remove the flash drive it will just keep re-occurring. This restored everything for me. Now I just have to wait until the fix is available. They say they are close.

markr7 | June 1, 2019

Try this:
Posted elsewhere on this forum...

FULL POWER CYCLE

1. Make sure you vehicle is not plugged in or charging, make sure the vehicle stays parked, make sure the doors are closed, make sure the windows are up, keep your feet off the brake and acceleration, and try not to move around in your seat too much.

2. Hold in the scroll wheels on the steering wheel until the screens go blank and then release.

3. When the MCU reboots, select controls, safety and security, power the vehicle off.

4. Wait for 3 full minutes. (if the vehicle powers itself on during this time, double check that all the conditions from step 1 are met and start again).

5. Power the vehicle back by opening and closing the door.

bcmusik | July 9, 2019

Wow, having the same issue. I'm on 20.4.2.
Navigate on Auto Pilot no longer shows up but all the options/settings are still available in the menu and even summons still works. I'll wait until tomorrow and see what's up, Tesla must be doing something and it'll sort itself out.

bcmusik | July 13, 2019

It came back the next day just slightly different. Navigate on autopilot used to show up no matter what nav destination I chose (somewhere down the street or somewhere that required getting on the freeway). Now it just shows up if a freeway is part of the navigation. No Freeway then no option to navigate on autopilot.

EVRider | July 14, 2019

@bcmusik: I think Navigate on Autopilot has been like that for a while. Which firmware version did you have before the update?

UL8 | July 14, 2019

It seems like it is my turn now,- Navigate On Autopilot option disappear from my model 3, Like I would never even bought it. I am on 2019.20.4.2
Multiple restarts (removed usb) didn’t help. My Tesla Model 3 account shows FSD option is available for purchase! Sent message to Tesla support and waiting for their explanation.

EVRider | July 15, 2019

@UL8: Did you read the previous replies?

UL8 | July 15, 2019

Yes, but it doesn’t explain why this is so random happens. I tried to disable Sentry mode and remove USB, reboot it multiple times without much help. So, I’ve been waiting for model technician come to my house and take a look at it.

ccq | September 17, 2019

This happened to me last night - no autopilot, etc. I had just upgraded to FSD on my new Model 3 about 12 hours prior, and there also might have been a software update. That said, I followed the full power off procedure that markr7 posted above and it worked like a charm. All set now.

chiragp1987 | December 24, 2019

I have model 3 2020 but did not purchase FSD. Will I still get the navigate on autopilot option ??? Can somebody tell me?

1089 | December 24, 2019

No, you will not. You have Autpilot, but only for lane keeping, with manual lane changes, and TACC.

stingray.don | December 24, 2019

chiragp1987 | December 24, 2019
I have model 3 2020 but did not purchase FSD. Will I still get the navigate on autopilot option ??? Can somebody tell me?
___________________________

No, but you can still get it by purchasing FSD.

Alec-MS | January 5, 2020

I have the same issue - both options (Summon, NoA) just disappeared from the menu after upgrade from V10.0 (2019.32.12) to V10.1 (2019.40.2.1). Call to Tesla CS yield nothing, scheduled the service appointment.

EVRider | January 5, 2020

@blinetsky: Did you purchase Enhanced Autopilot or FSD?

GrumpyinAZ | January 5, 2020

I see mine is back with V 2019.40.5.1 as of 12/30/2019

john.schreiber8 | January 11, 2020

This is an important chain. I bought in October of 2018 and had autopilot and summon from the beginning. I lost it December if 2019 suddenly and received an email saying it is now offered for $3000. I scheduled service who said oh yeah you already have it we will restore it with a mobile visit since restart didn’t work. Then they canceled the appointment saying they can’t restore it since they don’t see that I paid for it. I bumped it up to the advanced team but have not heard yet. No where does it say when I got autopilot that it is a one year trial. I think it is not appropriate to take away functions I have used for a year and ask for more money. Is this even legal?

Magic 8 Ball | January 11, 2020

An important "chain" well then. So they gave you a free year of something you did not pay for and you now want it free forever. I think it is inappropriate to expect free stuff.

lbowroom | January 11, 2020

John, where did it say you get EAP for free when you declined to buy it originally? Clearly you bought an inventory car which had it pre loaded for demos and you said no thank you to paying for it. You gambled, enjoyed it for a year, and now lost.

ReD eXiLe ms us | January 11, 2020

Magic 8 Ball: But... doesn't 'stolen' equal 'free forever'...? ;-)

Magic 8 Ball | January 11, 2020

Sadly, for some:

● It is decidedly so.

Of course forever is a very long time so...

john.schreiber8 | January 22, 2020

Ouch this is a tough crowd. I think you are right. Back in 18 my car ordered didn’t sow up and they got me another one which had autopilot. Honestly, I assumed what I got came with the car and unlimited premium which I bought. I guess it would have been nice to get an email saying have fun because you didn’t pay for this and it goes away someday. That said, Tesla may in fact restore it since it came with the vehicle. Stay tuned I’ll let you know.

doigtsdhonneur | February 19, 2020

Any update on whether you were able to get it back or not?

montaque | March 4, 2020

I got the same issue. the visualization disappeared suddenly today, it was there since day 1. any hints to fix it?

EVRider | March 4, 2020

@montaque: It's always advisable to try rebooting before you even post the question here. If you've already done that, check your Controls > Autopilot settings and make sure FSD Visualization Preview is still enabled.

j.garnica | March 4, 2020

I've had my model 3 since Dec 2019, and I've been using enhanced Cruise Control and Auto Steer almost daily. Turned on Sentry Mode on Friday Feb 28th and continued using Auto Steer. Used Auto Steer on Sunday March 1st. Charged to 90% overnight. Next morning (Monday) on my way to the airport, no Auto Steer or Cruise control available. I dropped by the Van Nuys, California Service Center and a tech was kind enough to verify that both were not working. He did a hard reset, but no effect. Made a service appointment for March 5th.

In the meantime, I get home later that night and read about this problem and find that turning off the sentry mode appears to fix the problem, so I do that and PRESTO! Everything works again! Obviously a software bug.

I got a text from a tech about an hour ago (today is Wednesday, March 4th) and he verified that everything is back to normal. I asked about a software fix, and he replied, "Firmware version 2020.8 has some improvement for this issue." I cancelled the service appt since there's no need now.