TeslaCam grayed out when no USB stick present

TeslaCam grayed out when no USB stick present

2018 March Model X 100D with v9.0 2019.16.2 The TeslaCam icon appears on the top bar with a grayed out X, whether or not there is actually a USB stick inserted. I had thought that if there was no stick, or a stick with no TeslaCam folder, there would be no icon... Further, if I DO insert a USB stick, with or without the requisite folder, there is no change. Any ideas?

mikah_no | June 1, 2019

2018 October Model X 75D. v.9 2019.16.2.

I have the same problem. Before the update the DashCam worked beautifully. After the update, I have a nifty Sentry icon that records when I touch it but have lost the DashCam ability. Reformatted the USB, restarted the car, reset the screen (press and hold the scroll buttons) - nothing works. I even tried a micro-USB reader instead of a USB thumb drive. The DashCam icon is still grayed out with an X on it.

I hope someone figures out a solution soon. I miss the DashCam.

jjgunn | June 2, 2019

In the future, before performing a firmware update long press the TeslaCam -- wait about 60 seconds then remove USB -- THEN perform update.

Sounds like the USB got hosed. Try a new USB formatted correctly with FAT32 or MacOS FAT (same thing). | June 2, 2019

The new Sentry mode icon is now available even when no USB drive is inserted (and in park). This is because it will still work, but will not record to the USB if the USB is not present. This allows it to work in HW2.0 cars that don't have any dashcam ability. When you drive, you should see the dashcam icon only when the USB drive is inserted. No security icon should appear while driving.

mikah_no | June 2, 2019

Took a 2 hour road trip with the DashCam grayed out. Got to our destination, put Blanche in Park, got ready to exit the car and then lo and behold, the DashCam started working again. That was 12 hours ago and the DashCam is still working! Weird but yay for me!

mikah_no | June 3, 2019

Nevermind. It grayed out again. Reformatted the USB, powered down the car and reset using the scroll buttons. Still not working. It’s so weird. Still missing the DashCam function.

jjgunn | June 4, 2019

It seems 2019.16.3.2 is being pushed out. Perhaps the updated firmware can help

eveningsun | June 6, 2019

Same for me, called service, they are looking into this and working on another update

mikah_no | June 10, 2019

I did a factory reset on the car and got DashCam back. It's been a day and a half and it's still working. So if all else fails, try a factory reset.

eveningsun | June 11, 2019

Just got the new software update .20.1 and dash cam worked, not even a reboot was required (no other release notes or updates notices) but I'm happy:)